summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-07-25 13:42:05 -0300
committerDaniel Bermond2022-07-25 13:42:05 -0300
commit0be887ce450296e333bf97fd7473222466d06f0e (patch)
tree2b14f09634f200cbc35ae1c4cc5767e3e6680c6a
parent505771822fc5e3a747c88d680e2014a02a6a40cb (diff)
downloadaur-0be887ce450296e333bf97fd7473222466d06f0e.tar.gz
Match latest upstream changes
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d3d9639ca43..fdf27401e4e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vosk-api-git
pkgdesc = Offline speech recognition toolkit (git version)
- pkgver = 0.3.42.r0.gb1b216d
+ pkgver = 0.3.43.r1.gf63b015
pkgrel = 1
url = https://alphacephei.com/vosk/
arch = x86_64
@@ -18,6 +18,7 @@ pkgbase = vosk-api-git
makedepends = python-setuptools
makedepends = python-srt
makedepends = python-tqdm
+ makedepends = python-websockets
makedepends = python-wheel
noextract = vosk-model-small-en-us-0.15.zip
source = git+https://github.com/alphacep/vosk-api.git
@@ -48,6 +49,7 @@ pkgname = python-vosk-git
depends = python-requests
depends = python-srt
depends = python-tqdm
- depends = vosk-api-git=0.3.42.r0.gb1b216d
+ depends = python-websockets
+ depends = vosk-api-git=0.3.43.r1.gf63b015
provides = python-vosk
conflicts = python-vosk
diff --git a/PKGBUILD b/PKGBUILD
index 5bc104ca187a..93a4e2a53ebb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=vosk-api-git
pkgname=('vosk-api-git' 'python-vosk-git')
-pkgver=0.3.42.r0.gb1b216d
+pkgver=0.3.43.r1.gf63b015
pkgrel=1
_model_small_ver=0.15
_model_spk_ver=0.4
@@ -11,7 +11,8 @@ arch=('x86_64')
url='https://alphacephei.com/vosk/'
license=('Apache')
makedepends=('git' 'cmake' 'gradle' 'python' 'python-build' 'python-cffi' 'python-installer'
- 'python-requests' 'python-setuptools' 'python-srt' 'python-tqdm' 'python-wheel')
+ 'python-requests' 'python-setuptools' 'python-srt' 'python-tqdm' 'python-websockets'
+ 'python-wheel')
checkdepends=('ffmpeg' 'python-numpy')
source=('git+https://github.com/alphacep/vosk-api.git'
'git+https://github.com/xianyi/OpenBLAS.git'
@@ -113,12 +114,11 @@ build() {
check() {
local _test
- local -x VOSK_MODEL_PATH="${srcdir}/models"
cd vosk-api/python/example
for _test in alternatives empty ffmpeg nlsml reset simple speaker srt text words
do
printf '%s\n' "Running test_${_test}..."
- PYTHONPATH="${PWD}/../build/lib" python "./test_${_test}.py" test.wav
+ PYTHONPATH="${PWD}/../build/lib" VOSK_MODEL_PATH="${srcdir}/models" python "./test_${_test}.py" test.wav
done
}
@@ -139,14 +139,14 @@ package_vosk-api-git() {
package_python-vosk-git() {
pkgdesc='Python module for vosk-api (git version)'
- depends=('python' 'python-cffi' 'python-requests' 'python-srt' 'python-tqdm' "vosk-api-git=${pkgver}")
+ depends=('python' 'python-cffi' 'python-requests' 'python-srt' 'python-tqdm' 'python-websockets'
+ "vosk-api-git=${pkgver}")
provides=('python-vosk')
conflicts=('python-vosk')
local _pyver
_pyver="$(python -c 'import sys; print("%s.%s" %sys.version_info[0:2])')"
- cd vosk-api/python
- python -m installer --destdir="$pkgdir" dist/*.whl
+ python -m installer --destdir="$pkgdir" vosk-api/python/dist/*.whl
rm "${pkgdir}/usr/lib/python${_pyver}/site-packages/vosk/libvosk.so"
ln -s ../../../libvosk.so "${pkgdir}/usr/lib/python${_pyver}/site-packages/vosk/libvosk.so"
}