summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Yantis2016-06-16 14:15:38 -0700
committerJonathan Yantis2016-06-16 14:15:38 -0700
commit1c250b29f52d708328b5ced3787cc341d44c4319 (patch)
tree34a67e9461a45a3c92a50b37c884ce51534fc933
parent1271be77dad0ffdeb7ac50680c1b9b5e35692bc3 (diff)
downloadaur-1c250b29f52d708328b5ced3787cc341d44c4319.tar.gz
PKGBUILD
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44022974cd27..27e8512c8351 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Thu Jun 16 21:15:38 UTC 2016
pkgbase = vowpal_wabbit
pkgdesc = Vowpal Wabbit is a machine learning system which pushes the frontier of ML with techniques such as online, hashing, allreduce, reductions, learning2search, active, and interactive learning. Includes extra utilities.
- pkgver = 7.10
+ pkgver = 8.1.1
pkgrel = 1
url = https://github.com/JohnLangford/vowpal_wabbit
arch = i686
@@ -11,8 +13,8 @@ pkgbase = vowpal_wabbit
provides = vowpal-wabbit-git
conflicts = vowpal-wabbit
conflicts = vowpal-wabbit-git
- source = https://github.com/JohnLangford/vowpal_wabbit/archive/7.10.tar.gz
- sha256sums = 8d9aeddd9a5b7d73264fe28264f05f2a2b6a8fa38f65b02081c6e40460604c36
+ source = https://github.com/JohnLangford/vowpal_wabbit/archive/8.1.1.tar.gz
+ sha256sums = 174609bb09eaeac150c08639a82713a2290442a42bc0b23d53943e9a0f22911b
pkgname = vowpal_wabbit
diff --git a/PKGBUILD b/PKGBUILD
index c67ab2cc2f7d..4a2221d7fff8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer: jyantis <yantis@yantis.net>
# Contributor: Sid Karunaratne <sid at karunaratne dot net>
+# Contributor: xF0E
# Note: There is also a git version of this package build called
-# vowpal-wabbit-git that has python 2 support
+# vowpal-wabbit-git that has python 2 support and much more up to date
pkgname=vowpal_wabbit
-pkgver=7.10
+pkgver=8.1.1
pkgrel=1
pkgdesc="Vowpal Wabbit is a machine learning system which pushes the frontier of ML with techniques such as online, hashing, allreduce, reductions, learning2search, active, and interactive learning. Includes extra utilities."
arch=(i686 x86_64)
@@ -13,7 +14,7 @@ url='https://github.com/JohnLangford/vowpal_wabbit'
license=('custom')
depends=('boost')
source=("https://github.com/JohnLangford/vowpal_wabbit/archive/${pkgver}.tar.gz")
-sha256sums=("8d9aeddd9a5b7d73264fe28264f05f2a2b6a8fa38f65b02081c6e40460604c36")
+sha256sums=("174609bb09eaeac150c08639a82713a2290442a42bc0b23d53943e9a0f22911b")
provides=('vowpal-wabbit' 'vowpal-wabbit-git')
conflicts=('vowpal-wabbit' 'vowpal-wabbit-git')
@@ -34,7 +35,7 @@ package() {
install -D -m644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
# Install all the utilities
- mkdir -p $pkgdir/usr/bin/
+ mkdir -p "$pkgdir/usr/bin/"
install -D -m755 utl/logistic "$pkgdir/usr/bin/logistic"
install -D -m755 utl/vw-convergence "$pkgdir/usr/bin/vw-convergence"
install -D -m755 utl/vw-csv2bin "$pkgdir/usr/bin/vw-csv2bin"
@@ -44,7 +45,7 @@ package() {
install -D -m755 utl/vw-varinfo "$pkgdir/usr/bin/vw-varinfo"
install -D -m755 utl/vw2csv "$pkgdir/usr/bin/vw2csv"
- make DESTDIR=${pkgdir} install
+ make DESTDIR="${pkgdir}" install
}
# vim:set ts=2 sw=2 et: