summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarrison2023-03-18 16:42:29 -0400
committerHarrison2023-03-18 16:52:03 -0400
commit158e75bf00fa980b141df680089e201379fd724b (patch)
tree2d8394c24e197c3c238c240a3f28c459cced24b3
downloadaur-158e75bf00fa980b141df680089e201379fd724b.tar.gz
Upload files
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD59
-rw-r--r--vox-exec5
-rw-r--r--voxatron.desktop8
4 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..35e65d905413
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = voxatron-hib
+ pkgdesc = fantasy console and collection of games made entirely out of voxels
+ pkgver = 0.3.6
+ pkgrel = 1
+ url = http://www.lexaloffle.com/voxatron.php
+ arch = i686
+ arch = x86_64
+ groups = humblevoxatronbundle
+ groups = games
+ license = custom: "commercial"
+ depends = libgl
+ depends = sdl
+ optdepends = alsa-lib: sound support
+ optdepends = libpulse: sound support
+ options = !strip
+ source_i686 = hib://voxatron_0.3.6_amd64.zip
+ source_i686 = voxatron.desktop
+ source_i686 = vox-exec
+ md5sums_i686 = 381d91f5314f9f74859a3f7f28e24407
+ md5sums_i686 = 184c021b52d3a9c8ac5f49435b4b93e0
+ md5sums_i686 = bb84f6fcd7cdb18eb417173a6f58e00e
+ source_x86_64 = hib://voxatron_0.3.6_amd64.zip
+ source_x86_64 = voxatron.desktop
+ source_x86_64 = vox-exec
+ md5sums_x86_64 = 381d91f5314f9f74859a3f7f28e24407
+ md5sums_x86_64 = 184c021b52d3a9c8ac5f49435b4b93e0
+ md5sums_x86_64 = bb84f6fcd7cdb18eb417173a6f58e00e
+
+pkgname = voxatron-hib
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a119fa9362db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Contributor: Marcel Pfeiffer <pfeiffer.marcel at gmx dot de>
+# Contributor: Zachary A. Jones <JazzplayerL9@gmail.com>
+# Contributor: Jose Riha <jose1711 gmail com>
+# Maintainer: Harrison <htv04rules at gmail com>
+
+_pkgname=voxatron
+pkgname=${_pkgname}-hib
+pkgver=0.3.6
+pkgrel=1
+pkgdesc="fantasy console and collection of games made entirely out of voxels"
+url="http://www.lexaloffle.com/voxatron.php"
+license=('custom: "commercial"')
+groups=('humblevoxatronbundle' 'games')
+arch=('i686' 'x86_64')
+depends=('libgl' 'sdl')
+optdepends=('alsa-lib: sound support' 'libpulse: sound support')
+case $CARCH in
+ i686)
+ _gamepkg="${_pkgname}_${pkgver}_i386.zip"
+ ;;
+ x86_64)
+ _gamepkg="${_pkgname}_${pkgver}_amd64.zip"
+ ;;
+esac
+options=(!strip)
+
+source_i686=("hib://${_gamepkg}"
+ "${_pkgname}.desktop"
+ "vox-exec")
+
+source_x86_64=("hib://${_gamepkg}"
+ "${_pkgname}.desktop"
+ "vox-exec")
+
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Manually download it to \"$(pwd)\", or set up a hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+
+package(){
+ cd "${srcdir}"
+
+ install -d "${pkgdir}/opt/${_pkgname}"
+ cp -R "${srcdir}"/${_pkgname}/* "${pkgdir}/opt/${_pkgname}/"
+
+ # create Launcher
+ install -d "${pkgdir}/usr/bin/"
+ install -D -m755 "${srcdir}/vox-exec" "${pkgdir}/usr/bin/${_pkgname}"
+ # Install Desktop File and Icon
+ install -D -m644 "${srcdir}/${_pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+ install -D -m644 "${pkgdir}/opt/${_pkgname}/lexaloffle-vox.png" \
+ "${pkgdir}/usr/share/icons/${_pkgname}-icon.png"
+ # Install license
+ install -Dm 644 "${pkgdir}"/opt/${_pkgname}/license.txt "${pkgdir}"/usr/share/licenses/${_pkgname}/license
+}
+md5sums_i686=('381d91f5314f9f74859a3f7f28e24407'
+ '184c021b52d3a9c8ac5f49435b4b93e0'
+ 'bb84f6fcd7cdb18eb417173a6f58e00e')
+md5sums_x86_64=('381d91f5314f9f74859a3f7f28e24407'
+ '184c021b52d3a9c8ac5f49435b4b93e0'
+ 'bb84f6fcd7cdb18eb417173a6f58e00e')
diff --git a/vox-exec b/vox-exec
new file mode 100644
index 000000000000..81077d5737fa
--- /dev/null
+++ b/vox-exec
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+export LD_LIBRARY_PATH=/opt/voxatron/
+/opt/voxatron/vox
+
diff --git a/voxatron.desktop b/voxatron.desktop
new file mode 100644
index 000000000000..c77a0db4c82b
--- /dev/null
+++ b/voxatron.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Categories=Game;ActionGame;AdventureGame;
+Exec=/usr/bin/voxatron
+Icon=voxatron-icon
+Terminal=false
+Type=Application
+Name=Voxatron
+Comment=Action/adventure game set in a fully destructible world made of voxels.