summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDamien Flament2017-08-26 09:11:27 +0200
committerDamien Flament2017-08-26 10:22:29 +0200
commit77f6d27e6d33bb1f373774ee5c749f6412dced82 (patch)
treee69626df8d17b89b5bda8fa2738097f8317b4e84
parent609047617a772ce6aeec8283a624498277c3d5de (diff)
downloadaur-77f6d27e6d33bb1f373774ee5c749f6412dced82.tar.gz
Moved script generation within the prepare() function
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
-rwxr-xr-xvoxelshop6
3 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 727ded623fb9..344fa82a708e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = voxelshop
pkgdesc = An extremely intuitive and powerful cross-platform software to modify and create voxel objects which was designed from the ground up in close collaboration with artists.
pkgver = 1.8.02
- pkgrel = 2
+ pkgrel = 3
url = http://blackflux.com/node/11
arch = any
license = Apache
@@ -9,7 +9,7 @@ pkgbase = voxelshop
depends = bash
source = voxelshop
source = https://github.com/simlu/voxelshop/releases/download/1.8.02/VoxelShop-java-all-os-fast.zip
- sha256sums = 69ff1076bf585855c81862b06bf50bd67621ac435d0c0f4a2ac3d19aa31317aa
+ sha256sums = 849a498d505f7e817c529d5b538f94c82aeaf45a8d75786dcf9651adf3d1d645
sha256sums = 86c1fd50ef32b17be92df37d6a5c2206e456d99bc7abe4da80a44f49d2a377d3
pkgname = voxelshop
diff --git a/PKGBUILD b/PKGBUILD
index 9186651d1ea4..d77664833a7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=voxelshop
_pkgname_upper=VoxelShop
pkgver=1.8.02
-pkgrel=2
+pkgrel=3
pkgdesc='An extremely intuitive and powerful cross-platform software to modify and create voxel objects which was designed from the ground up in close collaboration with artists.'
url=http://blackflux.com/node/11
license=('Apache')
@@ -21,20 +21,24 @@ changelog=
source=('voxelshop'
"https://github.com/simlu/voxelshop/releases/download/${pkgver}/VoxelShop-java-all-os-fast.zip")
noextract=()
-sha256sums=('0158a4e52afc88c9d9c6341f50c237383e1781c18a25060c93989877e2f71aa7'
+sha256sums=('849a498d505f7e817c529d5b538f94c82aeaf45a8d75786dcf9651adf3d1d645'
'86c1fd50ef32b17be92df37d6a5c2206e456d99bc7abe4da80a44f49d2a377d3')
arch=('any')
+prepare() {
+ # Generate the startup script
+ cd "${srcdir}"
+ sed -i "s/{{pkgname}}/${pkgname}/g" "${pkgname}"
+}
+
package() {
# Install the distributed files in /opt
cd "${srcdir}/${_pkgname_upper}"
- install -Dm755 -t "${pkgdir}/opt/${pkgname}" data/*
-
- # Generate the startup script
+ install -Dm755 -t "${pkgdir}/usr/share/${pkgname}" data/*
+
+ # Install the custom startup script
cd "${srcdir}"
- sed -i "s/{{pkgname}}/${pkgname}/g" "${pkgname}"
-
install -D -t "${pkgdir}/usr/bin" "${pkgname}"
# Add a symlink to the startup script using the camel-cased package name
diff --git a/voxelshop b/voxelshop
index 13eaef068d9e..13d8b2c3fb9b 100755
--- a/voxelshop
+++ b/voxelshop
@@ -1,11 +1,11 @@
#!/bin/bash
-cd /opt/{{pkgname}}/
-declare -r DATA_DIR=${XDG_DATA_HOME:-"${HOME}/.local.share"}/{{pkgname}}
+cd /usr/share/{{pkgname}}/
+declare -r DATA_DIR=${XDG_DATA_HOME:-"${HOME}/.local/share"}/{{pkgname}}
# Update the Getdown configuration file
install -CDm644 -t "${DATA_DIR}" getdown.txt
# Start the application using Getdown
-java -jar getdown-client.jar "${DATA_DIR}"
+exec /usr/bin/java -jar getdown-client.jar "${DATA_DIR}"