summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDamien Flament2017-08-26 14:32:37 +0200
committerDamien Flament2017-08-26 14:39:55 +0200
commit8a6275ba21e408b87d342539b862913ce2c355e5 (patch)
tree402c88e122c0a0d6d00495cf2d4a0a22f65b985a
parent77f6d27e6d33bb1f373774ee5c749f6412dced82 (diff)
downloadaur-8a6275ba21e408b87d342539b862913ce2c355e5.tar.gz
Updated to version 1.8.11
- Java runtime 8 is the minimum version required, - GetDown is nomore used, - extract the sources archive manually to prevent filename conflict with the custom startup script, - add some packaging info messages.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD49
-rwxr-xr-xvoxelshop9
3 files changed, 38 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 344fa82a708e..52948b9fdc57 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = voxelshop
pkgdesc = An extremely intuitive and powerful cross-platform software to modify and create voxel objects which was designed from the ground up in close collaboration with artists.
- pkgver = 1.8.02
- pkgrel = 3
- url = http://blackflux.com/node/11
+ pkgver = 1.8.11
+ pkgrel = 1
+ url = https://blackflux.com/node/11
arch = any
license = Apache
- depends = java-runtime-common
+ depends = java-runtime=8
depends = bash
+ noextract = voxelshop-1.8.11.zip
source = voxelshop
- source = https://github.com/simlu/voxelshop/releases/download/1.8.02/VoxelShop-java-all-os-fast.zip
- sha256sums = 849a498d505f7e817c529d5b538f94c82aeaf45a8d75786dcf9651adf3d1d645
- sha256sums = 86c1fd50ef32b17be92df37d6a5c2206e456d99bc7abe4da80a44f49d2a377d3
+ source = voxelshop-1.8.11.zip::https://github.com/simlu/voxelshop/releases/download/1.8.11/voxelshop-bin.zip
+ sha256sums = 1f1535bd452294f1f8261bdd0432e0100e43f41650ff25aa67d92cf786be7df8
+ sha256sums = 913cc42e789f5914ab894ed6157be94bcedc5d5cb528481bf6e167b0e3d70354
pkgname = voxelshop
diff --git a/PKGBUILD b/PKGBUILD
index d77664833a7b..fe01ad945df6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,13 @@
# Maintainer: Andrew Dunai <andrew@dun.ai>
# Contributor: Damien Flament <damien.flament@gmx.com>
pkgname=voxelshop
-_pkgname_upper=VoxelShop
-pkgver=1.8.02
-pkgrel=3
+pkgver=1.8.11
+pkgrel=1
pkgdesc='An extremely intuitive and powerful cross-platform software to modify and create voxel objects which was designed from the ground up in close collaboration with artists.'
-url=http://blackflux.com/node/11
+url=https://blackflux.com/node/11
license=('Apache')
groups=()
-depends=('java-runtime-common' 'bash')
+depends=('java-runtime>=8' 'bash')
makedepends=()
optdepends=()
provides=()
@@ -18,30 +17,40 @@ backup=()
options=()
install=
changelog=
+_source_filename="${pkgname}-${pkgver}.zip"
source=('voxelshop'
- "https://github.com/simlu/voxelshop/releases/download/${pkgver}/VoxelShop-java-all-os-fast.zip")
-noextract=()
-sha256sums=('849a498d505f7e817c529d5b538f94c82aeaf45a8d75786dcf9651adf3d1d645'
- '86c1fd50ef32b17be92df37d6a5c2206e456d99bc7abe4da80a44f49d2a377d3')
+ "${_source_filename}::https://github.com/simlu/${pkgname}/releases/download/${pkgver}/${pkgname}-bin.zip")
+noextract=("${_source_filename}")
+sha256sums=('1f1535bd452294f1f8261bdd0432e0100e43f41650ff25aa67d92cf786be7df8'
+ '913cc42e789f5914ab894ed6157be94bcedc5d5cb528481bf6e167b0e3d70354')
arch=('any')
+
prepare() {
- # Generate the startup script
- cd "${srcdir}"
+ msg2 "Generating startup script..."
sed -i "s/{{pkgname}}/${pkgname}/g" "${pkgname}"
+
+ # Unzip the sources. This is usually done automatically by makepkg. But the
+ # extracted directory name conflicts with the startup script name.
+ msg2 "Extracting sources..."
+ if [[ ! -d "${pkgname}-${pkgver}" ]]
+ then
+ mkdir "${pkgname}-${pkgver}"
+ cd "${pkgname}-${pkgver}"
+ bsdtar -xkf "${srcdir}/${_source_filename}"
+ mv "${pkgname}"/* .
+ rmdir "${pkgname}"
+ fi
}
package() {
- # Install the distributed files in /opt
- cd "${srcdir}/${_pkgname_upper}"
-
- install -Dm755 -t "${pkgdir}/usr/share/${pkgname}" data/*
-
- # Install the custom startup script
- cd "${srcdir}"
+ msg2 "Installing startup script..."
install -D -t "${pkgdir}/usr/bin" "${pkgname}"
- # Add a symlink to the startup script using the camel-cased package name
- ln -s "${pkgname}" "${pkgdir}/usr/bin/${_pkgname_upper}"
+ msg2 "Installing the jars..."
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ install -Dm644 -t "${pkgdir}/usr/share/java/${pkgname}" "${pkgname}-start.jar"
+ install -Dm644 -t "${pkgdir}/usr/share/java/${pkgname}/lib" lib/*
}
diff --git a/voxelshop b/voxelshop
index 13d8b2c3fb9b..217ceadf25ef 100755
--- a/voxelshop
+++ b/voxelshop
@@ -1,11 +1,4 @@
#!/bin/bash
-cd /usr/share/{{pkgname}}/
-declare -r DATA_DIR=${XDG_DATA_HOME:-"${HOME}/.local/share"}/{{pkgname}}
-
-# Update the Getdown configuration file
-install -CDm644 -t "${DATA_DIR}" getdown.txt
-
-# Start the application using Getdown
-exec /usr/bin/java -jar getdown-client.jar "${DATA_DIR}"
+exec /usr/bin/java -jar /usr/share/java/{{pkgname}}/{{pkgname}}-start.jar