summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Repp2022-09-24 10:49:02 +0200
committerSimon Repp2022-09-24 11:01:22 +0200
commit8ba393630e1f068d0b31edafb578ea062dbca9b2 (patch)
treed5c673faed739dfd5f3432262fd59df63900c7be
parent5e066fd92f256a53df2ee5d8487e266f41e5b908 (diff)
downloadaur-vpaint.tar.gz
Apply unreleased patch to un-break building for 1.7
-rw-r--r--.SRCINFO5
-rw-r--r--Gui.pro.patch6
-rw-r--r--PKGBUILD17
3 files changed, 23 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4114af2cc88..9782b5b31c85 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vpaint
pkgdesc = VPaint is an experimental vector graphics editor based on the Vector Animation Complex technology.
pkgver = 1.7
- pkgrel = 1
+ pkgrel = 2
url = https://www.vpaint.org
arch = i686
arch = x86_64
@@ -12,8 +12,9 @@ pkgbase = vpaint
depends = qt5-base
depends = libxkbcommon-x11
conflicts = vpaint-git
+ source = Gui.pro.patch
source = https://github.com/dalboris/vpaint/archive/v1.7.tar.gz
+ md5sums = b9fd8b31d9a6edda47df543a7d4bfe90
md5sums = f714e2bd6569e08e16f89e22cfbcb2dd
pkgname = vpaint
-
diff --git a/Gui.pro.patch b/Gui.pro.patch
new file mode 100644
index 000000000000..ffad37fd97a5
--- /dev/null
+++ b/Gui.pro.patch
@@ -0,0 +1,6 @@
+79c93,95
+< !win32: QMAKE_CXXFLAGS += $$QMAKE_CFLAGS_ISYSTEM $$PWD/../Third/
+---
+> !isEmpty(QMAKE_CFLAGS_ISYSTEM) {
+> QMAKE_CXXFLAGS += $$QMAKE_CFLAGS_ISYSTEM $$PWD/../Third/
+> }
diff --git a/PKGBUILD b/PKGBUILD
index 76dcb6f86901..2ff24de4359b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=vpaint
pkgver=1.7
-pkgrel=1
+pkgrel=2
pkgdesc='VPaint is an experimental vector graphics editor based on the Vector Animation Complex technology.'
arch=('i686' 'x86_64')
license=('MIT')
@@ -12,8 +12,14 @@ makedepends=('gendesk' 'icoutils')
url='https://www.vpaint.org'
conflicts=('vpaint-git')
provides=()
-source=("https://github.com/dalboris/vpaint/archive/v$pkgver.tar.gz")
-md5sums=('f714e2bd6569e08e16f89e22cfbcb2dd')
+source=(
+ 'Gui.pro.patch'
+ "https://github.com/dalboris/vpaint/archive/v$pkgver.tar.gz"
+)
+md5sums=(
+ 'b9fd8b31d9a6edda47df543a7d4bfe90'
+ 'f714e2bd6569e08e16f89e22cfbcb2dd'
+)
prepare() {
icotool -x -o $srcdir/vpaint.png $srcdir/$pkgname-$pkgver/src/Gui/images/VPaint.ico
@@ -23,6 +29,11 @@ prepare() {
}
build() {
+ # Apply unreleased patch to un-break building 1.7 on recent linux/gcc
+ # https://github.com/dalboris/vpaint/pull/134#issuecomment-1256451558
+ # (This can be removed with any following release after current 1.7)
+ patch "$srcdir/$pkgname-$pkgver/src/Gui/Gui.pro" "$srcdir/Gui.pro.patch"
+
mkdir -p "$srcdir/$pkgname-$pkgver/build"
cd "$srcdir/$pkgname-$pkgver/build"