summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel-Andrew Pollo Guilbert2015-08-09 16:13:20 -0400
committerGabriel-Andrew Pollo Guilbert2015-08-09 16:13:20 -0400
commit756d2bc3b6441f7a8f973171ab8759b881e3ee35 (patch)
tree5866d66e0e1ca49df49b3653e3a444d1a2e26ad4
parent0b514b9210a655e1112fbd7c26335e9e3e86544f (diff)
downloadaur-756d2bc3b6441f7a8f973171ab8759b881e3ee35.tar.gz
Compile with qt5
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85a8498e956c..3eddb881c083 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,8 +11,9 @@ pkgbase = vpaint
makedepends = qtchooser
depends = qt4
depends = glu
- source = vpaint::https://github.com/dalboris/vpaint/archive/v1.5.tar.gz
- md5sums = SKIP
+ depends = qt5-base
+ source = https://github.com/dalboris/vpaint/archive/v1.5.tar.gz
+ md5sums = aee4b49c9a9a0345a1d98d734a008b7d
pkgname = vpaint
diff --git a/PKGBUILD b/PKGBUILD
index ce5e4036fdbb..014d638340c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,19 +6,22 @@ pkgrel=1
pkgdesc='VPaint is an experimental vector graphics editor based on the Vector Animation Complex technology.'
arch=('i686' 'x86_64')
license=('MIT')
-depends=('qt4' 'glu')
+depends=('qt4' 'glu' 'qt5-base')
makedepends=('gcc' 'make' 'qtchooser')
url='http://www.vpaint.org'
conflicts=()
provides=()
-source=("vpaint::https://github.com/dalboris/vpaint/archive/v$pkgver.tar.gz")
-md5sums=('SKIP')
+source=("https://github.com/dalboris/vpaint/archive/v$pkgver.tar.gz")
+md5sums=('aee4b49c9a9a0345a1d98d734a008b7d')
options=()
build() {
mkdir -p "$srcdir/$pkgname-$pkgver/build"
cd "$srcdir/$pkgname-$pkgver/build"
+ export CXXFLAGS="$CXXFLAGS -fPIC"
+ export QT_SELECT=5
+
qmake ../src/VPaint.pro -r -spec linux-g++
make
}