summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2024-02-22 02:24:22 -0600
committerHurricanePootis2024-02-22 02:26:35 -0600
commit606fa3ccfe39f04daaa64bb79df1ad4f50368b9d (patch)
tree7594bdad44e0de9fb179dfc56c0b4138381bcaf4
parent4a350d41f7ab5f92d6237b3dfdf9ad60316932f1 (diff)
downloadaur-606fa3ccfe39f04daaa64bb79df1ad4f50368b9d.tar.gz
Add libvpkeditc to the install process, remember to remove the patches for next commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
2 files changed, 45 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index afdc2a23ef98..39407239317a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vpkedit
pkgdesc = A library and CLI/GUI tool to create, read, and write several pack file formats
pkgver = 4.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/craftablescience/VPKEdit
arch = x86_64
license = MIT
@@ -10,9 +10,6 @@ pkgbase = vpkedit
makedepends = gcc
depends = gcc-libs
depends = glibc
- depends = qt6-base
- depends = hicolor-icon-theme
- optdepends = qt6-wayland: Wayland support
source = vpkedit::git+https://github.com/craftablescience/VPKEdit.git#tag=v4.1.0
source = argparse::git+https://github.com/p-ranav/argparse.git
source = vtflib::git+https://github.com/StrataSource/VTFLib.git
@@ -22,6 +19,9 @@ pkgbase = vpkedit
source = minizip-ng::git+https://github.com/zlib-ng/minizip-ng.git
source = sourcepp::git+https://github.com/craftablescience/sourcepp.git
source = miniaudio::git+https://github.com/mackron/miniaudio.git
+ source = libvpkeditc.patch::https://github.com/craftablescience/VPKEdit/commit/4ae22388250f76e68006564c31a6a5fcd49b6c69.patch
+ source = libvpkeditc2.patch::https://github.com/craftablescience/VPKEdit/commit/55e2d756b68d02cd93afcfc3abc02ebe39036b7b.patch
+ source = libvpkeditc3.patch::https://github.com/craftablescience/VPKEdit/commit/b831bd32dc9dcf3a48aa8c5924796d473c7457ea.patch
source = bufferstream::git+https://github.com/craftablescience/BufferStream.git
sha256sums = SKIP
sha256sums = SKIP
@@ -32,6 +32,16 @@ pkgbase = vpkedit
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = 9f59b6aa4e561e4ab60818ec7bfab4d968ce33e4f88d2e3abe5e3d20e2d73a20
+ sha256sums = 61bbc9ccb191fe0c117f97a519b216b7060f805ceb284e8e0583f74e0daeb618
+ sha256sums = 69fb93ace18cf2e1339430e6135b445964656793fee47e15bbff0e36c5185ff8
sha256sums = SKIP
pkgname = vpkedit
+ depends = gcc-libs
+ depends = glibc
+ depends = qt6-base
+ depends = hicolor-icon-theme
+ optdepends = qt6-wayland: Wayland support
+
+pkgname = libvpkeditc
diff --git a/PKGBUILD b/PKGBUILD
index 931114560c97..8574afae9151 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: HurricanePootis <hurricanepootis@protonmail.com>
-pkgname=vpkedit
+pkgbase=vpkedit
+pkgname=(vpkedit libvpkeditc)
pkgver=4.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="A library and CLI/GUI tool to create, read, and write several pack file formats"
arch=('x86_64')
url="https://github.com/craftablescience/VPKEdit"
license=('MIT')
-depends=('gcc-libs' 'glibc' 'qt6-base' 'hicolor-icon-theme')
+depends=('gcc-libs' 'glibc')
makedepends=('cmake' 'git' 'gcc')
-optdepends=('qt6-wayland: Wayland support')
source=("$pkgname::git+$url.git#tag=v${pkgver}"
"argparse::git+https://github.com/p-ranav/argparse.git"
"vtflib::git+https://github.com/StrataSource/VTFLib.git"
@@ -18,6 +18,9 @@ source=("$pkgname::git+$url.git#tag=v${pkgver}"
"minizip-ng::git+https://github.com/zlib-ng/minizip-ng.git"
"sourcepp::git+https://github.com/craftablescience/sourcepp.git"
"miniaudio::git+https://github.com/mackron/miniaudio.git"
+ "libvpkeditc.patch::https://github.com/craftablescience/VPKEdit/commit/4ae22388250f76e68006564c31a6a5fcd49b6c69.patch"
+ "libvpkeditc2.patch::https://github.com/craftablescience/VPKEdit/commit/55e2d756b68d02cd93afcfc3abc02ebe39036b7b.patch"
+ "libvpkeditc3.patch::https://github.com/craftablescience/VPKEdit/commit/b831bd32dc9dcf3a48aa8c5924796d473c7457ea.patch"
#Submodule for submodules
"bufferstream::git+https://github.com/craftablescience/BufferStream.git")
sha256sums=('SKIP'
@@ -29,14 +32,18 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ '9f59b6aa4e561e4ab60818ec7bfab4d968ce33e4f88d2e3abe5e3d20e2d73a20'
+ '61bbc9ccb191fe0c117f97a519b216b7060f805ceb284e8e0583f74e0daeb618'
+ '69fb93ace18cf2e1339430e6135b445964656793fee47e15bbff0e36c5185ff8'
'SKIP')
-
prepare() {
cd "$srcdir/$pkgname"
+ patch -p1 <"$srcdir/libvpkeditc.patch"
+ patch -p1 <"$srcdir/libvpkeditc2.patch"
+ patch -p1 <"$srcdir/libvpkeditc3.patch"
git submodule init
- for submodule in {vtflib,saap,speedykeyv,sourcepp,miniaudio};
- do
+ for submodule in {vtflib,saap,speedykeyv,sourcepp,miniaudio}; do
git config submodule.src/gui/thirdparty/$submodule.url "$srcdir/${submodule}"
done
git config submodule.src/cli/thirdparty/argparse.url "$srcdir/argparse"
@@ -54,12 +61,16 @@ build() {
cmake -B build \
-S "$pkgname" \
-DCMAKE_INSTALL_PREFIX=/opt/vpkedit \
- -DCMAKE_BUILD_TYPE=Release
+ -DCMAKE_BUILD_TYPE=Release \
+ -DVPKEDIT_BUILD_LIBC=ON
cmake --build build
}
-package() {
+package_vpkedit() {
+ optdepends=('qt6-wayland: Wayland support')
+ depends+=('qt6-base' 'hicolor-icon-theme')
+
cd "$srcdir"
DESTDIR="$pkgdir" cmake --install build
@@ -70,3 +81,14 @@ package() {
# Install License
install -Dm644 "$srcdir/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
+
+package_libvpkeditc() {
+ cd "$srcdir/build"
+ install -Dm755 libvpkeditc.so "$pkgdir/usr/lib/libvpkeditc.so"
+ install -Dm644 "$srcdir/vpkedit/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ cd "$srcdir/vpkedit"
+ mkdir -p "$pkgdir/usr/include/" && cp -r include/vpkeditc "$pkgdir/usr/include/vpkeditc"
+ chmod 755 "$pkgdir/usr/include/vpkeditc"
+
+}