summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2024-01-29 15:18:21 -0600
committerHurricanePootis2024-01-29 15:18:21 -0600
commit9d0001ee1aef641f7b90902e437f31f2d05b9749 (patch)
tree9e3e60b38df78e010dbfab52e3ecb1d2e58ce944
parent00d2dbc87aeab5709bcf6758d01954a6f0614731 (diff)
downloadaur-9d0001ee1aef641f7b90902e437f31f2d05b9749.tar.gz
Update to 4.0.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
2 files changed, 17 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8319b34cb82f..777e29e4d426 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vpkedit
- pkgdesc = A library and tool to create, read, and write Valve VPK archives
- pkgver = 3.7.0
+ pkgdesc = A library and CLI/GUI tool to create, read, and write several pack file formats
+ pkgver = 4.0.0
pkgrel = 1
url = https://github.com/craftablescience/VPKEdit
arch = x86_64
@@ -13,12 +13,16 @@ pkgbase = vpkedit
depends = qt6-base
depends = hicolor-icon-theme
optdepends = qt6-wayland: Wayland support
- source = vpkedit::git+https://github.com/craftablescience/VPKEdit.git#tag=v3.7.0
+ source = vpkedit::git+https://github.com/craftablescience/VPKEdit.git#tag=v4.0.0
+ source = argparse::git+https://github.com/p-ranav/argparse
source = vtflib::git+https://github.com/StrataSource/VTFLib.git
source = saap::git+https://github.com/Trico-Everfire/SteamAppPathProvider.git
source = speedykeyv::git+https://github.com/ozxybox/SpeedyKeyV.git
source = studiomodelpp::git+https://github.com/craftablescience/studiomodelpp.git
source = bufferstream::git+https://github.com/craftablescience/BufferStream.git
+ source = minizip-ng::git+https://github.com/zlib-ng/minizip-ng.git
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 4d307a1db069..635bbd9b5b7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: HurricanePootis <hurricanepootis@protonmail.com>
pkgname=vpkedit
-pkgver=3.7.0
+pkgver=4.0.0
pkgrel=1
-pkgdesc="A library and tool to create, read, and write Valve VPK archives"
+pkgdesc="A library and CLI/GUI tool to create, read, and write several pack file formats"
arch=('x86_64')
url="https://github.com/craftablescience/VPKEdit"
license=('MIT')
@@ -10,16 +10,20 @@ depends=('gcc-libs' 'glibc' 'qt6-base' 'hicolor-icon-theme')
makedepends=('cmake' 'git' 'gcc')
optdepends=('qt6-wayland: Wayland support')
source=("$pkgname::git+$url.git#tag=v${pkgver}"
+ "argparse::git+https://github.com/p-ranav/argparse"
"vtflib::git+https://github.com/StrataSource/VTFLib.git"
"saap::git+https://github.com/Trico-Everfire/SteamAppPathProvider.git"
"speedykeyv::git+https://github.com/ozxybox/SpeedyKeyV.git"
"studiomodelpp::git+https://github.com/craftablescience/studiomodelpp.git"
- "bufferstream::git+https://github.com/craftablescience/BufferStream.git")
+ "bufferstream::git+https://github.com/craftablescience/BufferStream.git"
+ "minizip-ng::git+https://github.com/zlib-ng/minizip-ng.git")
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
@@ -30,8 +34,11 @@ prepare() {
do
git config submodule.src/gui/thirdparty/$submodule.url "$srcdir/${submodule}"
done
+ git config submodule.src/cli/thirdparty/argparse.url "$srcdir/argparse"
+ git config submodule.src/lib/thirdparty/minizip-ng.url "$srcdir/minizip-ng"
git -c protocol.file.allow=always submodule update
+
cd "$srcdir/$pkgname/src/gui/thirdparty/studiomodelpp/"
git submodule init
git config submodule.src/thirdparty/bufferstream.url "$srcdir/bufferstream"