summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2023-12-11 20:05:28 -0600
committerHurricanePootis2023-12-11 20:05:28 -0600
commitf1b087e0beb4cbeb624fddefe29680a6692e5efb (patch)
treeee652bd8dc16e4e93f67d37e8d18258c22614f83
parentc037dafd982fe7061d432db3e53042d4cec0ed5d (diff)
downloadaur-f1b087e0beb4cbeb624fddefe29680a6692e5efb.tar.gz
Update to 3.6.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD41
2 files changed, 15 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf742c1e7a37..48156bf973d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vpkedit
pkgdesc = A library and tool to create, read, and write Valve VPK archives
- pkgver = 3.6.0
- pkgrel = 2
+ pkgver = 3.6.1
+ pkgrel = 1
url = https://github.com/craftablescience/VPKEdit
arch = x86_64
license = MIT
@@ -13,11 +13,13 @@ pkgbase = vpkedit
depends = qt6-base
depends = hicolor-icon-theme
optdepends = qt6-wayland: Wayland support
- source = vpkedit::git+https://github.com/craftablescience/VPKEdit.git#tag=v3.6.0
+ source = vpkedit::git+https://github.com/craftablescience/VPKEdit.git#tag=v3.6.1
source = vtflib::git+https://github.com/StrataSource/VTFLib.git
source = saap::git+https://github.com/Trico-Everfire/SteamAppPathProvider.git
source = speedykeyv::git+https://github.com/ozxybox/SpeedyKeyV.git
source = studiomodelpp::git+https://github.com/craftablescience/studiomodelpp.git
+ source = bufferstream::git+https://github.com/craftablescience/BufferStream.git
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f7ea367a5db8..b29b9083d2a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: HurricanePootis <hurricanepootis@protonmail.com>
pkgname=vpkedit
-pkgver=3.6.0
-pkgrel=2
+pkgver=3.6.1
+pkgrel=1
pkgdesc="A library and tool to create, read, and write Valve VPK archives"
arch=('x86_64')
url="https://github.com/craftablescience/VPKEdit"
@@ -13,11 +13,13 @@ source=("$pkgname::git+$url.git#tag=v${pkgver}"
"vtflib::git+https://github.com/StrataSource/VTFLib.git"
"saap::git+https://github.com/Trico-Everfire/SteamAppPathProvider.git"
"speedykeyv::git+https://github.com/ozxybox/SpeedyKeyV.git"
- "studiomodelpp::git+https://github.com/craftablescience/studiomodelpp.git")
+ "studiomodelpp::git+https://github.com/craftablescience/studiomodelpp.git"
+ "bufferstream::git+https://github.com/craftablescience/BufferStream.git")
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
@@ -29,6 +31,11 @@ prepare() {
git config submodule.src/gui/thirdparty/$submodule.url "$srcdir/${submodule}"
done
git -c protocol.file.allow=always submodule update
+
+ cd "$srcdir/$pkgname/src/gui/thirdparty/studiomodelpp/"
+ git submodule init
+ git config submodule.src/thirdparty/bufferstream.url "$srcdir/bufferstream"
+ git -c protocol.file.allow=always submodule update
}
build() {
@@ -51,32 +58,4 @@ package() {
# Install License
install -Dm644 "$srcdir/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-
- # Create mime for VPKEDIT to open up vpks
- mkdir -p "$pkgdir/usr/share/mime/packages"
- cat > "$pkgdir/usr/share/mime/packages/vpkedit.xml" <<-EOF
-<?xml version="1.0" encoding="UTF-8"?>
-<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
- <mime-type type="application/x-vpk">
- <comment>VPK Archive</comment>
- <icon name="x-vpk"/>
- <acronym>VPK</acronym>
- <expanded-acronym>Valve Pack File</expanded-acronym>
- <glob-deleteall/>
- <glob pattern="*.VPK"/>
- <glob pattern="*.vpk"/>
- </mime-type>
-</mime-info>
-EOF
- # Make the vpkedit desktop file be associated with the x-vpkedit mimetype and allow opening files
- cd "$pkgdir/usr/share/applications"
- sed -i 's"Exec=/opt/vpkedit/vpkedit"Exec=/opt/vpkedit/vpkedit %f"g' vpkedit.desktop
-
- cat >> "vpkedit.desktop" <<-EOF
- MimeType=application/x-vpk
- EOF
-
- # Give VPKs an icon
- mkdir -p "$pkgdir/usr/share/icons/hicolor/128x128/mimetypes/"
- cp "$pkgdir/usr/share/pixmaps/vpkedit.png" "$pkgdir/usr/share/icons/hicolor/128x128/mimetypes/x-vpk.png"
}