summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArda Aytekin2021-03-01 22:59:46 +0100
committerArda Aytekin2021-03-01 22:59:46 +0100
commit3e7432d99885ab2c774c6cf9e11c38f2100ee828 (patch)
treeeaeae90524bac1bd646716a00183965fb15bed18
parentdd09adaf41185c5c6867679cbd887d6952769825 (diff)
downloadaur-3e7432d99885ab2c774c6cf9e11c38f2100ee828.tar.gz
Bump version and add support for wireguard
Bumped version to 8.5 and added support for wireguard.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD20
2 files changed, 30 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c0fa01caeb2..cca2b268a29c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vpn-unlimited
pkgdesc = VPN Unlimited client application
- pkgver = 7.0
- pkgrel = 4
+ pkgver = 8.5
+ pkgrel = 1
url = https://www.vpnunlimitedapp.com
arch = x86_64
license = custom:"Copyright (c) 2018 KeepSolid Inc."
@@ -20,10 +20,23 @@ pkgbase = vpn-unlimited
depends = lsb-release
depends = strongswan>=5.8.1
depends = qt5-webengine>=5.2.1
+ depends = curl>=7.68.0
+ depends = libnghttp2>=1.39.2
+ depends = libidn2>=2.3.0
+ depends = libssh2>=1.9.0
+ depends = libpsl>=0.21.0
+ depends = openssl>=1.1.1.d
+ depends = krb5>=1.17.1
+ depends = e2fsprogs>=1.45.5
+ depends = zstd>=1.4.4
+ depends = libunistring>=0.9.10
+ depends = keyutils>=1.6.1
+ depends = pkcs11-helper>=1.26.0
+ depends = wireguard-tools
source_x86_64 = vpn-unlimited-daemon.service
- source_x86_64 = http://apt.keepsolid.com/debian/dists/buster/main/binary-amd64/vpn-unlimited_7.0+deb10-amd64.deb
+ source_x86_64 = http://apt.keepsolid.com/debian/dists/buster/main/binary-amd64/vpn-unlimited_8.5+deb10-amd64.deb
sha256sums_x86_64 = dd5ba49842bcbf4c5f722bac2ab3d4c919c676bc29c1ca269678e8a53c0e6a41
- sha256sums_x86_64 = b1394bba3de9c4da23f83d29d989e9e72cd8b040cfd3386bcb313e63036085e9
+ sha256sums_x86_64 = 6a16e29475cefde3709b499c6c738243bedb330eb0b1932f5ae5995c9474562b
pkgname = vpn-unlimited
diff --git a/PKGBUILD b/PKGBUILD
index b2e9e48c8584..52299993c854 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Arda Aytekin <aytekin@protonmail.com>
pkgname=vpn-unlimited
-pkgver=7.0
-pkgrel=4
+pkgver=8.5
+pkgrel=1
pkgdesc="VPN Unlimited client application"
arch=("x86_64")
url="https://www.vpnunlimitedapp.com"
@@ -10,19 +10,22 @@ license=('custom:"Copyright (c) 2018 KeepSolid Inc."')
source_x86_64=(
"vpn-unlimited-daemon.service"
- "http://apt.keepsolid.com/debian/dists/buster/main/binary-amd64/vpn-unlimited_7.0+deb10-amd64.deb"
+ "http://apt.keepsolid.com/debian/dists/buster/main/binary-amd64/vpn-unlimited_8.5+deb10-amd64.deb"
)
sha256sums_x86_64=(
"dd5ba49842bcbf4c5f722bac2ab3d4c919c676bc29c1ca269678e8a53c0e6a41"
- "b1394bba3de9c4da23f83d29d989e9e72cd8b040cfd3386bcb313e63036085e9"
+ "6a16e29475cefde3709b499c6c738243bedb330eb0b1932f5ae5995c9474562b"
)
depends=(
"glibc>=2.9" "qt5-base>=5.2.1" "qt5-script>=5.2.1" "qt5-webkit>=5.2.1"
- "gcc-libs>=4.4.15" "zlib>=1.2.0" "openvpn" "openresolv" "lzo>=2.0"
- "iproute2" "net-tools" "c-ares>=1.10.0" "lsb-release" "strongswan>=5.8.1"
- "qt5-webengine>=5.2.1"
+ "gcc-libs>=4.4.15" "zlib>=1.2.0" "openvpn" "openresolv" "lzo>=2.0" "iproute2"
+ "net-tools" "c-ares>=1.10.0" "lsb-release" "strongswan>=5.8.1"
+ "qt5-webengine>=5.2.1" "curl>=7.68.0" "libnghttp2>=1.39.2" "libidn2>=2.3.0"
+ "libssh2>=1.9.0" "libpsl>=0.21.0" "openssl>=1.1.1.d" "krb5>=1.17.1"
+ "e2fsprogs>=1.45.5" "zstd>=1.4.4" "libunistring>=0.9.10" "keyutils>=1.6.1"
+ "pkcs11-helper>=1.26.0" "wireguard-tools"
)
package() {
@@ -48,4 +51,7 @@ package() {
rm --recursive --force "${pkgdir}/usr/share/doc"
chmod --recursive go-w "${pkgdir}/usr"
+
+ find "${pkgdir}/usr/share" -type d -name aclocal -prune -exec rm -rf {} +
+ find "${pkgdir}/usr/lib" -type f -name "*.so*" -exec chmod +x {} +
}