summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArda Aytekin2017-07-24 14:16:56 +0200
committerArda Aytekin2017-07-24 16:07:53 +0200
commitfebef7d6f15e9e30677097c52f30cc6d5015cf57 (patch)
tree2027c74e7a8337b13270a32d627d86892aa2022e
downloadaur-febef7d6f15e9e30677097c52f30cc6d5015cf57.tar.gz
Initialize repository
Initialized the repository with PKGBUILD, .SRCINFO and .gitignore.
-rw-r--r--.SRCINFO36
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD49
-rw-r--r--vpn-unlimited3
-rw-r--r--vpn-unlimited-daemon.service8
5 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b610090cc727
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = vpn-unlimited
+ pkgdesc = VPN Unlimited client application
+ pkgver = 4.1
+ pkgrel = 1
+ url = https://www.vpnunlimitedapp.com
+ arch = x86_64
+ arch = i686
+ license = custom:"Copyright (c) 2017 KeepSolid Inc"
+ depends = glibc>=2.9
+ depends = qt5-base>=5.2.1
+ depends = qt5-script>=5.2.1
+ depends = qt5-webkit>=5.1.1
+ depends = gcc-libs>=4.4.15
+ depends = zlib>=1.2.0
+ depends = openvpn
+ depends = openresolv
+ depends = lzo>=2.0
+ depends = libcurl-openssl-1.0
+ depends = iproute
+ depends = net-tools
+ depends = c-ares>=1.10.0
+ source_x86_64 = vpn-unlimited
+ source_x86_64 = vpn-unlimited-daemon.service
+ source_x86_64 = http://apt.keepsolid.com/debian/pool/main/v/vpn-unlimited/vpn-unlimited_4.1_amd64.deb
+ md5sums_x86_64 = 8623605b1bef9eda0f451a9b4447629f
+ md5sums_x86_64 = b4a4b36065e1026ca4054ba584003272
+ md5sums_x86_64 = 4fa9c4e38467c29d972b300f29f03f75
+ source_i686 = vpn-unlimited
+ source_i686 = vpn-unlimited-daemon.service
+ source_i686 = http://apt.keepsolid.com/debian/pool/main/v/vpn-unlimited/vpn-unlimited_4.1_i386.deb
+ md5sums_i686 = 8623605b1bef9eda0f451a9b4447629f
+ md5sums_i686 = 53d6de7ea5facf7ee1a31d2dace29dcc
+ md5sums_i686 = 5bc6a3c909feefc6451b42311c2aa7fc
+
+pkgname = vpn-unlimited
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7861b8d0bffe
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.deb
+*.pkg.tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59116f256e91
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Arda Aytekin <aytekin@protonmail.com>
+
+pkgname=vpn-unlimited
+pkgver=4.1
+pkgrel=1
+pkgdesc='VPN Unlimited client application'
+arch=('x86_64' 'i686')
+url='https://www.vpnunlimitedapp.com'
+license=('custom:"Copyright (c) 2017 KeepSolid Inc"')
+
+source_x86_64=("vpn-unlimited" "vpn-unlimited-daemon.service"
+ "http://apt.keepsolid.com/debian/pool/main/v/vpn-unlimited/vpn-unlimited_${pkgver}_amd64.deb")
+md5sums_x86_64=('8623605b1bef9eda0f451a9b4447629f'
+ '53d6de7ea5facf7ee1a31d2dace29dcc'
+ '4fa9c4e38467c29d972b300f29f03f75')
+
+source_i686=("vpn-unlimited" "vpn-unlimited-daemon.service"
+ "http://apt.keepsolid.com/debian/pool/main/v/vpn-unlimited/vpn-unlimited_${pkgver}_i386.deb")
+md5sums_i686=('8623605b1bef9eda0f451a9b4447629f'
+ '53d6de7ea5facf7ee1a31d2dace29dcc'
+ '5bc6a3c909feefc6451b42311c2aa7fc')
+
+depends=("glibc>=2.9" "qt5-base>=5.2.1" "qt5-script>=5.2.1" "qt5-webkit>=5.1.1"
+ "gcc-libs>=4.4.15" "zlib>=1.2.0" "openvpn" "openresolv" "lzo>=2.0"
+ "libcurl-openssl-1.0" "iproute" "net-tools" "c-ares>=1.10.0")
+
+package() {
+ cd "${srcdir}"
+
+ # Extract the package
+ tar --extract --file data.tar.xz --directory "${pkgdir}"
+
+ # Remove the init.d related things
+ rm --recursive --force "${pkgdir}/etc"
+
+ # Add the systemd equivalent
+ install -Dm644 "${srcdir}/vpn-unlimited-daemon.service" \
+ "${pkgdir}/usr/lib/systemd/system/vpn-unlimited-daemon.service"
+
+ # Move sbin to bin
+ find "${pkgdir}/usr/sbin" -type f -exec mv '{}' "${pkgdir}/usr/bin/" \;
+ rmdir "${pkgdir}/usr/sbin"
+
+ # Copy the wrapper file
+ mv "${pkgdir}/usr/bin/vpn-unlimited" "${pkgdir}/usr/share/vpn-unlimited/"
+ install -Dm755 "${srcdir}/vpn-unlimited" "${pkgdir}/usr/bin/"
+
+ chmod --recursive go-w "${pkgdir}/usr"
+}
diff --git a/vpn-unlimited b/vpn-unlimited
new file mode 100644
index 000000000000..ac4bd78f0fda
--- /dev/null
+++ b/vpn-unlimited
@@ -0,0 +1,3 @@
+#!/bin/sh
+export LD_PRELOAD=libcurl-openssl-1.0.so
+/usr/share/vpn-unlimited/vpn-unlimited "$@"
diff --git a/vpn-unlimited-daemon.service b/vpn-unlimited-daemon.service
new file mode 100644
index 000000000000..c763501ee1fa
--- /dev/null
+++ b/vpn-unlimited-daemon.service
@@ -0,0 +1,8 @@
+[Unit]
+Description=VPN Unlimited daemon
+
+[Service]
+ExecStart=/usr/bin/vpn-unlimited-daemon
+
+[Install]
+WantedBy=multi-user.target