summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJörg Thalheim2016-04-05 21:53:27 +0200
committerJörg Thalheim2016-04-05 21:53:27 +0200
commitd2a0a90f0823d2a92a78a863bb7816a3b00b7ec7 (patch)
treea9be188e03358292630be311e168a33ecf6cd179
downloadaur-d2a0a90f0823d2a92a78a863bb7816a3b00b7ec7.tar.gz
first commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77d8ec2ddf01
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Tue Apr 5 19:36:28 UTC 2016
+pkgbase = vpn-ws
+ pkgdesc = A VPN server over websockets
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/unbit/vpn-ws
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = openssl
+ source = git+https://github.com/unbit/vpn-ws.git#tag=v0.2
+ md5sums = SKIP
+
+pkgname = vpn-ws
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..223a11f11821
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname='vpn-ws'
+pkgver=r147.9d0e866
+pkgrel=1
+pkgdesc="A VPN server over websockets"
+url="https://github.com/unbit/vpn-ws"
+license=('GPL3')
+makedepends=('git')
+depends=('openssl')
+arch=('any')
+source=("git+https://github.com/unbit/vpn-ws.git")
+
+pkgver() {
+ cd "$srcdir/vpn-ws"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/vpn-ws"
+ export CFLAGS="-Wno-error=implicit-int $CFLAGS"
+ make vpn-ws vpn-ws-client
+ install -m 755 -d "${pkgdir}/usr/bin"
+ install -m 755 vpn-ws "${pkgdir}/usr/bin/vpn-ws"
+ install -m 755 vpn-ws-client "${pkgdir}/usr/bin/vpn-ws-client"
+}
+md5sums=('SKIP')