summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpingplug2019-05-20 20:35:03 +0800
committerpingplug2019-05-20 20:35:03 +0800
commite12c67e4c82adfb5cb37f1bcea86ab85d0d0df29 (patch)
tree9334c29d096e41e6e6d2345fb803914924856ccb
parent7ef88466a41a310699eaf29e5232fa64de5652b2 (diff)
downloadaur-e12c67e4c82adfb5cb37f1bcea86ab85d0d0df29.tar.gz
update email
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD30
2 files changed, 19 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e048e72e210b..ef46c0642b8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = vqmt-git
pkgdesc = Video Quality Measurement Tool which can compute PSNR, SSIM, MS-SSIM, VIFp, PSNR-HVS and PSNR-HVS-M metrics
- pkgver = v1.1.22.g4e32135
+ pkgver = v1.1.23.ge49803f
pkgrel = 1
- url = https://mmspg.epfl.ch/vqmt
+ url = https://mmspg.epfl.ch/downloads/vqmt/
arch = x86_64
- arch = i686
license = custom
makedepends = git
makedepends = cmake
depends = opencv
source = git+https://github.com/Rolinh/VQMT.git
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = vqmt-git
diff --git a/PKGBUILD b/PKGBUILD
index c8c98a8270d6..18cf4718a943 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,39 @@
-# Maintainer: pingplug <pingplug@foxmail.com>
-# Submitter: Rolinh <robinDOThahlingATgw-computingDOTnet>
-# Contributor: Rolinh <robinDOThahlingATgw-computingDOTnet>
+# Maintainer: pingplug < aur at pingplug dot me >
+# Submitter: Rolinh < robin DOT hahling AT gw-computing DOT net >
+# Contributor: Rolinh < robin DOT hahling AT gw-computing DOT net>
-pkgname=vqmt-git
_pkgname=VQMT
-pkgver=v1.1.22.g4e32135
+
+pkgname=vqmt-git
+pkgver=v1.1.23.ge49803f
pkgrel=1
pkgdesc="Video Quality Measurement Tool which can compute PSNR, SSIM, MS-SSIM, VIFp, PSNR-HVS and PSNR-HVS-M metrics"
-arch=('x86_64' 'i686')
-url="https://mmspg.epfl.ch/vqmt"
+arch=('x86_64')
+url="https://mmspg.epfl.ch/downloads/vqmt/"
license=('custom')
depends=('opencv')
-makedepends=('git' 'cmake')
+makedepends=('git'
+ 'cmake')
source=("git+https://github.com/Rolinh/VQMT.git")
-md5sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${_pkgname}"
-
git describe --tags | sed 's|-|.|g'
}
build() {
- cd "$srcdir/$_pkgname"
-
- cmake ./ -DPREFIX=/usr -DCMAKE_BUILD_TYPE=RELEASE
+ cd "${srcdir}/${_pkgname}"
+ cmake \
+ -DPREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=RELEASE \
+ .
make
}
package() {
cd "${srcdir}/${_pkgname}"
make DESTDIR="${pkgdir}" install
-
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
}