summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMistle Yurika2022-11-04 17:47:51 +0300
committerMistle Yurika2022-11-04 22:21:16 +0300
commit13d681a0d5f329590835889a9571c93521ea7e55 (patch)
tree84b603459042cbf23694eaabe7e9ebf25cc1c064
downloadaur-13d681a0d5f329590835889a9571c93521ea7e55.tar.gz
VR2Normal: Initial commit at version 1.2
-rw-r--r--.SRCINFO15
-rw-r--r--0001-Fix-Linux-packaging-with-correctly-set-target.path.patch11
-rw-r--r--PKGBUILD32
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..227d5e7e5a75
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vr2normal
+ pkgdesc = C++ QT Program that converts virtual reality videos into normal videos for viewing on any screen
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://gitlab.com/vongooB9/vr2normal
+ arch = x86_64
+ license = GPL3
+ depends = ffmpeg>=5.0
+ depends = qt5-base>=5.15.0
+ source = vr2normal-1.2.tar.gz::https://gitlab.com/vongooB9/vr2normal/-/archive/1.2/vr2normal-1.2.tar.gz
+ source = 0001-Fix-Linux-packaging-with-correctly-set-target.path.patch
+ sha256sums = e590926a8a36753908d576f48a972df6ed559753aae2f6ee64afeccac95a9de3
+ sha256sums = e0ae9e79fdf2140df22045b10ee7417eb18e7250151b02a3e819e96eff1edb5d
+
+pkgname = vr2normal
diff --git a/0001-Fix-Linux-packaging-with-correctly-set-target.path.patch b/0001-Fix-Linux-packaging-with-correctly-set-target.path.patch
new file mode 100644
index 000000000000..3484c006dbc5
--- /dev/null
+++ b/0001-Fix-Linux-packaging-with-correctly-set-target.path.patch
@@ -0,0 +1,11 @@
+diff --git a/VR2Normal.pro b/VR2Normal.pro
+index 4c125eb..d420b2d 100644
+--- a/VR2Normal.pro
++++ b/VR2Normal.pro
+@@ -24,5 +24,5 @@ FORMS += \
+
+ # Default rules for deployment.
+ qnx: target.path = /tmp/$${TARGET}/bin
+-else: unix:!android: target.path = /opt/$${TARGET}/bin
++else: unix:!android: target.path = $$(PREFIX)/bin
+ !isEmpty(target.path): INSTALLS += target
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c63e3d3df29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Mistle <tehmistle [at] gmx.com>
+pkgname=vr2normal
+pkgver=1.2
+pkgrel=1
+pkgdesc="C++ QT Program that converts virtual reality videos into normal videos for viewing on any screen"
+arch=('x86_64')
+url="https://gitlab.com/vongooB9/vr2normal"
+license=('GPL3')
+depends=('ffmpeg>=5.0' 'qt5-base>=5.15.0')
+makedepends=()
+source=("$pkgname-$pkgver.tar.gz::$url/-/archive/$pkgver/$pkgname-$pkgver.tar.gz"
+"0001-Fix-Linux-packaging-with-correctly-set-target.path.patch"
+)
+sha256sums=('e590926a8a36753908d576f48a972df6ed559753aae2f6ee64afeccac95a9de3'
+'e0ae9e79fdf2140df22045b10ee7417eb18e7250151b02a3e819e96eff1edb5d'
+)
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -Np1 -i "$srcdir/0001-Fix-Linux-packaging-with-correctly-set-target.path.patch"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ PREFIX=/usr qmake-qt5
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make INSTALL_ROOT="$pkgdir/" install
+}