summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMistle Yurika2022-12-04 18:29:14 +0300
committerMistle Yurika2022-12-04 18:41:48 +0300
commitd165eab50e09f4afe71e2675148f24e4ee4e4a4e (patch)
tree00c704f787c7b89d1a038541fcc0a89c40e321cc
parent99e2e4f73d60dd5f893c6876908e87a7ddc9c531 (diff)
downloadaur-d165eab50e09f4afe71e2675148f24e4ee4e4a4e.tar.gz
Update to 1.4
Remove patch to "make install" work, since it's now fixed in upstream Thanks vongooB9 for this improvement!
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Fix-Linux-packaging-with-correctly-set-target.path.patch11
-rw-r--r--PKGBUILD13
3 files changed, 6 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1906e0502c2..fdf03ac025ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = vr2normal
pkgdesc = C++ QT Program that converts virtual reality videos into normal videos for viewing on any screen
- pkgver = 1.3
+ pkgver = 1.4
pkgrel = 1
url = https://gitlab.com/vongooB9/vr2normal
arch = x86_64
license = GPL3
depends = ffmpeg>=5.0
depends = qt5-base>=5.15.0
- source = vr2normal-1.3.tar.gz::https://gitlab.com/vongooB9/vr2normal/-/archive/1.3/vr2normal-1.3.tar.gz
- source = 0001-Fix-Linux-packaging-with-correctly-set-target.path.patch
- sha256sums = 2eab584e87d0d533347f4c498d237b3b08b5c59b6ef16343801c54497db1fcd7
- sha256sums = e0ae9e79fdf2140df22045b10ee7417eb18e7250151b02a3e819e96eff1edb5d
+ source = vr2normal-1.4.tar.gz::https://gitlab.com/vongooB9/vr2normal/-/archive/1.4/vr2normal-1.4.tar.gz
+ sha256sums = 2b28bf8d3d4b39b829a15b4fcc02af76cbe58bc34eb7307dafd7c5b47f78c7c3
pkgname = vr2normal
diff --git a/0001-Fix-Linux-packaging-with-correctly-set-target.path.patch b/0001-Fix-Linux-packaging-with-correctly-set-target.path.patch
deleted file mode 100644
index 3484c006dbc5..000000000000
--- a/0001-Fix-Linux-packaging-with-correctly-set-target.path.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff --git a/VR2Normal.pro b/VR2Normal.pro
-index 4c125eb..d420b2d 100644
---- a/VR2Normal.pro
-+++ b/VR2Normal.pro
-@@ -24,5 +24,5 @@ FORMS += \
-
- # Default rules for deployment.
- qnx: target.path = /tmp/$${TARGET}/bin
--else: unix:!android: target.path = /opt/$${TARGET}/bin
-+else: unix:!android: target.path = $$(PREFIX)/bin
- !isEmpty(target.path): INSTALLS += target
diff --git a/PKGBUILD b/PKGBUILD
index ccbcda1bc367..13f2e47ab6aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Mistle <tehmistle [at] gmx.com>
pkgname=vr2normal
-pkgver=1.3
+pkgver=1.4
pkgrel=1
pkgdesc="C++ QT Program that converts virtual reality videos into normal videos for viewing on any screen"
arch=('x86_64')
@@ -9,19 +9,12 @@ license=('GPL3')
depends=('ffmpeg>=5.0' 'qt5-base>=5.15.0')
makedepends=()
source=("$pkgname-$pkgver.tar.gz::$url/-/archive/$pkgver/$pkgname-$pkgver.tar.gz"
-"0001-Fix-Linux-packaging-with-correctly-set-target.path.patch"
)
-sha256sums=('2eab584e87d0d533347f4c498d237b3b08b5c59b6ef16343801c54497db1fcd7'
- 'e0ae9e79fdf2140df22045b10ee7417eb18e7250151b02a3e819e96eff1edb5d')
-
-prepare() {
- cd "$pkgname-$pkgver"
- patch -Np1 -i "$srcdir/0001-Fix-Linux-packaging-with-correctly-set-target.path.patch"
-}
+sha256sums=('2b28bf8d3d4b39b829a15b4fcc02af76cbe58bc34eb7307dafd7c5b47f78c7c3')
build() {
cd "$pkgname-$pkgver"
- PREFIX=/usr qmake-qt5
+ qmake-qt5 USR_DIR=/usr
make
}