summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlbidoux2015-06-17 09:57:50 +0200
committerlbidoux2015-06-17 09:57:50 +0200
commit5b69e0afe616ae21eb99577d03b349e7eb43994b (patch)
tree43fd2e635bc32ff3e84a877b83196186f2658da5
downloadaur-5b69e0afe616ae21eb99577d03b349e7eb43994b.tar.gz
vrms-arch 0.1.0.r14.gf9d0964
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cf363ed4c0a9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vrms-arch
+ pkgdesc = vrms for ArchLinux
+ pkgver = 0.1.0.r14.gf9d0964
+ pkgrel = 1
+ url = https://github.com/orospakr/vrms-arch
+ arch = any
+ license = custom:BSD3
+ makedepends = git
+ depends = python
+ depends = pyalpm
+ source = git+https://github.com/orospakr/vrms-arch.git
+ md5sums = SKIP
+
+pkgname = vrms-arch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e0c6aa37e39
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: Andrew Clunis <andrew@orospakr.ca>
+# Contributor: Ben R <thebenj88 *AT* gmail *DOT* com>
+# Maintainer: Loïc Bidoux <loic.bidoux [at] owndata.org>
+
+pkgname=vrms-arch
+pkgver=0.1.0.r14.gf9d0964
+pkgrel=1
+pkgdesc="vrms for ArchLinux"
+arch=('any')
+url="https://github.com/orospakr/${pkgname}"
+license=('custom:BSD3')
+makedepends=('git')
+depends=('python' 'pyalpm')
+source=("git+https://github.com/orospakr/${pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g;s/v*//'
+}
+
+build() {
+ cd "$srcdir/${pkgname}"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname}"
+ python setup.py install --root=${pkgdir}
+ install -Dm 644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}