summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhanibek Adilbekov2022-10-07 01:40:46 +0600
committerZhanibek Adilbekov2022-10-07 01:40:46 +0600
commit0a0cddb90419e04fc2ceaf28fcc1b8e6190d8f7b (patch)
tree9b8fd130b882bbd5b588c40dc37a8d387e559ff4
downloadaur-0a0cddb90419e04fc2ceaf28fcc1b8e6190d8f7b.tar.gz
build: version 1.28.0
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore113
-rw-r--r--PKGBUILD17
3 files changed, 142 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8fb2156e3600
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = vscode-php-debug
+ pkgdesc = PHP Debug Adapter (DAP)
+ pkgver = 1.28.0
+ pkgrel = 1
+ url = https://github.com/xdebug/vscode-php-debug
+ arch = any
+ license = MIT
+ depends = nodejs
+ source = extension.zip::https://github.com/xdebug/vscode-php-debug/releases/download/v1.28.0/php-debug-1.28.0.vsix
+ b2sums = 96710618ce939c7be45c7f5d1066f91638badffb8cd8dd86d08430f0fbe84f8eafac20ae6c0c0ee4242dc3e78db9e146d9566a9301f8ce0ba7cba20a879ce760
+
+pkgname = vscode-php-debug
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6fb3ba70637b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,113 @@
+# Created by https://www.toptal.com/developers/gitignore/api/linux,windows,macos,vim,archlinuxpackages
+# Edit at https://www.toptal.com/developers/gitignore?templates=linux,windows,macos,vim,archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+### Linux ###
+*~
+
+# temporary files which can be created if a process still has a handle open of a deleted file
+.fuse_hidden*
+
+# KDE directory preferences
+.directory
+
+# Linux trash folder which might appear on any partition or disk
+.Trash-*
+
+# .nfs files are created when an open file is removed but is still being accessed
+.nfs*
+
+### macOS ###
+# General
+.DS_Store
+.AppleDouble
+.LSOverride
+
+# Icon must end with two \r
+Icon
+
+# Thumbnails
+._*
+
+# Files that might appear in the root of a volume
+.DocumentRevisions-V100
+.fseventsd
+.Spotlight-V100
+.TemporaryItems
+.Trashes
+.VolumeIcon.icns
+.com.apple.timemachine.donotpresent
+
+# Directories potentially created on remote AFP share
+.AppleDB
+.AppleDesktop
+Network Trash Folder
+Temporary Items
+.apdisk
+
+### macOS Patch ###
+# iCloud generated files
+*.icloud
+
+### Vim ###
+# Swap
+[._]*.s[a-v][a-z]
+!*.svg # comment out if you don't need vector files
+[._]*.sw[a-p]
+[._]s[a-rt-v][a-z]
+[._]ss[a-gi-z]
+[._]sw[a-p]
+
+# Session
+Session.vim
+Sessionx.vim
+
+# Temporary
+.netrwhist
+# Auto-generated tag files
+tags
+# Persistent undo
+[._]*.un~
+
+### Windows ###
+# Windows thumbnail cache files
+Thumbs.db
+Thumbs.db:encryptable
+ehthumbs.db
+ehthumbs_vista.db
+
+# Dump file
+*.stackdump
+
+# Folder config file
+[Dd]esktop.ini
+
+# Recycle Bin used on file shares
+$RECYCLE.BIN/
+
+# Windows Installer files
+*.cab
+*.msix
+*.msm
+*.msp
+
+# Windows shortcuts
+*.lnk
+
+# End of https://www.toptal.com/developers/gitignore/api/linux,windows,macos,vim,archlinuxpackages
+
+*.vsix
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f7686c382e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Zhanibek Adilbekov <zhanibek.adilbekov@proton.me>
+pkgname=vscode-php-debug
+pkgver=1.28.0
+pkgrel=1
+pkgdesc='PHP Debug Adapter (DAP)'
+arch=('any')
+url="https://github.com/xdebug/$pkgname"
+license=('MIT')
+depends=('nodejs')
+source=("extension.zip::https://github.com/xdebug/vscode-php-debug/releases/download/v$pkgver/php-debug-$pkgver.vsix")
+b2sums=('96710618ce939c7be45c7f5d1066f91638badffb8cd8dd86d08430f0fbe84f8eafac20ae6c0c0ee4242dc3e78db9e146d9566a9301f8ce0ba7cba20a879ce760')
+
+package() {
+ install -dm755 "$pkgdir/usr/lib/node_modules/php-debug"
+ cp -r "$srcdir/extension"/. "$pkgdir/usr/lib/node_modules/php-debug"
+ install -Dm644 "$srcdir/extension/LICENSE.txt" "$pkgdir/usr/share/licenses/php-debug/LICENSE.txt"
+}