summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCedric Roijakkers2024-01-30 15:51:26 +0100
committerCedric Roijakkers2024-01-30 15:51:26 +0100
commit13d50304885d66a24831804781b27717078f87bb (patch)
tree126fafc87bc200decf68aefa34c5e2baefa97d8d
parent13fe436b7f7d9019f22e6232a4b9b42f1b0257a3 (diff)
downloadaur-13d50304885d66a24831804781b27717078f87bb.tar.gz
Fixed build and added launcher file for Wayland just like the binary release does
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD5
-rw-r--r--vscodium-git-wayland.desktop18
4 files changed, 26 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a33ad3d389b..a048ac54a9d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -37,9 +37,11 @@ pkgbase = vscodium-git
conflicts = vscodium-git
source = git+https://github.com/VSCodium/vscodium.git#branch=master
source = vscodium-git.desktop
+ source = vscodium-git-wayland.desktop
source = vscodium-git-uri-handler.desktop
sha256sums = SKIP
sha256sums = 07cde55d43e5f456f90867c5592a04e33e79e15db21faf2160a22357737bd029
+ sha256sums = 1841d08fdb512f32433eefa21132bf7ad13e106cb45ca3218d0da7b7be9cfc81
sha256sums = 28bd860a45b8795b0374c3660065a02e04adf20e3a3556bbd1d192f0cd554a7c
pkgname = vscodium-git
diff --git a/.gitignore b/.gitignore
index 2f56d34cbf0f..b2ff876cd7de 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,4 +4,5 @@
!BUILDING
!PKGBUILD
!vscodium-git-uri-handler.desktop
+!vscodium-git-wayland.desktop
!vscodium-git.desktop
diff --git a/PKGBUILD b/PKGBUILD
index d479e52ce1c9..d2d94a45dd8c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -40,10 +40,12 @@ makedepends=(
source=(
"git+${url}#branch=master"
"${pkgname}.desktop"
+ "${pkgname}-wayland.desktop"
"${pkgname}-uri-handler.desktop"
)
sha256sums=('SKIP'
'07cde55d43e5f456f90867c5592a04e33e79e15db21faf2160a22357737bd029'
+ '1841d08fdb512f32433eefa21132bf7ad13e106cb45ca3218d0da7b7be9cfc81'
'28bd860a45b8795b0374c3660065a02e04adf20e3a3556bbd1d192f0cd554a7c')
provides=(
'codium'
@@ -138,6 +140,8 @@ build() {
# the app will be updated with pacman
export DISABLE_UPDATE="yes"
+ # Disabling this patch, since it is for win32 and does not apply here
+ rm -rf patches/cleanup-archive.patch
. get_repo.sh
. build.sh
}
@@ -154,6 +158,7 @@ package() {
ln -s /usr/share/${pkgname}/bin/codium ${pkgdir}/usr/bin/vscodium
install -D -m644 ${pkgname}.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
+ install -D -m644 ${pkgname}-wayland.desktop ${pkgdir}/usr/share/applications/${pkgname}-wayland.desktop
install -D -m644 ${pkgname}-uri-handler.desktop ${pkgdir}/usr/share/applications/${pkgname}-uri-handler.desktop
install -D -m644 ${srcdir}/vscodium/VSCode-linux-${_vscode_arch}/resources/app/resources/linux/code.png ${pkgdir}/usr/share/pixmaps/${pkgname}.png
diff --git a/vscodium-git-wayland.desktop b/vscodium-git-wayland.desktop
new file mode 100644
index 000000000000..6d2828e63d4a
--- /dev/null
+++ b/vscodium-git-wayland.desktop
@@ -0,0 +1,18 @@
+[Desktop Entry]
+Name=VSCodium - Wayland
+Comment=Code Editing. Redefined.
+GenericName=Text Editor
+Exec=/usr/bin/codium --enable-features=UseOzonePlatform,WaylandWindowDecorations --ozone-platform=wayland --unity-launch %F
+Icon=vscodium
+Type=Application
+StartupNotify=false
+StartupWMClass=codium-url-handler
+Categories=Utility;Development;IDE;
+MimeType=text/plain;inode/directory;
+Actions=new-empty-window;
+Keywords=vscode;
+
+[Desktop Action new-empty-window]
+Name=New Empty Window
+Exec=/usr/bin/codium --enable-features=UseOzonePlatform,WaylandWindowDecorations --ozone-platform=wayland --new-window %F
+Icon=vscodium