summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBaptiste Augrain2023-05-17 12:31:01 +0200
committerBaptiste Augrain2023-05-17 12:31:01 +0200
commit6d11738b9a8a9b5a19c20bc18cc49bb010aa1aa0 (patch)
tree836b12fdcfde80d79d183581354901d94edf5ba7
parentae74b759d2b624dc64bba2e5cad8790d66d437c2 (diff)
downloadaur-6d11738b9a8a9b5a19c20bc18cc49bb010aa1aa0.tar.gz
Updated to 1.78.1.23131.r0.g272f67d
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a450686e98a..bc4565c90c4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vscodium-git
pkgdesc = Free/Libre Open Source Software Binaries of VSCode (git build from latest commit).
- pkgver = 1.77.0.23095.r4.g6137a9f
+ pkgver = 1.78.1.23131.r0.g272f67d
pkgrel = 1
url = https://github.com/VSCodium/vscodium.git
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index d0c42790066e..5518d4fc4d4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Inspired from the PKGBUILD for vscodium-bin and code-stable-git.
pkgname=vscodium-git
-pkgver=1.77.0.23095.r4.g6137a9f
+pkgver=1.78.1.23131.r0.g272f67d
pkgrel=1
pkgdesc="Free/Libre Open Source Software Binaries of VSCode (git build from latest commit)."
arch=('x86_64' 'aarch64' 'armv7h')
@@ -106,12 +106,22 @@ build() {
nvm use
# Check if the correct version of node is being used
- if [[ "$(node --version)" != "$(cat .nvmrc)" ]]
+ nvmrc_version="$(cat .nvmrc)"
+ if [[ "$nvmrc_version" != "v"* ]]
then
- echo "Using the wrong version of NodeJS! Expected ["$(cat .nvmrc)"] but using ["$(node --version)"]."
- exit 1
+ # Add the v prefix, because it seems to be missing in .nvmrc
+ echo "Configured .nvmrc version is [$nvmrc_version], adding the v prefix before checking if it matches with the node command."
+ nvmrc_version="v$nvmrc_version"
fi
+ # Now check if the version matches exactly, or at least starts with the same prefix
+ if [[ "$(node --version)" != "$nvmrc_version"* ]]
+ then
+ echo "Using the wrong version of NodeJS! Expected ["$nvmrc_version"] but using ["$(node --version)"]."
+ exit 1
+ fi
+ echo "Installed version of node ["$(node --version)"] matches required version ["$nvmrc_version"], continuing."
+
# Remove old build
if [ -d "vscode" ]; then
rm -rf vscode* VSCode*