summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcopygirl2018-01-20 17:49:59 +0100
committercopygirl2018-01-20 17:49:59 +0100
commit9870777cf87e761433149155813ff453d5188c36 (patch)
treea9dd635d895368c1ada4790be750bc0d1ba6f11f
parent5f0a2cc25dcd76e4d9a3251b0b9a8abfd7d2eb88 (diff)
downloadaur-9870777cf87e761433149155813ff453d5188c36.tar.gz
copygirl earned The Power of INSTALL!
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD47
2 files changed, 26 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c7832fea179..80e87520180a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vsmodelcreator-git
pkgdesc = Vintage Story Model Creator
- pkgver = r223.3327409
+ pkgver = r225.75c385c
pkgrel = 1
url = https://github.com/anegostudios/vsmodelcreator
arch = any
@@ -8,7 +8,7 @@ pkgbase = vsmodelcreator-git
makedepends = git
makedepends = java-environment>=8
depends = java-runtime>=8
- source = vsmodelcreator::git://github.com/anegostudios/vsmodelcreator.git
+ source = git://github.com/anegostudios/vsmodelcreator.git
source = vsmodelcreator.desktop
source = vsmodelcreator.sh
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 03886a2375e4..e66554af4f74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: copygirl <copygirl@mcft.net>
_pkgname=vsmodelcreator
pkgname=${_pkgname}-git
-pkgver=r223.3327409
+pkgver=r225.75c385c
pkgrel=1
pkgdesc="Vintage Story Model Creator"
-arch=('any')
+arch=("any")
url="https://github.com/anegostudios/vsmodelcreator"
-license=('Apache')
-depends=('java-runtime>=8')
-makedepends=('git' 'java-environment>=8')
+license=("Apache")
+depends=("java-runtime>=8")
+makedepends=("git" "java-environment>=8")
options=()
-source=("${_pkgname}::git://github.com/anegostudios/vsmodelcreator.git"
+source=("git://github.com/anegostudios/vsmodelcreator.git"
"vsmodelcreator.desktop"
"vsmodelcreator.sh")
md5sums=("SKIP"
@@ -26,28 +26,29 @@ build() {
cd "${_pkgname}"
# Build the application
mkdir -p bin
- javac -cp 'libs/*' -d bin $(find src -name "*.java")
+ javac -cp "libs/*" -d bin $(find src -name "*.java")
# Create a .jar file
- jar cfe "${_pkgname}.jar" at.vintagestory.modelcreator.Start -C bin . -C assets .
+ jar cfe ${_pkgname}.jar "at.vintagestory.modelcreator.Start" -C bin . -C assets .
# (Specifying the main entry class here, but
# not actually using it in the launch script.)
}
package() {
- cd "${_pkgname}"
- mkdir -p "${pkgdir}/usr/share/java/${_pkgname}"
- # Copy executable and library .jar files
- cp --parents vsmodelcreator.jar "${pkgdir}/usr/share/java/${_pkgname}/"
- cp --parents libs/* "${pkgdir}/usr/share/java/${_pkgname}/"
- # Copy native libraries
- cp --parents natives/linux/* "${pkgdir}/usr/share/java/${_pkgname}/"
- # TODO: See if we can depend on other packages that provide our dependencies.
+ cd ${_pkgname}
+ # Create directory structure for application in /usr/share/java/vsmodelcreator
+ install -dm 755 ${pkgdir}/usr/share/java/${_pkgname}/{,libs,natives/linux}
+ # Copies .jar file, libs and native libraries
+ install -Dm 755 vsmodelcreator.jar ${pkgdir}/usr/share/java/${_pkgname}/
+ install -Dm 644 libs/* ${pkgdir}/usr/share/java/${_pkgname}/libs/
+ install -Dm 644 natives/linux/* ${pkgdir}/usr/share/java/${_pkgname}/natives/linux/
+ # TODO: See if we can depend on other packages that provide our native dependencies.
- cd ".."
- mkdir -p ${pkgdir}/usr/{bin,share/{applications,pixmaps}}
- # Copy launcher .sh file
- cp "${_pkgname}.sh" "${pkgdir}/usr/bin/${_pkgname}"
- # Copy .desktop file and icon
- cp "${_pkgname}.desktop" "${pkgdir}/usr/share/applications"
- cp "${_pkgname}/assets/appicon.ico" "${pkgdir}/usr/share/pixmaps/vsmodelcreator.ico"
+ cd ${srcdir}
+ # Create directory structure for launchers
+ install -dm 755 ${pkgdir}/usr/{bin,share/{pixmaps,applications}}
+ # Copy console launcher .sh
+ install -Dm 755 ${_pkgname}.sh ${pkgdir}/usr/bin/${_pkgname}
+ # Copy application icon and .desktop launcher file
+ install -Dm 644 ${_pkgname}/assets/appicon.ico ${pkgdir}/usr/share/pixmaps/${_pkgname}.ico
+ install -Dm 644 ${_pkgname}.desktop ${pkgdir}/usr/share/applications/
}