summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcopygirl2018-02-03 08:02:39 +0100
committercopygirl2018-02-03 08:02:39 +0100
commite27cc2d0cabed08bf1b89025e470b33e6b086bdc (patch)
treeb4b198acddaf7711d1a5adc5f2b93ec32a610eed
parent9870777cf87e761433149155813ff453d5188c36 (diff)
downloadaur-e27cc2d0cabed08bf1b89025e470b33e6b086bdc.tar.gz
Update PKGBUILD based on feedback
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD39
2 files changed, 17 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80e87520180a..03dd07e10bd5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vsmodelcreator-git
pkgdesc = Vintage Story Model Creator
pkgver = r225.75c385c
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/anegostudios/vsmodelcreator
arch = any
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index e66554af4f74..293dfe1c0ba7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,14 @@
# Maintainer: copygirl <copygirl@mcft.net>
_pkgname=vsmodelcreator
-pkgname=${_pkgname}-git
+pkgname=$_pkgname-git
pkgver=r225.75c385c
-pkgrel=1
+pkgrel=2
pkgdesc="Vintage Story Model Creator"
arch=("any")
url="https://github.com/anegostudios/vsmodelcreator"
license=("Apache")
depends=("java-runtime>=8")
makedepends=("git" "java-environment>=8")
-options=()
source=("git://github.com/anegostudios/vsmodelcreator.git"
"vsmodelcreator.desktop"
"vsmodelcreator.sh")
@@ -18,37 +17,31 @@ md5sums=("SKIP"
"c73547c2875d92655e67ed75fd98dd85")
pkgver() {
- cd "${_pkgname}"
+ cd "$_pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "${_pkgname}"
+ cd "$_pkgname"
# Build the application
mkdir -p bin
javac -cp "libs/*" -d bin $(find src -name "*.java")
# Create a .jar file
- jar cfe ${_pkgname}.jar "at.vintagestory.modelcreator.Start" -C bin . -C assets .
- # (Specifying the main entry class here, but
- # not actually using it in the launch script.)
+ jar cfe "$_pkgname".jar "at.vintagestory.modelcreator.Start" -C bin . -C assets .
+ # Specifying the main entry class here, but not actually using it in the launch script.
}
package() {
- cd ${_pkgname}
- # Create directory structure for application in /usr/share/java/vsmodelcreator
- install -dm 755 ${pkgdir}/usr/share/java/${_pkgname}/{,libs,natives/linux}
- # Copies .jar file, libs and native libraries
- install -Dm 755 vsmodelcreator.jar ${pkgdir}/usr/share/java/${_pkgname}/
- install -Dm 644 libs/* ${pkgdir}/usr/share/java/${_pkgname}/libs/
- install -Dm 644 natives/linux/* ${pkgdir}/usr/share/java/${_pkgname}/natives/linux/
- # TODO: See if we can depend on other packages that provide our native dependencies.
-
- cd ${srcdir}
- # Create directory structure for launchers
- install -dm 755 ${pkgdir}/usr/{bin,share/{pixmaps,applications}}
# Copy console launcher .sh
- install -Dm 755 ${_pkgname}.sh ${pkgdir}/usr/bin/${_pkgname}
+ install -Dm755 "$_pkgname".sh "$pkgdir"/usr/bin/"$_pkgname"
# Copy application icon and .desktop launcher file
- install -Dm 644 ${_pkgname}/assets/appicon.ico ${pkgdir}/usr/share/pixmaps/${_pkgname}.ico
- install -Dm 644 ${_pkgname}.desktop ${pkgdir}/usr/share/applications/
+ install -Dm644 "$_pkgname"/assets/appicon.ico "$pkgdir"/usr/share/pixmaps/"$_pkgname".ico
+ install -Dm644 "$_pkgname".desktop "$pkgdir"/usr/share/applications/"$_pkgname".desktop
+
+ cd "$_pkgname"
+ # Copies .jar file, libs and native libraries
+ install -Dm755 vsmodelcreator.jar "$pkgdir"/usr/share/java/"$_pkgname"/vsmodelcreator.jar
+ install -Dm644 -t "$pkgdir"/usr/share/java/"$_pkgname"/libs/ libs/*
+ install -Dm644 -t "$pkgdir"/usr/share/java/"$_pkgname"/natives/linux/ natives/linux/*
+ # TODO: See if we can depend on other packages that provide our native dependencies.
}