summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEroldin2021-11-04 13:17:42 +0100
committerEroldin2021-11-04 13:17:42 +0100
commita99f303dd628fe7582a40951b6af5d2dd3fd4d39 (patch)
treed43a6c9bb6099e0d0d6a50712c07130a9c45f132
downloadaur-a99f303dd628fe7582a40951b6af5d2dd3fd4d39.tar.gz
First upload of VSSH
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..069a1fab0c09
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = vssh-bin
+ pkgdesc = A plugin for VirtualBox which gives easy CLI access to installed OpenSSH Servers on the system without populating the known_hosts file.
+ pkgver = 1.0
+ pkgrel = 0
+ url = https://github.com/Eroldin/vssh
+ arch = x86_64
+ license = CC BY-SA 4.0
+ depends = virtualbox
+ depends = sshpass
+ depends = openssh
+ source = https://github.com/Eroldin/vssh/releases/download/v1.0/vssh-1.0.tbz2
+ sha256sums = 6f888ac72ed5769459cf6322a30a3a7f0e6eba2e8f2682b53175f48ff47583c1
+
+pkgname = vssh-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..210434a14276
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Eroldin <djnightchild at gmail dot com>
+pkgname=vssh-bin
+pkgver=1.0
+pkgrel=0
+pkgdesc="A plugin for VirtualBox which gives easy CLI access to installed OpenSSH Servers on the system without populating the known_hosts file."
+arch=(x86_64)
+url="https://github.com/Eroldin/vssh"
+license=("CC BY-SA 4.0")
+depends=("virtualbox" "sshpass" "openssh")
+source=("https://github.com/Eroldin/vssh/releases/download/v$pkgver/vssh-1.0.tbz2")
+sha256sums=("6f888ac72ed5769459cf6322a30a3a7f0e6eba2e8f2682b53175f48ff47583c1")
+
+package() {
+ # executable
+ install -D -m755 "$srcdir/vssh" "$pkgdir/usr/bin/vssh"
+ #license
+ install -D -m644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/vssh/LICENSE"
+}