summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamLukeYes2020-06-22 23:14:59 +0800
committerSamLukeYes2020-06-22 23:14:59 +0800
commit28e6228cab0b764843e3b594c045d8aa42038683 (patch)
treede74be5ddae6bcc66ebbe4e2e0c34ba34bbcf98a
parente6e131230a294e09eb8cec9719207fbc1ff1d0a0 (diff)
downloadaur-28e6228cab0b764843e3b594c045d8aa42038683.tar.gz
add a launcher script
-rw-r--r--PKGBUILD11
-rw-r--r--vst-video.desktop3
-rw-r--r--vst-video.sh4
3 files changed, 12 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 06248ac52407..3095348789e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=('vst-video-bin')
_pkgname='vst-video'
pkgver=2.55
-pkgrel=1
+pkgrel=2
pkgdesc="Creates a cloud playback platform for Linux."
arch=('x86_64')
url="https://github.com/xymov/vst-video"
@@ -14,9 +14,11 @@ depends=('qt5-multimedia')
makedepends=('tar')
optdepends=()
source=("https://github.com/xymov/vst-video/releases/download/V${pkgver}/${_pkgname}.deb"
- "vst-video.desktop")
+ "${_pkgname}.desktop"
+ "${_pkgname}.sh")
md5sums=('a12bc1fb1d82e0f2ad57ad2310f04176'
- '85395127ed4ce23f7dddfe437fcf9166')
+ 'a5973c32a3023e69c026ffc149d48958'
+ 'a8a7962f0bf293dcf6d73153dfe6f9a8')
install=
prepare() {
@@ -27,7 +29,8 @@ prepare() {
}
package() {
- install -d ${pkgdir}/usr/lib/vst-video ${pkgdir}/usr/share/applications ${pkgdir}/usr/share/icons/vst-video
+ install -d ${pkgdir}/usr/bin ${pkgdir}/usr/lib/vst-video ${pkgdir}/usr/share/applications ${pkgdir}/usr/share/icons/vst-video
+ install -m755 ${srcdir}/vst-video.sh /${pkgdir}/usr/bin/vst-video
install -m755 ${srcdir}/usr/src/vst-video/vst-video ${pkgdir}/usr/lib/vst-video
install -m755 ${srcdir}/vst-video.desktop ${pkgdir}/usr/share/applications
install -m644 ${srcdir}/usr/share/icons/vst-video/icon.svg ${pkgdir}/usr/share/icons/vst-video
diff --git a/vst-video.desktop b/vst-video.desktop
index 62a40c727a16..72e03bde40a7 100644
--- a/vst-video.desktop
+++ b/vst-video.desktop
@@ -2,11 +2,10 @@
Encoding=UTF-8
Categories=AudioVideo;Application;
Comment=vst-video player
-Exec=/usr/lib/vst-video/vst-video %u
+Exec=/usr/bin/vst-video %u
Icon=/usr/share/icons/vst-video/icon.svg
Name=vst-video
Name[zh_CN]=全聚合影视
-Path=/tmp/
Terminal=false
Type=Application
MimeType=application/ogg;application/vnd.apple.mpegurl;application/vnd.rn-realmedia;application/x-extension-mp4;application/x-flac;application/x-matroska;application/x-ogg;application/xspf+xml;image/vnd.rn-realpix;misc/ultravox;video/3gpp;video/dv;video/mp2t;video/mp4;video/x-m4v;video/mp4v-es;video/mpeg;video/msvideo;video/ogg;video/quicktime;video/vnd.rn-realvideo;video/webm;video/x-anim;video/x-avi;video/x-flc;video/x-fli;video/x-flv;video/x-matroska;video/x-mpeg;video/x-ms-asf;video/x-msvideo;video/x-ms-wmv;video/x-nsv;video/x-ogm+ogg;video/x-theora+ogg;x-content/video-dvd;x-content/video-svcd;x-content/video-vcd;x-scheme-handler/mms;x-scheme-handler/rtmp;x-scheme-handler/rtsp;
diff --git a/vst-video.sh b/vst-video.sh
new file mode 100644
index 000000000000..615b08100523
--- /dev/null
+++ b/vst-video.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+mkdir -p ~/.cache/vst-video
+cd ~/.cache/vst-video
+/usr/lib/vst-video/vst-video $@ \ No newline at end of file