summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamLukeYes2020-06-22 21:40:44 +0800
committerSamLukeYes2020-06-22 21:40:44 +0800
commite6e131230a294e09eb8cec9719207fbc1ff1d0a0 (patch)
tree7987d954a9694497a86138814faa678bef517f7a
downloadaur-e6e131230a294e09eb8cec9719207fbc1ff1d0a0.tar.gz
add package
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
-rw-r--r--vst-video.desktop14
4 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..435d31d757da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vst-video-bin
+ pkgdesc = Creates a cloud playback platform for Linux.
+ pkgver = 2.55
+ pkgrel = 1
+ url = https://github.com/xymov/vst-video
+ arch = x86_64
+ groups =
+ license = GPL3
+ makedepends = tar
+ depends = qt5-multimedia
+ provides = vst-video
+ source = https://github.com/xymov/vst-video/releases/download/V2.55/vst-video.deb
+ source = vst-video.desktop
+ md5sums = a12bc1fb1d82e0f2ad57ad2310f04176
+ md5sums = 85395127ed4ce23f7dddfe437fcf9166
+
+pkgname = vst-video-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1749e8b7d082
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar*
+src/
+pkg/
+*.deb \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06248ac52407
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Sam L. Yes <manjaroyes123@outlook.com>
+
+pkgname=('vst-video-bin')
+_pkgname='vst-video'
+pkgver=2.55
+pkgrel=1
+pkgdesc="Creates a cloud playback platform for Linux."
+arch=('x86_64')
+url="https://github.com/xymov/vst-video"
+license=('GPL3')
+groups=('')
+provides=(${_pkgname})
+depends=('qt5-multimedia')
+makedepends=('tar')
+optdepends=()
+source=("https://github.com/xymov/vst-video/releases/download/V${pkgver}/${_pkgname}.deb"
+ "vst-video.desktop")
+md5sums=('a12bc1fb1d82e0f2ad57ad2310f04176'
+ '85395127ed4ce23f7dddfe437fcf9166')
+install=
+
+prepare() {
+ #mkdir -p ${srcdir}/pkg/usr/bin
+ tar xf ${srcdir}/data.tar.xz -C ${srcdir}
+ #mv ${srcdir}/pkg/usr/src/vst-video ${srcdir}/pkg/usr/bin/
+ #cp -f ${srcdir}/vst-video.desktop ${srcdir}/pkg/usr/share/applications/
+}
+
+package() {
+ install -d ${pkgdir}/usr/lib/vst-video ${pkgdir}/usr/share/applications ${pkgdir}/usr/share/icons/vst-video
+ install -m755 ${srcdir}/usr/src/vst-video/vst-video ${pkgdir}/usr/lib/vst-video
+ install -m755 ${srcdir}/vst-video.desktop ${pkgdir}/usr/share/applications
+ install -m644 ${srcdir}/usr/share/icons/vst-video/icon.svg ${pkgdir}/usr/share/icons/vst-video
+}
diff --git a/vst-video.desktop b/vst-video.desktop
new file mode 100644
index 000000000000..62a40c727a16
--- /dev/null
+++ b/vst-video.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Encoding=UTF-8
+Categories=AudioVideo;Application;
+Comment=vst-video player
+Exec=/usr/lib/vst-video/vst-video %u
+Icon=/usr/share/icons/vst-video/icon.svg
+Name=vst-video
+Name[zh_CN]=全聚合影视
+Path=/tmp/
+Terminal=false
+Type=Application
+MimeType=application/ogg;application/vnd.apple.mpegurl;application/vnd.rn-realmedia;application/x-extension-mp4;application/x-flac;application/x-matroska;application/x-ogg;application/xspf+xml;image/vnd.rn-realpix;misc/ultravox;video/3gpp;video/dv;video/mp2t;video/mp4;video/x-m4v;video/mp4v-es;video/mpeg;video/msvideo;video/ogg;video/quicktime;video/vnd.rn-realvideo;video/webm;video/x-anim;video/x-avi;video/x-flc;video/x-fli;video/x-flv;video/x-matroska;video/x-mpeg;video/x-ms-asf;video/x-msvideo;video/x-ms-wmv;video/x-nsv;video/x-ogm+ogg;video/x-theora+ogg;x-content/video-dvd;x-content/video-svcd;x-content/video-vcd;x-scheme-handler/mms;x-scheme-handler/rtmp;x-scheme-handler/rtsp;
+
+