summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2015-07-15 20:06:54 -0700
committerLlewelyn Trahaearn2015-07-15 20:06:54 -0700
commit3a92a8417a68d62e7fcb78852f4d3ec484f8801b (patch)
tree8cf0f6a7a01bf99abb1ff4dde5779407246358e2
downloadaur-3a92a8417a68d62e7fcb78852f4d3ec484f8801b.tar.gz
Initial import.
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD36
-rw-r--r--vsxu.install12
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..012a07e7ee5a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = vsxu
+ pkgdesc = A free to use program that lets you create and perform real-time audio visual presets.
+ pkgver = 0.5.1
+ pkgrel = 1
+ url = http://www.vsxu.com/
+ install = vsxu.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = custom
+ makedepends = cmake
+ depends = jack
+ depends = glew
+ depends = glfw2
+ depends = opencv
+ depends = libpng12
+ depends = desktop-file-utils
+ depends = xdg-utils
+ provides = vsxu
+ conflicts = vsxu
+ source = https://github.com/vovoid/vsxu/archive/v0.5.1.tar.gz
+ sha512sums = e77d8e7300a43ceeb59cf39771f0d8ac8930cebffb4d25305a9e245fd5e2d668e126267227c5334f999688307f8b22cf30183c495137f7490942d78581d0d4a6
+
+pkgname = vsxu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8f1038c3e59
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Llewelyn Trahaearn <WoefulDerelict at GMail dot com>
+# Contributor: speps <speps at aur dot archlinux dot org>
+pkgname=vsxu
+pkgver=0.5.1
+pkgrel=1
+pkgdesc="A free to use program that lets you create and perform real-time audio visual presets."
+arch=('i686' 'x86_64')
+url="http://www.vsxu.com/"
+license=('GPL' 'custom')
+depends=('jack' 'glew' 'glfw2' 'opencv' 'libpng12' 'desktop-file-utils' 'xdg-utils')
+makedepends=('cmake')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+install=${pkgname}.install
+source=("https://github.com/vovoid/vsxu/archive/v${pkgver}.tar.gz")
+sha512sums=('e77d8e7300a43ceeb59cf39771f0d8ac8930cebffb4d25305a9e245fd5e2d668e126267227c5334f999688307f8b22cf30183c495137f7490942d78581d0d4a6')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ [[ -d build ]] || mkdir build && cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
+ -DGLFW_LIBRARY=/usr/lib/libglfw2.so \
+ -DPNG_LIBRARY=/usr/lib/libpng12.so \
+ -DPNG_PNG_INCLUDE_DIR=/usr/include/libpng12
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}/build"
+ make DESTDIR="${pkgdir}" install
+
+ # License.
+ install -Dm644 ../COPYING \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/vsxu.install b/vsxu.install
new file mode 100644
index 000000000000..bce670aff4af
--- /dev/null
+++ b/vsxu.install
@@ -0,0 +1,12 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}