summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2018-08-11 07:59:01 -0700
committerLlewelyn Trahaearn2018-08-11 07:59:01 -0700
commit796a4a983669a6759c97af0bb51bc6481d4a0b28 (patch)
tree14d69661ee535ad4212909c6654cdeb75faf15a7
parenteab0292b4c21f7dc9c78e82837c6492d76bef51c (diff)
downloadaur-796a4a983669a6759c97af0bb51bc6481d4a0b28.tar.gz
Mend build by setting OpenGL_GL_PREFERENCE to GLVND for cmake and include missing dependency.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 272ae9750a36..cf3e0bc2b4fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Fri Aug 25 17:08:52 UTC 2017
pkgbase = vsxu
pkgdesc = A free to use program that lets you create and perform real-time audio visual presets.
pkgver = 0.6.2
- pkgrel = 1
+ pkgrel = 2
url = http://www.vsxu.com/
arch = i686
arch = x86_64
@@ -18,6 +16,7 @@ pkgbase = vsxu
depends = glew
depends = libpng
depends = opencv
+ depends = sdl2
depends = xdg-utils
optdepends = alsa-lib: ALSA support.
optdepends = jack: JACK support
diff --git a/PKGBUILD b/PKGBUILD
index 2637382c65bd..5ce49c34b1c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=vsxu
pkgver=0.6.2
-pkgrel=1
+pkgrel=2
pkgdesc="A free to use program that lets you create and perform real-time audio visual presets."
arch=('i686' 'x86_64')
url="http://www.vsxu.com/"
license=('GPL' 'custom')
-depends=('desktop-file-utils' 'glew' 'libpng' 'opencv' 'xdg-utils')
+depends=('desktop-file-utils' 'glew' 'libpng' 'opencv' 'sdl2' 'xdg-utils')
makedepends=('alsa-lib' 'cmake' 'git' 'jack' 'pulseaudio')
optdepends=(
'alsa-lib: ALSA support.'
@@ -54,7 +54,8 @@ pkgver() {
build() {
cd "${pkgname}/build"
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
+ -DOpenGL_GL_PREFERENCE=GLVND
make
}