summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2016-01-27 04:04:36 -0800
committerLlewelyn Trahaearn2016-01-27 04:04:36 -0800
commitbcac8d8240a58ab28db05c81aceb92b2a67f8cba (patch)
treef257882144c67841bfb1c8261c5cf9b71c59d3ce
parentb9b4a8b353c6f2bdee34eb37308ccf530455c873 (diff)
downloadaur-bcac8d8240a58ab28db05c81aceb92b2a67f8cba.tar.gz
Dependency tuning.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
2 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 837cc488001..a7d6349b108 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Wed Jan 27 12:04:23 UTC 2016
pkgbase = vsxu
pkgdesc = A free to use program that lets you create and perform real-time audio visual presets.
pkgver = 0.5.1
@@ -8,15 +10,19 @@ pkgbase = vsxu
arch = x86_64
license = GPL
license = custom
+ makedepends = alsa-lib
makedepends = cmake
- depends = pulseaudio
+ makedepends = pulseaudio
+ makedepends = jack
+ depends = desktop-file-utils
depends = glew
depends = glfw2
depends = opencv
depends = libpng12
- depends = desktop-file-utils
depends = xdg-utils
- optdepends = jack: alternate audio source
+ optdepends = alsa-lib: ALSA support.
+ optdepends = jack: JACK support
+ optdepends = pulseaudio: PulseAudio support
provides = vsxu
conflicts = vsxu
source = https://github.com/vovoid/vsxu/archive/v0.5.1.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index a5c9333f149..ec2cf56b3f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,9 +8,13 @@ pkgdesc="A free to use program that lets you create and perform real-time audio
arch=('i686' 'x86_64')
url="http://www.vsxu.com/"
license=('GPL' 'custom')
-depends=('pulseaudio' 'glew' 'glfw2' 'opencv' 'libpng12' 'desktop-file-utils' 'xdg-utils')
-makedepends=('cmake')
-optdepends=( 'jack: alternate audio source')
+depends=('desktop-file-utils' 'glew' 'glfw2' 'opencv' 'libpng12' 'xdg-utils')
+makedepends=('alsa-lib' 'cmake' 'pulseaudio' 'jack')
+optdepends=(
+ 'alsa-lib: ALSA support.'
+ 'jack: JACK support'
+ 'pulseaudio: PulseAudio support'
+)
provides=("${pkgname}")
conflicts=("${pkgname}")
install=${pkgname}.install