summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorml2020-03-07 20:47:29 +0100
committerml2020-03-07 20:47:29 +0100
commit1de553fc38def49f13d3605041a8ca1c3d02f3d7 (patch)
treeeefbcbad9725bbc283809868643271a8f17be100
parentb001d437d49eaf4010d363445d267734ff3984e1 (diff)
downloadaur-1de553fc38def49f13d3605041a8ca1c3d02f3d7.tar.gz
upgpkg: vt-cli 0.7.0-4
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD38
2 files changed, 23 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c75c430835aa..90703d9b2dff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = vt-cli
pkgdesc = VirusTotal Command Line Interface
pkgver = 0.7.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/VirusTotal/vt-cli
arch = i686
arch = x86_64
license = Apache
+ makedepends = git
makedepends = go
makedepends = dep
+ depends = glibc
source = vt-cli-0.7.0.tar.gz::https://github.com/VirusTotal/vt-cli/archive/0.7.0.tar.gz
sha512sums = 2064b4a34c80ae71b199c870acef4a42f64f79718bb1cd74eb00027b47f334fba23287433be8d86995a9a82fd0f1bbf8c243b6177612005eea7900cdfe3968d0
diff --git a/PKGBUILD b/PKGBUILD
index e647d5b0a727..35feab6e3bec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,39 @@
# Maintainer: Matthias Lisin <ml@visu.li
pkgname=vt-cli
pkgver=0.7.0
-pkgrel=3
+pkgrel=4
pkgdesc='VirusTotal Command Line Interface'
arch=('i686' 'x86_64')
url='https://github.com/VirusTotal/vt-cli'
license=('Apache')
-makedepends=('go' 'dep')
+depends=('glibc')
+makedepends=('git' 'go' 'dep')
source=("$pkgname-$pkgver.tar.gz::${url}/archive/${pkgver}.tar.gz")
sha512sums=('2064b4a34c80ae71b199c870acef4a42f64f79718bb1cd74eb00027b47f334fba23287433be8d86995a9a82fd0f1bbf8c243b6177612005eea7900cdfe3968d0')
_gopkg=gopath/src/github.com/VirusTotal/"$pkgname"
prepare() {
- export GOPATH="$srcdir/gopath"
- mkdir -p "${_gopkg%/*}"
- ln -frs "$pkgname-$pkgver" "$_gopkg"
- cd "$_gopkg"
- dep ensure
+ export GOPATH="$srcdir/gopath"
+ mkdir -p "${_gopkg%/*}"
+ ln -frs "$pkgname-$pkgver" "$_gopkg"
+ cd "$_gopkg"
+ dep ensure
}
build() {
- export GOPATH="$srcdir/gopath"
- cd "$_gopkg"
- LDFLAGS+=" -X github.com/VirusTotal/vt-cli/cmd.Version=${pkgver}"
- go build -trimpath \
- -ldflags "-extldflags=${LDFLAGS}" \
- -buildmode=pie -o build/vt vt/main.go
+ export GOPATH="$srcdir/gopath"
+ cd "$_gopkg"
+ LDFLAGS+=" -X github.com/VirusTotal/vt-cli/cmd.Version=${pkgver}"
+ go build -trimpath \
+ -buildmode=pie \
+ -ldflags "-extldflags=${LDFLAGS}" \
+ -o build/vt vt/main.go
}
package() {
- cd "$pkgname-$pkgver"
- install -dm755 "$pkgdir"/usr/share/{bash-completion/completions,zsh/site-functions}
- install -Dm755 build/vt "$pkgdir"/usr/bin/vt
- build/vt completion bash > "$pkgdir"/usr/share/bash-completion/completions/vt
- build/vt completion zsh > "$pkgdir"/usr/share/zsh/site-functions/_vt
+ cd "$pkgname-$pkgver"
+ install -dm755 "$pkgdir"/usr/share/{bash-completion/completions,zsh/site-functions}
+ install -Dm755 build/vt "$pkgdir"/usr/bin/vt
+ build/vt completion bash >"$pkgdir"/usr/share/bash-completion/completions/vt
+ build/vt completion zsh >"$pkgdir"/usr/share/zsh/site-functions/_vt
}