summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDevin J. Pohly2015-07-02 13:50:44 -0400
committerDevin J. Pohly2015-07-02 13:50:44 -0400
commit6b355be0aff54617114fb90239a0a0b58fa05aaf (patch)
treef2f0c504ce120725901779417f61c7cf8b3d8c8b
downloadaur-6b355be0aff54617114fb90239a0a0b58fa05aaf.tar.gz
Import from AUR3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..86e7c5473e33
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = vtclock
+ pkgdesc = Text-mode full-screen digital clock
+ pkgver = 20050220
+ pkgrel = 2
+ url = http://webonastick.com/vtclock
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = ncurses
+ source = http://webonastick.com/vtclock/vtclock-2005-02-20.tar.gz
+ sha1sums = aabc321bd46ceb9015ee5cd84b526487d63f2dc1
+
+pkgname = vtclock
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93886c5e93d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Devin J. Pohly <djpohly+arch@djpohly.com>
+pkgname=vtclock
+pkgver=20050220
+pkgrel=2
+pkgdesc="Text-mode full-screen digital clock"
+arch=(i686 x86_64)
+url="http://webonastick.com/vtclock"
+license=('GPL')
+depends=(ncurses)
+source=("http://webonastick.com/$pkgname/$pkgname-2005-02-20.tar.gz")
+sha1sums=('aabc321bd46ceb9015ee5cd84b526487d63f2dc1')
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ # Makefile doesn't do this for us...
+ install -d "$pkgdir/usr/bin"
+ make prefix="$pkgdir/usr/" install
+}
+
+# vim:set ts=2 sw=2 et: