summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRay Song2016-05-07 15:32:46 +0800
committerRay Song2016-05-07 15:33:07 +0800
commit3765f59b0ace9a5d7b05fb5e88062a9dc687dd6f (patch)
tree34f21004af66f459cf60cae49c1809475173b642
parent59143402066b299aedf36b42e33c5760a9252731 (diff)
downloadaur-3765f59b0ace9a5d7b05fb5e88062a9dc687dd6f.tar.gz
filesystem:https:// url selection
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
-rw-r--r--fullwidth-emoji.patch15
3 files changed, 18 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8469438a993d..2e38f3343b56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vte3-ng-fullwidth-emoji
pkgdesc = Enhanced Virtual Terminal Emulator widget for use with GTK3 (patched with support for fullwidth emoji)
pkgver = 0.44.1.a
- pkgrel = 1
+ pkgrel = 3
url = https://github.com/thestinger/vte-ng
arch = i686
arch = x86_64
@@ -27,7 +27,7 @@ pkgbase = vte3-ng-fullwidth-emoji
source = https://github.com/thestinger/vte-ng/archive/0.44.1.a.tar.gz
source = fullwidth-emoji.patch
sha256sums = 63c01b8bc3299086e7fb30e59fd3af879326f6f6d7629e46fdeeb344f9be141b
- sha256sums = 85e9c7f2014419238077f0cbe3fc522dc8afc81430dd49840cd1e33622623270
+ sha256sums = SKIP
pkgname = vte3-ng-fullwidth-emoji
diff --git a/PKGBUILD b/PKGBUILD
index 15ecb5a4fd3b..977b04270b87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ makedepends=('intltool' 'gobject-introspection' 'gtk3' 'vala' 'gtk-doc' 'gperf')
url="https://github.com/thestinger/vte-ng"
source=(https://github.com/thestinger/vte-ng/archive/$pkgver.tar.gz fullwidth-emoji.patch)
sha256sums=('63c01b8bc3299086e7fb30e59fd3af879326f6f6d7629e46fdeeb344f9be141b'
- '85e9c7f2014419238077f0cbe3fc522dc8afc81430dd49840cd1e33622623270')
+ 'SKIP')
provides=(vte3=$_basever vte3-select-text=$_basever vte3-ng)
conflicts=(vte3 vte3-select-text vte3-ng)
replaces=(vte3-select-text vte3-ng)
diff --git a/fullwidth-emoji.patch b/fullwidth-emoji.patch
index ba6ce297fad5..a9a1a7aafe53 100644
--- a/fullwidth-emoji.patch
+++ b/fullwidth-emoji.patch
@@ -50,3 +50,18 @@
}
/* Cursor left N columns. */
+diff --git i/src/app.vala w/src/app.vala
+index 8104964..cc871d8 100644
+--- i/src/app.vala
++++ w/src/app.vala
+@@ -214,8 +214,8 @@ class Window : Gtk.ApplicationWindow
+ private uint launch_idle_id;
+
+ private string[] builtin_dingus = {
+- "(((gopher|news|telnet|nntp|file|http|ftp|https)://)|(www|ftp)[-A-Za-z0-9]*\\.)[-A-Za-z0-9\\.]+(:[0-9]*)?",
+- "(((gopher|news|telnet|nntp|file|http|ftp|https)://)|(www|ftp)[-A-Za-z0-9]*\\.)[-A-Za-z0-9\\.]+(:[0-9]*)?/[-A-Za-z0-9_\\$\\.\\+\\!\\*\\(\\),;:@&=\\?/~\\#\\%]*[^]'\\.}>\\) ,\\\"]"
++ "((((filesystem|gopher|news|telnet|nntp|file|http|ftp|https):)+//)|(www|ftp)[-A-Za-z0-9]*\\.)[-A-Za-z0-9\\.]+(:[0-9]*)?",
++ "((((filesystem|gopher|news|telnet|nntp|file|http|ftp|https):)+//)|(www|ftp)[-A-Za-z0-9]*\\.)[-A-Za-z0-9\\.]+(:[0-9]*)?/[-A-Za-z0-9_\\$\\.\\+\\!\\*\\(\\),;:@&=\\?/~\\#\\%]*[^]'\\.}>\\) ,\\\"]"
+ };
+
+ private const GLib.ActionEntry[] action_entries = {