summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelipe Contreras2022-01-23 23:57:59 -0600
committerFelipe Contreras2022-01-23 23:58:43 -0600
commit3fcfcb909d672d1d40177f11769c1e97cc937695 (patch)
tree969734829b95c79a2b668dbe726f9f5b612beee6
parent463b13e12aa9b2d19cbbeda07be533d4bb3f050d (diff)
downloadaur-3fcfcb909d672d1d40177f11769c1e97cc937695.tar.gz
Update patch
Signed-off-by: Felipe Contreras <felipe.contreras@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--fix-exit-regression.patch34
3 files changed, 27 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d614792704e..5e664836d42b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vte3-nohang
pkgdesc = Virtual Terminal Emulator widget (plus no-hang patch)
pkgver = 0.66.2
- pkgrel = 1
+ pkgrel = 2
url = https://wiki.gnome.org/Apps/Terminal/VTE
arch = x86_64
license = LGPL
@@ -23,6 +23,6 @@ pkgbase = vte3-nohang
source = git+https://gitlab.gnome.org/GNOME/vte.git#tag=0.66.2
source = fix-exit-regression.patch
sha256sums = SKIP
- sha256sums = 582edbac0c92cb023a4c0a8f70cb74c85606c139ab8c8f83f6093a21e3033a5c
+ sha256sums = 269072f4f65f42ac0338039c69bd03cb767fc08f837a78d12c11c9487397a195
pkgname = vte3-nohang
diff --git a/PKGBUILD b/PKGBUILD
index 972d3c879ca6..09552ca2247e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=vte3-nohang
pkgver=0.66.2
-pkgrel=1
+pkgrel=2
pkgdesc="Virtual Terminal Emulator widget (plus no-hang patch)"
url="https://wiki.gnome.org/Apps/Terminal/VTE"
arch=(x86_64)
@@ -14,7 +14,7 @@ makedepends=(gobject-introspection vala git gtk-doc gperf meson)
source=("git+https://gitlab.gnome.org/GNOME/vte.git#tag=$pkgver"
fix-exit-regression.patch)
sha256sums=('SKIP'
- '582edbac0c92cb023a4c0a8f70cb74c85606c139ab8c8f83f6093a21e3033a5c')
+ '269072f4f65f42ac0338039c69bd03cb767fc08f837a78d12c11c9487397a195')
depends+=(vte-common)
provides=("vte3=$pkgver" libvte-2.91.so)
diff --git a/fix-exit-regression.patch b/fix-exit-regression.patch
index eeaf3afba227..a15d882899b8 100644
--- a/fix-exit-regression.patch
+++ b/fix-exit-regression.patch
@@ -1,6 +1,6 @@
-From 21514e6d4f38cdf4d5ce9186c2dcc8e6bb63ce15 Mon Sep 17 00:00:00 2001
+From 0552a83b044517a35f48c42fd8eed8b6eda09656 Mon Sep 17 00:00:00 2001
From: Felipe Contreras <felipe.contreras@gmail.com>
-Date: Sun, 6 Dec 2020 04:01:03 -0600
+Date: Sun, 23 Jan 2022 23:36:44 -0600
Subject: [PATCH] Fix exit regression
Any time you start a job in the background vte gets confused and waits
@@ -19,28 +19,40 @@ was reported more than one year ago.
https://gitlab.gnome.org/GNOME/vte/-/issues/204
-With this patch we can return to the behavior of 0.59, where the
-terminal exits immediately.
+We know the child has exited, the client does not. It's up to the client
+to decide if it was to wait for rest of the input, or exit immediately.
+
+So send the signal as soon as we receive it.
Signed-off-by: Felipe Contreras <felipe.contreras@gmail.com>
---
- src/vte.cc | 3 +++
- 1 file changed, 3 insertions(+)
+ src/vte.cc | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/vte.cc b/src/vte.cc
-index 2614e5b4..ea80d1ee 100644
+index 103dc4d5..c47c10af 100644
--- a/src/vte.cc
+++ b/src/vte.cc
-@@ -3130,6 +3130,9 @@ Terminal::child_watch_done(pid_t pid,
+@@ -3200,6 +3200,9 @@ Terminal::child_watch_done(pid_t pid,
m_pty_pid = -1;
-+ if (pty())
-+ unset_pty();
++ if (widget())
++ widget()->emit_child_exited(status);
+
/* If we still have a PTY, or data to process, defer emitting the signals
* until we have EOF on the PTY, so that we can process all pending data.
*/
+@@ -3210,9 +3213,6 @@ Terminal::child_watch_done(pid_t pid,
+ m_child_exited_eos_wait_timer.schedule_seconds(2); // FIXME: better value?
+ } else {
+ m_child_exited_after_eos_pending = false;
+-
+- if (widget())
+- widget()->emit_child_exited(status);
+ }
+ }
+
--
-2.29.2
+2.34.1