summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelipe Contreras2023-02-24 12:43:30 -0600
committerFelipe Contreras2023-02-24 12:43:30 -0600
commitea0c5e228a7b7f6e462ec396b68e07c25618275c (patch)
tree38c0b7067642bef3745b5675aea68ce3a715247d
parent604afeb20b442f09f8f7f66153e96cf6aa0c15a8 (diff)
downloadaur-ea0c5e228a7b7f6e462ec396b68e07c25618275c.tar.gz
Update regression fix patch
Signed-off-by: Felipe Contreras <felipe.contreras@gmail.com>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--fix-exit-regression.patch8
3 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 036f2dab4dab..2fe1a636aeff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -22,6 +22,6 @@ pkgbase = vte3-nohang
source = https://gitlab.gnome.org/GNOME/vte/-/archive/0.70.3/vte-0.70.3.tar.bz2
source = fix-exit-regression.patch
sha256sums = 94d0b6776d55252bc1f15995c1ade7eb44b4a2c99531487eba9b8bded1a0fe2f
- sha256sums = b7175b365c87b4014725a690448db716e22c27636fc03c08c5a4bc516798871e
+ sha256sums = 7c2e392a6178c6926458a7c79bfdbacac911632f799a98d581b69d2c5d1f9b86
pkgname = vte3-nohang
diff --git a/PKGBUILD b/PKGBUILD
index a29a974e2ce4..8677e32b3791 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ options=(!lto)
source=("https://gitlab.gnome.org/GNOME/vte/-/archive/$pkgver/vte-$pkgver.tar.bz2"
fix-exit-regression.patch)
sha256sums=('94d0b6776d55252bc1f15995c1ade7eb44b4a2c99531487eba9b8bded1a0fe2f'
- 'b7175b365c87b4014725a690448db716e22c27636fc03c08c5a4bc516798871e')
+ '7c2e392a6178c6926458a7c79bfdbacac911632f799a98d581b69d2c5d1f9b86')
provides=("vte3=$pkgver" libvte-2.91.so)
conflicts=(vte3)
diff --git a/fix-exit-regression.patch b/fix-exit-regression.patch
index 0415808df2be..387bb2905058 100644
--- a/fix-exit-regression.patch
+++ b/fix-exit-regression.patch
@@ -1,4 +1,4 @@
-From a8f9b3299a2f996070ae8242eb5546083b648639 Mon Sep 17 00:00:00 2001
+From 76bbbf8486d73bb830c5c513eefc3ba0d0656481 Mon Sep 17 00:00:00 2001
From: Felipe Contreras <felipe.contreras@gmail.com>
Date: Sun, 23 Jan 2022 23:36:44 -0600
Subject: [PATCH] Fix exit regression
@@ -28,10 +28,10 @@ Signed-off-by: Felipe Contreras <felipe.contreras@gmail.com>
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/src/vte.cc b/src/vte.cc
-index 8b75883f..da296daf 100644
+index 7cc26c48..80f26454 100644
--- a/src/vte.cc
+++ b/src/vte.cc
-@@ -10124,7 +10124,6 @@ Terminal::emit_pending_signals()
+@@ -10273,7 +10273,6 @@ Terminal::emit_pending_signals()
m_bell_pending = false;
}
@@ -39,7 +39,7 @@ index 8b75883f..da296daf 100644
if (m_eos_pending) {
queue_eof();
m_eos_pending = false;
-@@ -10132,7 +10131,7 @@ Terminal::emit_pending_signals()
+@@ -10281,7 +10280,7 @@ Terminal::emit_pending_signals()
unset_pty();
}