summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormydongistiny2020-03-08 14:12:06 -0700
committermydongistiny2020-03-08 14:12:09 -0700
commit2ea134938d0f90b1afbbef0409d153c206f4a09b (patch)
tree5ff113305ff1d8e1d24f5fba38d0b7aad1c09912
parent6876155052826bb9f2c426944b7b006092c76cc4 (diff)
downloadaur-2ea134938d0f90b1afbbef0409d153c206f4a09b.tar.gz
Update to version 0.60.0 and f32
Disable LTO when building or else it will fail Signed-off-by: mydongistiny <jaysonedson@gmail.com>
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7ed65c91a9e..eb80b0b7db15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vte3-notification
pkgdesc = Virtual Terminal Emulator widget for use with GTK3 with Fedora patches
- pkgver = 0.58.3
- pkgrel = 2
+ pkgver = 0.60.0
+ pkgrel = 1
url = https://wiki.gnome.org/Apps/Terminal/VTE
arch = i686
arch = x86_64
@@ -19,23 +19,23 @@ pkgbase = vte3-notification
depends = pcre2
depends = gnutls
options = !emptydirs
- source = git+https://git.gnome.org/browse/vte#tag=0.58.3
- source = vte291-cntnr-precmd-preexec-scroll.patch-b067afd77f6dbc789b9844dbe4b455ed77540464::https://src.fedoraproject.org/rpms/vte291/raw/b067afd77f6dbc789b9844dbe4b455ed77540464/f/vte291-cntnr-precmd-preexec-scroll.patch
+ source = git+https://git.gnome.org/browse/vte#tag=0.60.0
+ source = vte291-cntnr-precmd-preexec-scroll.patch-c2f2db14c1a858d79c69f344650c38987a675d09::https://src.fedoraproject.org/rpms/vte291/raw/c2f2db14c1a858d79c69f344650c38987a675d09/f/vte291-cntnr-precmd-preexec-scroll.patch
sha256sums = SKIP
- sha256sums = 9e2f27aad738d11226161f066c0eefc831a3aa1ec6f043d53104382a8e752d2d
+ sha256sums = 714470357ea008de821d62f60e551351d2379a4ef723410909fba3f68e7b57b0
pkgname = vte3-notification
depends = gtk3
depends = pcre2
depends = gnutls
depends = vte-notification-common
- provides = vte3=0.58.3
+ provides = vte3=0.60.0
conflicts = vte3
pkgname = vte-notification-common
pkgdesc = Common files used by vte and vte3
arch = any
depends = sh
- provides = vte-common=0.58.3
+ provides = vte-common=0.60.0
conflicts = vte-common
diff --git a/PKGBUILD b/PKGBUILD
index 307e63f6e66b..c7a3e6af6b37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
pkgbase='vte3-notification'
pkgname=("${pkgbase}" 'vte-notification-common')
-pkgver=0.58.3
-pkgrel=2
+pkgver=0.60.0
+pkgrel=1
pkgdesc='Virtual Terminal Emulator widget for use with GTK3 with Fedora patches'
arch=('i686' 'x86_64')
url='https://wiki.gnome.org/Apps/Terminal/VTE'
@@ -18,9 +18,9 @@ options=('!emptydirs')
# Fedora patches: https://pkgs.fedoraproject.org/cgit/rpms/vte291.git/tree/
_frepourl='https://src.fedoraproject.org/rpms/vte291'
-_frepobranch='f31'
+_frepobranch='f32'
_fpatchfile='vte291-cntnr-precmd-preexec-scroll.patch'
-_fcommit='b067afd77f6dbc789b9844dbe4b455ed77540464'
+_fcommit='c2f2db14c1a858d79c69f344650c38987a675d09'
# VTE source ref
_vtetag=${pkgver}
@@ -30,7 +30,7 @@ source=(
"${_fpatchfile}-${_fcommit}::${_frepourl}/raw/${_fcommit}/f/${_fpatchfile}"
)
sha256sums=('SKIP'
- '9e2f27aad738d11226161f066c0eefc831a3aa1ec6f043d53104382a8e752d2d')
+ '714470357ea008de821d62f60e551351d2379a4ef723410909fba3f68e7b57b0')
prepare () {
cd "vte"
@@ -39,7 +39,7 @@ prepare () {
}
build() {
- arch-meson vte build -D docs=true
+ arch-meson vte build -Db_lto=false -D docs=true
ninja -C build
}