summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelipe Contreras2023-03-18 09:12:17 -0600
committerFelipe Contreras2023-03-18 09:39:06 -0600
commit1b06ed779fadd25b830749f4c578117fc2af5e25 (patch)
tree2f681ee9b5de9d6cb91b969ebc117b5ad62072c7
parentbd27347bebdc0d6a4e41c7f4775342f9244c4358 (diff)
downloadaur-1b06ed779fadd25b830749f4c578117fc2af5e25.tar.gz
Reuse common vte-common
No need to package it ourselves.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 7 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7d2900f03d3..4abe01c9d83f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -28,7 +28,7 @@ pkgname = vte3-tilix
depends = gtk3
depends = pcre2
depends = gnutls
- depends = vte-tilix-common
+ depends = vte-common
provides = vte3=0.70.3
provides = vte3-notification=0.70.3-2
provides = vte3-terminix-git
@@ -36,14 +36,3 @@ pkgname = vte3-tilix
conflicts = vte3
conflicts = vte3-notification
conflicts = vte3-terminix-git
-
-pkgname = vte-tilix-common
- pkgdesc = Common files used by vte and vte3
- arch = any
- depends = sh
- provides = vte-common=0.70.3
- provides = vte-notification-common=0.70.3-2
- provides = vte-terminix-common-git
- conflicts = vte-common
- conflicts = vte-notification-common
- conflicts = vte3-terminix-common-git
diff --git a/PKGBUILD b/PKGBUILD
index dbce2d6b7ecd..39f799cc963a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
# Maintainer: Alex Dewar <alex.dewar@gmx.co.uk>
# Contributer: Davi da Silva Böger <dsboger@gmail.com>
-pkgbase='vte3-tilix'
-pkgname=("${pkgbase}" 'vte-tilix-common')
+pkgname='vte3-tilix'
pkgver=0.70.3
pkgrel=1
pkgdesc='Virtual Terminal Emulator widget (GTK3) (Fedora and Tilix patches)'
@@ -47,20 +46,14 @@ build() {
}
package_vte3-tilix(){
- depends+=('vte-tilix-common')
+ depends+=('vte-common')
provides=("vte3=${pkgver}" "vte3-notification=${pkgver}-2" 'vte3-terminix-git')
provides+=(libvte-2.91.so)
conflicts=('vte3' 'vte3-notification' 'vte3-terminix-git')
meson install -C build --destdir "$pkgdir"
- rm "${pkgdir}/etc/profile.d/vte.sh"
-}
-
-package_vte-tilix-common() {
- depends=('sh')
- pkgdesc='Common files used by vte and vte3'
- arch=('any')
- provides=("vte-common=${pkgver}" "vte-notification-common=${pkgver}-2" 'vte-terminix-common-git')
- conflicts=('vte-common' 'vte-notification-common' 'vte3-terminix-common-git')
- install -Dm644 'build/src/vte.sh' "${pkgdir}/etc/profile.d/vte.sh"
+ # remove vte-common
+ rm -r "$pkgdir"/etc
+ rm -r "$pkgdir"/usr/lib/{systemd,vte-urlencode-cwd}
+ rm -r "$pkgdir"/usr/share/locale/
}