summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavi da Silva Böger2017-03-20 13:18:46 -0300
committerDavi da Silva Böger2017-03-20 13:18:46 -0300
commit636193db1c418d09b0669e6d2a40381cd7c46e7b (patch)
tree677eb643b4e9be7846168547244b862da3b1eef1
parent6cd1f2ac0aa437298dbbc8f44e3b851571e5932d (diff)
downloadaur-636193db1c418d09b0669e6d2a40381cd7c46e7b.tar.gz
Add missing provides/conflicts
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f088bd435a6d..782bde9d3f3c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Mar 20 15:36:00 UTC 2017
+# Mon Mar 20 16:18:31 UTC 2017
pkgbase = vte3-tilix
pkgdesc = Virtual Terminal Emulator widget for use with GTK3 with Fedora and Tilix patches
pkgver = 0.46.1+1.5.4
@@ -36,14 +36,18 @@ pkgname = vte3-tilix
depends = vte-tilix-common
provides = vte3=0.46.1
provides = vte3-notification=0.46.1-2
+ provides = vte3-terminix-git
conflicts = vte3
conflicts = vte3-notification
+ conflicts = vte3-terminix-git
pkgname = vte-tilix-common
pkgdesc = Common files used by vte and vte3
arch = any
provides = vte-common=0.46.1
provides = vte-notification-common=0.46.1-2
+ provides = vte-terminix-common-git
conflicts = vte-common
conflicts = vte-notification-common
+ conflicts = vte3-terminix-common-git
diff --git a/PKGBUILD b/PKGBUILD
index 4777d5b21aa0..24eaf3bee0b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -35,6 +35,7 @@ sha256sums=('8800cf8bc259704a12ad1853fb0eb43bfe3857af15242e6fb9f2c3fd95b3f5c6'
prepare() {
cd "vte-${_vtever}"
patch -p1 -i '../gperf-fix.patch'
+
echo '-> Making the patch-sets compatible'
sed -r -e 's/(\-\s*gpointer padding\[)16/\115/g' \
-e 's/(\+\s*gpointer padding\[)15/\114/g' \
@@ -61,8 +62,8 @@ build() {
package_vte3-tilix(){
depends=('gtk3' 'vte-tilix-common')
- provides=("vte3=${_vtever}" "vte3-notification=${_vtever}-2")
- conflicts=('vte3' 'vte3-notification')
+ provides=("vte3=${_vtever}" "vte3-notification=${_vtever}-2" 'vte3-terminix-git')
+ conflicts=('vte3' 'vte3-notification' 'vte3-terminix-git')
cd "vte-${_vtever}"
make DESTDIR="${pkgdir}" install
@@ -72,8 +73,8 @@ package_vte3-tilix(){
package_vte-tilix-common() {
pkgdesc='Common files used by vte and vte3'
arch=('any')
- provides=("vte-common=${_vtever}" "vte-notification-common=${_vtever}-2")
- conflicts=('vte-common' 'vte-notification-common')
+ provides=("vte-common=${_vtever}" "vte-notification-common=${_vtever}-2" 'vte-terminix-common-git')
+ conflicts=('vte-common' 'vte-notification-common' 'vte3-terminix-common-git')
cd "vte-${_vtever}"
install -Dm644 'src/vte.sh' "${pkgdir}/etc/profile.d/vte.sh"