summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavi da Silva Böger2017-04-24 14:09:01 -0300
committerDavi da Silva Böger2017-04-24 14:09:01 -0300
commit85624be1d14b6b9a32aee410b96cc4c1f1124da7 (patch)
tree4136c9deed1dbe1cf097998b94ea3383bb3abd8f
parentab18fffce01ee6a1bf98cb7e7df963a1055e7d32 (diff)
downloadaur-85624be1d14b6b9a32aee410b96cc4c1f1124da7.tar.gz
Update for version 0.48.2+2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
2 files changed, 19 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c4dfd72bef9f..37c1d2de3c31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Apr 24 16:29:59 UTC 2017
+# Mon Apr 24 17:08:41 UTC 2017
pkgbase = vte3-tilix
pkgdesc = Virtual Terminal Emulator widget for use with GTK3 with Fedora and Tilix patches
- pkgver = 0.48.2+1.5.6
+ pkgver = 0.48.2+2+g837cce9c+1.5.6
pkgrel = 1
url = https://github.com/gnunn1/tilix/tree/master/experimental/vte
arch = x86_64
@@ -18,12 +18,12 @@ pkgbase = vte3-tilix
depends = pcre2
depends = gnutls
options = !emptydirs
- source = https://download.gnome.org/sources/vte/0.48/vte-0.48.2.tar.xz
+ source = git://git.gnome.org/vte#commit=837cce9ced6bfe317cb97aeca171001da92cb3a1
source = vte291-command-notify-scroll-speed.patch::http://pkgs.fedoraproject.org/cgit/rpms/vte291.git/plain/vte291-command-notify-scroll-speed.patch?h=f26
source = add-zsh-notfication-support.patch
source = https://github.com/gnunn1/tilix/raw/1.5.6/experimental/vte/alternate-screen.patch
source = https://github.com/gnunn1/tilix/raw/1.5.6/experimental/vte/disable-bg-draw.patch
- sha256sums = c278b301edfe38b43baec1bccc86e225dacea5b670a96ca7ea55ca9a4b030690
+ sha256sums = SKIP
sha256sums = d32201c04d9f688195725bf76d7c618ae24178a2578da01c507d8216f082cf8e
sha256sums = 150a151404ca565f70259044661b2ef5cda43142ca677e7da324614eef8cf45a
sha256sums = 980b6bc75a30ec56fe70387784083b5c7ded79715b7a0611e1d4358ee27c4720
diff --git a/PKGBUILD b/PKGBUILD
index 4bf018c57809..3322d93ed52c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgbase='vte3-tilix'
pkgname=("${pkgbase}" 'vte-tilix-common')
_vtever=0.48.2
_tilixver=1.5.6
-pkgver=${_vtever}+${_tilixver}
+pkgver=0.48.2+2+g837cce9c+1.5.6
pkgrel=1
pkgdesc='Virtual Terminal Emulator widget for use with GTK3 with Fedora and Tilix patches'
arch=('x86_64')
@@ -17,21 +17,27 @@ options=('!emptydirs')
_frepourl='http://pkgs.fedoraproject.org/cgit/rpms/vte291.git'
_frepobranch='f26'
_fpatchfile='vte291-command-notify-scroll-speed.patch'
+_vtecommit=837cce9ced6bfe317cb97aeca171001da92cb3a1
source=(
- "https://download.gnome.org/sources/vte/${_vtever::4}/vte-${_vtever}.tar.xz"
+ "git://git.gnome.org/vte#commit=$_vtecommit"
"${_fpatchfile}::${_frepourl}/plain/${_fpatchfile}?h=${_frepobranch}"
'add-zsh-notfication-support.patch'
"https://github.com/gnunn1/tilix/raw/${_tilixver}/experimental/vte/alternate-screen.patch"
"https://github.com/gnunn1/tilix/raw/${_tilixver}/experimental/vte/disable-bg-draw.patch"
)
-sha256sums=('c278b301edfe38b43baec1bccc86e225dacea5b670a96ca7ea55ca9a4b030690'
+sha256sums=('SKIP'
'd32201c04d9f688195725bf76d7c618ae24178a2578da01c507d8216f082cf8e'
'150a151404ca565f70259044661b2ef5cda43142ca677e7da324614eef8cf45a'
'980b6bc75a30ec56fe70387784083b5c7ded79715b7a0611e1d4358ee27c4720'
'aa56313332850becb0b02aba1e05888ed978f7d8c006147679e2544cc0ca40cf')
+pkgver() {
+ cd vte
+
+ echo `git describe --tags | sed 's/-/+/g'`+$_tilixver
+}
prepare() {
- cd "vte-${_vtever}"
+ cd "vte"
echo '-> Making the patch-sets compatible'
sed -r -e 's/(\-\s*gpointer padding\[)16/\115/g' \
@@ -45,10 +51,12 @@ prepare() {
echo '-> Applying terminix patches'
patch -p1 -i '../alternate-screen.patch'
patch -p1 -i '../disable-bg-draw.patch'
+
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd "vte-${_vtever}"
+ cd "vte"
./configure --prefix='/usr' --sysconfdir='/etc' \
--libexecdir='/usr/lib/vte' \
--localstatedir='/var' --disable-static \
@@ -61,7 +69,7 @@ package_vte3-tilix(){
depends+=('vte-tilix-common')
provides=("vte3=${_vtever}" "vte3-notification=${_vtever}-2" 'vte3-terminix-git')
conflicts=('vte3' 'vte3-notification' 'vte3-terminix-git')
- cd "vte-${_vtever}"
+ cd "vte"
make DESTDIR="${pkgdir}" install
rm "${pkgdir}/etc/profile.d/vte.sh"
@@ -73,7 +81,7 @@ package_vte-tilix-common() {
arch=('any')
provides=("vte-common=${_vtever}" "vte-notification-common=${_vtever}-2" 'vte-terminix-common-git')
conflicts=('vte-common' 'vte-notification-common' 'vte3-terminix-common-git')
- cd "vte-${_vtever}"
+ cd "vte"
install -Dm644 'src/vte.sh' "${pkgdir}/etc/profile.d/vte.sh"
}