summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelipe Contreras2023-03-18 09:04:14 -0600
committerFelipe Contreras2023-03-18 09:38:57 -0600
commitbd27347bebdc0d6a4e41c7f4775342f9244c4358 (patch)
tree765a7abd6552eaa79a790739013791b8fa9a4441
parent0394baf1aed1069eb18a2302bde9e6965070a7d6 (diff)
downloadaur-bd27347bebdc0d6a4e41c7f4775342f9244c4358.tar.gz
Remove zsh-notification patch
The user can do this in a much better way.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
-rw-r--r--add-zsh-notfication-support.patch27
3 files changed, 0 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89bfc798a180..b7d2900f03d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -19,11 +19,9 @@ pkgbase = vte3-tilix
options = !emptydirs
source = git+https://gitlab.gnome.org/GNOME/vte.git#tag=0.70.3
source = vte291-cntnr-precmd-preexec-scroll.patch-de03576168f1ec4beeb7330239f4debf3234b842::https://src.fedoraproject.org/rpms/vte291/raw/de03576168f1ec4beeb7330239f4debf3234b842/f/vte291-cntnr-precmd-preexec-scroll.patch
- source = add-zsh-notfication-support.patch
source = alternate-screen.patch
sha256sums = SKIP
sha256sums = e5672a857c51a620ca5448da29e4ea5b0e319c2a54416a4ca615b0e0392e00a9
- sha256sums = 150a151404ca565f70259044661b2ef5cda43142ca677e7da324614eef8cf45a
sha256sums = 36fdf6a98c2be1b0c5b38a6116f160cdf0f270db688796ff1199234d64e49600
pkgname = vte3-tilix
diff --git a/PKGBUILD b/PKGBUILD
index 48dae84415de..dbce2d6b7ecd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,12 +25,10 @@ _vtetag=${pkgver}
source=(
"git+https://gitlab.gnome.org/GNOME/vte.git#tag=$_vtetag"
"${_fpatchfile}-${_fcommit}::${_frepourl}/raw/${_fcommit}/f/${_fpatchfile}"
- 'add-zsh-notfication-support.patch'
'alternate-screen.patch'
)
sha256sums=('SKIP'
'e5672a857c51a620ca5448da29e4ea5b0e319c2a54416a4ca615b0e0392e00a9'
- '150a151404ca565f70259044661b2ef5cda43142ca677e7da324614eef8cf45a'
'36fdf6a98c2be1b0c5b38a6116f160cdf0f270db688796ff1199234d64e49600')
prepare() {
@@ -38,7 +36,6 @@ prepare() {
echo '-> Applying Fedora patches'
patch -p1 -i "../${_fpatchfile}-${_fcommit}"
- #patch -p1 -i '../add-zsh-notfication-support.patch'
echo '-> Applying tilix patch'
patch -p1 -i "../alternate-screen.patch"
diff --git a/add-zsh-notfication-support.patch b/add-zsh-notfication-support.patch
deleted file mode 100644
index 31c3309466cb..000000000000
--- a/add-zsh-notfication-support.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 9e2914d67cdb8cbaf43b4371aac79b0870f843ae Mon Sep 17 00:00:00 2001
-From: Fernando Fernandez <fernando@softwareperonista.com.ar>
-Date: Fri, 3 Apr 2015 16:40:47 -0300
-Subject: [PATCH 1/1] add zsh notfication support
-
----
- src/vte.sh | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/src/vte.sh b/src/vte.sh
-index 2d211ca..6730aa3 100644
---- a/src/vte.sh
-+++ b/src/vte.sh
-@@ -46,7 +46,9 @@ __vte_ps1() {
- }
-
- __vte_osc7 () {
-- printf "\033]7;file://%s%s\007" "${HOSTNAME:-}" "$(__vte_urlencode "${PWD}")"
-+ last_command=$(history | tail -n1 - | cut -c8-)
-+
-+ printf "\033]777;notify;Command completed;%s\007\033]7;file://%s%s\007" "${last_command}" "${HOSTNAME:-}" "$(__vte_urlencode "${PWD}")"
- }
-
- __vte_prompt_command() {
---
-2.3.4
-