summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSigmund2015-07-09 00:22:52 +0100
committerSigmund2015-07-09 00:22:52 +0100
commitbe3f266d6eebf3894d69585bf656fd7c820e1511 (patch)
treed95710f757b80077eb330ba17d925b3a996e5dac
downloadaur-be3f266d6eebf3894d69585bf656fd7c820e1511.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD41
-rw-r--r--vtigercrm-customerportal.install12
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..512a86177ce1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vtigercrm-customerportal
+ pkgdesc = Customer portal for vTigerCRM
+ pkgver = 6.2.0
+ pkgrel = 1
+ url = https://www.vtiger.com/open-source
+ install = vtigercrm-customerportal.install
+ arch = any
+ license = custom
+ depends = vtigercrm
+ options = !strip
+ backup = srv/http/vtigercrm/portal/PortalConfig.php
+ source = http://downloads.sourceforge.net/project/vtigercrm/vtiger%20CRM%206.2.0/Add-ons/vtigercrm-customerportal-6.2.0.zip
+ md5sums = 1c8b98b9a8832c07694e5ce17230d2c9
+
+pkgname = vtigercrm-customerportal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dba5ead386be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Sigmund Vestergaard <sigmundv at gmail dot com>
+
+# Contributor: Phillip Smith <fukawi2@NO-SPAM.gmail.com>
+# http://github.com/fukawi2/aur-packages
+
+### I AM ONLY THE PACKAGER, NOT THE DEVELOPER
+### Please ask support questions about this software in one of:
+### 1) The AUR comments; OR
+### 2) Upstream forums/maillist etc; OR
+### 3) The ArchLinux forums
+### I do not always know enough about the software itself, or don't have the
+### time to promptly respond to direct emails.
+### If you have found a problem with the package/PKGBUILD (as opposed to
+### the software) then please do email me or post an AUR comment.
+
+pkgname=vtigercrm-customerportal
+pkgver=6.2.0
+pkgrel=1
+pkgdesc="Customer portal for vTigerCRM"
+arch=(any)
+url="https://www.vtiger.com/open-source"
+license=('custom')
+depends=('vtigercrm')
+backup=("srv/http/vtigercrm/portal/PortalConfig.php")
+options=('!strip')
+install=$pkgname.install
+source=("http://downloads.sourceforge.net/project/vtigercrm/vtiger%20CRM%20$pkgver/Add-ons/$pkgname-$pkgver.zip")
+md5sums=('1c8b98b9a8832c07694e5ce17230d2c9')
+
+package() {
+ _INSTDIR="${pkgdir}/srv/http/vtigercrm/portal"
+
+ # Install
+ msg "Installing files to $_INSTDIR then setting ownership and permissions"
+ install -dm755 $_INSTDIR
+ cp -ra $srcdir/vtigercrm-customerportal-$pkgver*/* $_INSTDIR
+ chown -R 33:33 $_INSTDIR
+ chmod -R u=rwX,go=rX $_INSTDIR
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/vtigercrm-customerportal.install b/vtigercrm-customerportal.install
new file mode 100644
index 000000000000..34173bc2e45b
--- /dev/null
+++ b/vtigercrm-customerportal.install
@@ -0,0 +1,12 @@
+post_install() {
+ echo "vtigercrm-customerportal: Please read /srv/http/vtigercrm/portal/INSTALLATION.txt before attempting to use the customer portal"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+op=$1
+shift
+
+$op $*