summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Mattern2016-05-23 19:19:06 +0200
committerPeter Mattern2016-05-24 01:34:15 +0200
commit9b76a5d2b4f4c8c32c58338990bfd968be0a3789 (patch)
tree0c6bc1579daca3b618fd3f7a43c81a401256a490
parentfca904ea220b3c75573d192fc51d0d6052811864 (diff)
downloadaur-9b76a5d2b4f4c8c32c58338990bfd968be0a3789.tar.gz
Fix dependencies
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD53
2 files changed, 43 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4fb088d4d965..1b7322e68459 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,27 @@
# Generated by mksrcinfo v8
-# Mon May 2 23:01:11 UTC 2016
+# Mon May 23 23:34:05 UTC 2016
pkgbase = vtk-git
pkgdesc = Open-source software system for image processing, 3D graphics, volume rendering and visualization
- pkgver = 7.0.0.1245.g99f5e84
- pkgrel = 2
+ pkgver = 7.0.0.1346.g2b54134
+ pkgrel = 1
url = http://www.vtk.org
arch = i686
arch = x86_64
license = BSD
makedepends = git
makedepends = cmake
- makedepends = hdf5
- makedepends = libjpeg-turbo
- makedepends = libtiff
makedepends = doxygen
+ makedepends = boost
makedepends = java-environment
- makedepends = python
- makedepends = tk
- depends = gl2ps
+ depends = jsoncpp
+ depends = libxt
+ depends = tk
+ depends = netcdf-cxx-legacy
+ depends = ffmpeg
+ depends = gdal
provides = vtk
conflicts = vtk
- conflicts =
- source = git+https://gitlab.kitware.com/vtk/vtk.git
+ source = vtk::git+https://github.com/Kitware/VTK.git
sha256sums = SKIP
pkgname = vtk-git
diff --git a/PKGBUILD b/PKGBUILD
index 6d12240d89f1..afe7f338f4ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,30 @@
# Maintainer: Peter Mattern <pmattern at arcor dot de>
+# Notes on dependencies
+# - GL2PS: Using the system library triggers FTBFS, see http://www.vtk.org/Bug/view.php?id=16083. Thus
+# the in-tree version is used instead. Shouldn't do any harm as the resulting libraries are named
+# libvtkgl2ps-<VTK version>.so*.
+# - Java: In order to discover all components needed the binary directory that's included in PATH by files
+# /etc/profile.d/jre.* of package java-runtime-common isn't sufficient but the JDK needs to be found.
+# Hence its path is set in JAVA_HOME.
+# - NetCDF: System library can still be accessed via the legacy C++ API only, see
+# http://www.vtk.org/Bug/view.php?id=15549.
+# - PROJ.4: System library doesn't get recognized, see http://www.vtk.org/Bug/view.php?id=14126. Same
+# solution as with GL2PS.
+
_pkgname=vtk
pkgname=$_pkgname-git
-pkgver=7.0.0.1245.g99f5e84
-pkgrel=2
+pkgver=7.0.0.1346.g2b54134
+pkgrel=1
pkgdesc='Open-source software system for image processing, 3D graphics, volume rendering and visualization'
arch=('i686' 'x86_64')
url='http://www.vtk.org'
license=('BSD')
-depends=('gl2ps')
-makedepends=('git' 'cmake' 'hdf5' 'libjpeg-turbo' 'libtiff' 'doxygen' 'java-environment' 'python' 'tk')
+depends=('jsoncpp' 'libxt' 'tk' 'netcdf-cxx-legacy' 'ffmpeg' 'gdal')
+makedepends=('git' 'cmake' 'doxygen' 'boost' 'java-environment')
provides=("$_pkgname")
-conflicts=("$_pkgname" "$_pkgname6")
-source=("git+https://gitlab.kitware.com/vtk/vtk.git")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+https://github.com/Kitware/VTK.git")
sha256sums=("SKIP")
pkgver() {
@@ -21,30 +33,26 @@ pkgver() {
}
build() {
- mkdir -p build ; cd build
-
- # Notes on CMake invocation
- # * Some Java components, in particular JNI, are discovered using $JAVA_HOME only.
- # * VTK doesn't get along with system-wide instances of recent NetCDF versions
- # (http://www.vtk.org/Bug/view.php?id=15549), hence using the rather outdated
- # (http://www.vtk.org/Bug/view.php?id=15123) version inside the VTK tree.
- # * Similarly, it doesn't seem to recognize system-wide instances of PROJ.4, neither
- # VCS checkouts nor release 4.9.2. Thus using the in-tree version for now, too.
-
export JAVA_HOME=/usr/lib/jvm/default
+ rm -Rf build && mkdir build && cd build
cmake $srcdir/$_pkgname \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DBUILD_SHARED_LIBS=ON \
- -DBUILD_TESTING=ON \
-DBUILD_DOCUMENTATION=ON \
+ -DBUILD_SHARED_LIBS=ON \
+ -DBUILD_TESTING=OFF \
-DVTK_LEGACY_REMOVE=ON \
-DVTK_USE_CXX11_FEATURES=ON \
+ -DVTK_USE_LARGE_DATA=ON \
-DVTK_USE_SYSTEM_LIBRARIES=ON \
- -DVTK_USE_SYSTEM_NETCDF=OFF \
+ -DVTK_USE_SYSTEM_GL2PS=OFF \
-DVTK_USE_SYSTEM_LIBPROJ4=OFF \
- -DVTK_USE_LARGE_DATA=ON \
- -DVTK_WRAP_PYTHON=ON \
+ -DVTK_USE_SYSTEM_XDMF3=OFF \
+ -DModule_vtkIOFFMPEG=ON \
+ -DModule_vtkIOGDAL=ON \
+ -DModule_vtkxdmf3=ON \
+ -DModule_vtkIOXdmf3=ON \
-DVTK_WRAP_JAVA=ON \
+ -DVTK_WRAP_PYTHON=ON \
-DVTK_WRAP_TCL=ON
make
}
@@ -52,5 +60,8 @@ build() {
package() {
cd build
make DESTDIR="$pkgdir" install
+ # Place XdmfConfig.cmake of internal XDMF at a more reasonable location
+ mkdir -p $pkgdir/usr/lib/cmake/XDMF && mv $pkgdir/usr/XdmfConfig.cmake $pkgdir/usr/lib/cmake/XDMF/
+ # Pack license
install -D -m644 $srcdir/$_pkgname/Copyright.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
}