summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaxonbeta2016-04-09 08:52:08 -0500
committerSaxonbeta2016-04-09 08:52:08 -0500
commitbe771d991bc6c341c8115063bc0a3c313a605012 (patch)
treee92a9c099b788add485d90c85e94908930dd6fec
parent6c8fb2c08b8db972600468e5aee1636a5d62fe35 (diff)
downloadaur-be771d991bc6c341c8115063bc0a3c313a605012.tar.gz
ffmpeg3 path and ninja compilation
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD31
-rw-r--r--ffmpeg3.patch62
3 files changed, 88 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8feedcd00be6..a26d87b176b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
+# Generated by mksrcinfo v8
+# Sat Apr 9 12:41:40 UTC 2016
pkgbase = vtk-qt4
pkgdesc = A software system for 3D computer graphics, image processing, and visualization. Linked against QT4
pkgver = 6.3.0
- pkgrel = 2
+ pkgrel = 3
url = http://www.vtk.org/
arch = i686
arch = x86_64
license = BSD
makedepends = boost
makedepends = cmake
+ makedepends = ninja
makedepends = java-environment
makedepends = doxygen
makedepends = gnuplot
@@ -22,12 +25,12 @@ pkgbase = vtk-qt4
makedepends = openmpi
makedepends = mariadb
makedepends = glew
- makedepends = gl2ps
depends = boost-libs
depends = ffmpeg
depends = qtwebkit
depends = lesstif
depends = jsoncpp
+ depends = gl2ps
optdepends = python2: python bindings
optdepends = java-runtime: java bindings
optdepends = tk: tcl bindings
@@ -43,7 +46,7 @@ pkgbase = vtk-qt4
optdepends = gl2ps
optdepends = gdal
optdepends = mariadb
- provides = vtk
+ provides = vtk=6.3.0
conflicts = vtk
options = staticlibs
source = http://www.vtk.org/files/release/6.3/VTK-6.3.0.tar.gz
@@ -52,12 +55,14 @@ pkgbase = vtk-qt4
source = remove-vtkxdmf3.patch
source = find-libxml2.patch
source = gdal2.patch
+ source = ffmpeg3.patch
sha1sums = 452efab1eedf6202f2d9a3362b5f69adfc44edda
sha1sums = 424b138c079a688cd8c52c43d12b54e2f2b06acf
sha1sums = 622a2bd314262961c6d96f2686f96224e8e31de3
sha1sums = f8c9270941707a296ff5e0ea3c73a1f0407c6f9b
sha1sums = baa807e4495219b3104b6245ca79b8f33ff299db
sha1sums = c60610e7c8cf0ad93d7c02cbf8a20fc415f59b3e
+ sha1sums = a78177f8dd6dedd9ad189fa12730ec53c7d02508
pkgname = vtk-qt4
diff --git a/PKGBUILD b/PKGBUILD
index 03d281283ace..d4c4c3134b4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,20 @@
-# $Id$
-# Maintainer: Ray Rashif <schiv@archlinux.org>
+# Maintainer: saxonbeta saxonbeta at _gmail____com
+# Contributor: Ray Rashif <schiv@archlinux.org>
# Contributor: Andrzej Giniewicz <gginiu@gmail.com>
# Contributor: Thomas Dziedzic < gostrc at gmail >
-# TODO: for Qt5 see FS#43007
-
pkgname=vtk-qt4
pkgver=6.3.0
_majorver=6.3
-pkgrel=2
+pkgrel=3
pkgdesc='A software system for 3D computer graphics, image processing, and visualization. Linked against QT4'
arch=('i686' 'x86_64')
url='http://www.vtk.org/'
license=('BSD')
-provides=(vtk)
+provides=(vtk=6.3.0)
conflicts=(vtk)
-depends=('boost-libs' 'ffmpeg' 'qtwebkit' 'lesstif' 'jsoncpp')
-makedepends=('boost' 'cmake' 'java-environment' 'doxygen' 'gnuplot' 'tk' 'wget' 'python2-matplotlib' 'python2-twisted' 'python2-mpi4py' 'python2-autobahn' 'unixodbc' 'gdal' 'openmpi' 'mariadb' 'glew' 'gl2ps')
+depends=('boost-libs' 'ffmpeg' 'qtwebkit' 'lesstif' 'jsoncpp' 'gl2ps')
+makedepends=('boost' 'cmake' 'ninja' 'java-environment' 'doxygen' 'gnuplot' 'tk' 'wget' 'python2-matplotlib' 'python2-twisted' 'python2-mpi4py' 'python2-autobahn' 'unixodbc' 'gdal' 'openmpi' 'mariadb' 'glew' )
optdepends=('python2: python bindings'
'java-runtime: java bindings'
'tk: tcl bindings'
@@ -37,14 +35,16 @@ source=("http://www.vtk.org/files/release/${_majorver}/VTK-${pkgver}.tar.gz"
"http://www.vtk.org/files/release/${_majorver}/VTKLargeData-${pkgver}.tar.gz"
remove-vtkxdmf3.patch
find-libxml2.patch
- gdal2.patch)
+ gdal2.patch
+ ffmpeg3.patch)
options=(staticlibs)
sha1sums=('452efab1eedf6202f2d9a3362b5f69adfc44edda'
'424b138c079a688cd8c52c43d12b54e2f2b06acf'
'622a2bd314262961c6d96f2686f96224e8e31de3'
'f8c9270941707a296ff5e0ea3c73a1f0407c6f9b'
'baa807e4495219b3104b6245ca79b8f33ff299db'
- 'c60610e7c8cf0ad93d7c02cbf8a20fc415f59b3e')
+ 'c60610e7c8cf0ad93d7c02cbf8a20fc415f59b3e'
+ 'a78177f8dd6dedd9ad189fa12730ec53c7d02508')
prepare() {
cd "${srcdir}"/VTK-$pkgver
@@ -53,6 +53,7 @@ prepare() {
patch -Np1 -i "${srcdir}"/remove-vtkxdmf3.patch
patch -Np1 -i "${srcdir}"/find-libxml2.patch
patch -Np1 -i "${srcdir}"/gdal2.patch
+ patch -Np1 -i "${srcdir}"/ffmpeg3.patch
sed -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
-e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
@@ -102,15 +103,19 @@ build() {
${cmake_system_flags} \
${cmake_system_python_flags} \
-DCMAKE_BUILD_TYPE=Release \
- "${srcdir}/VTK-$pkgver"
+ "${srcdir}/VTK-$pkgver" \
+ -GNinja
- make
+ ninja
}
package() {
cd "${srcdir}/build"
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" ninja install
+
+ #mkdir -p "$pkgdir/etc/ld.so.conf.d/"
+ #printf "%s\n" "/opt/vtk6/lib" > "$pkgdir/etc/ld.so.conf.d/$pkgname.conf"
# Move the vtk.jar to the arch-specific location
install -dv "${pkgdir}/usr/share/java/vtk"
diff --git a/ffmpeg3.patch b/ffmpeg3.patch
new file mode 100644
index 000000000000..bf9100ce351c
--- /dev/null
+++ b/ffmpeg3.patch
@@ -0,0 +1,62 @@
+diff --git a/IO/FFMPEG/vtkFFMPEGWriter.cxx b/IO/FFMPEG/vtkFFMPEGWriter.cxx
+index d3fd421..294b421 100644
+--- a/IO/FFMPEG/vtkFFMPEGWriter.cxx
++++ b/IO/FFMPEG/vtkFFMPEGWriter.cxx
+@@ -191,11 +191,11 @@ int vtkFFMPEGWriterInternal::Start()
+ c->height = this->Dim[1];
+ if (this->Writer->GetCompression())
+ {
+- c->pix_fmt = PIX_FMT_YUVJ422P;
++ c->pix_fmt = AV_PIX_FMT_YUVJ422P;
+ }
+ else
+ {
+- c->pix_fmt = PIX_FMT_BGR24;
++ c->pix_fmt = AV_PIX_FMT_BGR24;
+ }
+
+ //to do playback at actual recorded rate, this will need more work see also below
+@@ -274,13 +274,13 @@ int vtkFFMPEGWriterInternal::Start()
+ #endif
+
+ //for the output of the writer's input...
+- this->rgbInput = avcodec_alloc_frame();
++ this->rgbInput = av_frame_alloc();
+ if (!this->rgbInput)
+ {
+ vtkGenericWarningMacro (<< "Could not make rgbInput avframe." );
+ return 0;
+ }
+- int RGBsize = avpicture_get_size(PIX_FMT_RGB24, c->width, c->height);
++ int RGBsize = avpicture_get_size(AV_PIX_FMT_RGB24, c->width, c->height);
+ unsigned char *rgb = (unsigned char *)av_malloc(sizeof(unsigned char) * RGBsize);
+ if (!rgb)
+ {
+@@ -288,10 +288,10 @@ int vtkFFMPEGWriterInternal::Start()
+ return 0;
+ }
+ //The rgb buffer should get deleted when this->rgbInput is.
+- avpicture_fill((AVPicture *)this->rgbInput, rgb, PIX_FMT_RGB24, c->width, c->height);
++ avpicture_fill((AVPicture *)this->rgbInput, rgb, AV_PIX_FMT_RGB24, c->width, c->height);
+
+ //and for the output to the codec's input.
+- this->yuvOutput = avcodec_alloc_frame();
++ this->yuvOutput = av_frame_alloc();
+ if (!this->yuvOutput)
+ {
+ vtkGenericWarningMacro (<< "Could not make yuvOutput avframe." );
+@@ -349,12 +349,12 @@ int vtkFFMPEGWriterInternal::Write(vtkImageData *id)
+ //convert that to YUV for input to the codec
+ #ifdef VTK_FFMPEG_HAS_IMG_CONVERT
+ img_convert((AVPicture *)this->yuvOutput, cc->pix_fmt,
+- (AVPicture *)this->rgbInput, PIX_FMT_RGB24,
++ (AVPicture *)this->rgbInput, AV_PIX_FMT_RGB24,
+ cc->width, cc->height);
+ #else
+ //convert that to YUV for input to the codec
+ SwsContext* convert_ctx = sws_getContext(
+- cc->width, cc->height, PIX_FMT_RGB24,
++ cc->width, cc->height, AV_PIX_FMT_RGB24,
+ cc->width, cc->height, cc->pix_fmt,
+ SWS_BICUBIC, NULL, NULL, NULL);
+