summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel Souza Franco2018-03-30 01:09:04 +0200
committerGabriel Souza Franco2018-03-30 01:09:04 +0200
commit76d94ebe790ac237c8933dac2cb9e03b6346ea27 (patch)
tree5f8f829910a0b9d5b577cdbf5cc8a0055019f5bc
parentb369dceea513b5c27349b10fc7631963656c55b5 (diff)
downloadaur-76d94ebe790ac237c8933dac2cb9e03b6346ea27.tar.gz
Fix source location and compatibility with JDK9
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD12
3 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2765ba74701a..81b62de4d3b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,3 @@
-# Generated by mksrcinfo v8
-# Thu Mar 22 09:47:22 UTC 2018
pkgbase = vtk6
pkgdesc = A software system for 3D computer graphics, image processing, and visualization. Legacy 6.3 version.
pkgver = 6.3.0
@@ -49,8 +47,8 @@ pkgbase = vtk6
source = https://www.vtk.org/files/release/6.3/VTK-6.3.0.tar.gz
source = https://www.vtk.org/files/release/6.3/VTKData-6.3.0.tar.gz
source = https://www.vtk.org/files/release/6.3/VTKLargeData-6.3.0.tar.gz
- source = remove-vtkxdmf3.patch::https://github.com/nschloe/VTK/commit/a98527dfe9ce23beebf386fab07caef99b911ede.patch
- source = find-libxml2.patch::https://github.com/nschloe/VTK/commit/6216f98a7124e12a2c1cefd113347f94b51f3c51.patch
+ source = remove-vtkxdmf3.patch::https://github.com/Kitware/VTK/pull/21/commits/a98527dfe9ce23beebf386fab07caef99b911ede.patch
+ source = find-libxml2.patch::https://github.com/Kitware/VTK/pull/21/commits/6216f98a7124e12a2c1cefd113347f94b51f3c51.patch
source = ffmpeg3_compat.patch
source = gdal2.patch
source = gcc6.patch
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..818527c01f3d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+VTK*.tar.gz
+remove-vtkxdmf3.patch
+find-libxml2.patch
+*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
index fb217367b8e0..7c486c9266d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Mainteriner: Florian Pritz <bluewind@xinu.at>
+# Maintainer: Gabriel Souza Franco <Z2FicmllbGZyYW5jb3NvdXphQGdtYWlsLmNvbQ==>
+# Contributor: Florian Pritz <bluewind@xinu.at>
# Contributor: Ray Rashif <schiv@archlinux.org>
# Contributor: Andrzej Giniewicz <gginiu@gmail.com>
# Contributor: Thomas Dziedzic < gostrc at gmail >
@@ -30,10 +31,9 @@ optdepends=('python2: python bindings'
source=("https://www.vtk.org/files/release/${_majorver}/VTK-${pkgver}.tar.gz"
"https://www.vtk.org/files/release/${_majorver}/VTKData-${pkgver}.tar.gz"
"https://www.vtk.org/files/release/${_majorver}/VTKLargeData-${pkgver}.tar.gz"
- # https://github.com/Kitware/VTK/pull/21
- remove-vtkxdmf3.patch::https://github.com/nschloe/VTK/commit/a98527dfe9ce23beebf386fab07caef99b911ede.patch
- find-libxml2.patch::https://github.com/nschloe/VTK/commit/6216f98a7124e12a2c1cefd113347f94b51f3c51.patch
- ffmpeg3_compat.patch
+ remove-vtkxdmf3.patch::https://github.com/Kitware/VTK/pull/21/commits/a98527dfe9ce23beebf386fab07caef99b911ede.patch
+ find-libxml2.patch::https://github.com/Kitware/VTK/pull/21/commits/6216f98a7124e12a2c1cefd113347f94b51f3c51.patch
+ ffmpeg3_compat.patch
gdal2.patch
gcc6.patch)
options=(staticlibs)
@@ -100,6 +100,8 @@ build() {
-DVTK_WRAP_JAVA:BOOL=ON \
-DVTK_WRAP_PYTHON:BOOL=ON \
-DVTK_WRAP_TCL:BOOL=ON \
+ -DVTK_JAVA_SOURCE_VERSION="1.7" \
+ -DVTK_JAVA_TARGET_VERSION="1.7" \
-DCMAKE_CXX_FLAGS="-D__STDC_CONSTANT_MACROS" \
-DVTK_CUSTOM_LIBRARY_SUFFIX="" \
-DVTK_INSTALL_INCLUDE_DIR:PATH=include/vtk \