summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2021-04-28 19:51:02 +0200
committerGrey Christoforo2021-04-28 19:51:02 +0200
commit8b4858f03b21f7a0d77d5d0f9c768ed068d08bbf (patch)
treea3aff23f8bdb44083a88eda14eaba7833c91fea0
downloadaur-8b4858f03b21f7a0d77d5d0f9c768ed068d08bbf.tar.gz
initial commit
-rw-r--r--.SRCINFO53
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD120
-rw-r--r--freetype.patch19
4 files changed, 196 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..202823888589
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,53 @@
+pkgbase = vtk9-java
+ pkgdesc = A software system for 3D computer graphics, image processing, and visualization. version 9 with java bindings
+ pkgver = 9.0.1
+ pkgrel = 1
+ url = http://vtk.org
+ arch = x86_64
+ license = BSD
+ makedepends = java-runtime-openjdk=8
+ makedepends = cmake
+ makedepends = ninja
+ depends = gdal
+ depends = freetype2
+ depends = jsoncpp
+ depends = libharu
+ depends = libjpeg-turbo
+ depends = libogg
+ depends = libpng
+ depends = libtheora
+ depends = libtiff
+ depends = libxml2
+ depends = lzip
+ depends = python
+ depends = sqlite
+ depends = zlib
+ depends = ospray
+ depends = openimagedenoise
+ depends = libxt
+ depends = double-conversion
+ depends = glew
+ depends = eigen
+ depends = expat
+ depends = lz4
+ depends = hdf5
+ depends = proj
+ depends = utf8cpp
+ depends = pugixml
+ depends = netcdf
+ depends = pegtl
+ depends = gl2ps
+ depends = ffmpeg
+ depends = libtheora
+ depends = java-runtime
+ provides = vtk
+ conflicts = vtk
+ conflicts = vtk9
+ conflicts = vtk9-fix
+ source = vtk9-java-9.0.1.tar.gz::https://gitlab.kitware.com/vtk/vtk/-/archive/v9.0.1/vtk-v9.0.1.tar.gz
+ source = freetype.patch
+ sha256sums = 15c269946a8a8ed578bbd28a59672c251089185d582cd1268658908bf414e017
+ sha256sums = aa2daca929f4bc75809dcfe959b1bf6f8b81450a8c29892c73420711823d1438
+
+pkgname = vtk9-java
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3463d4e8edb3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.pkg.tar.zst
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..87043ff1c304
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,120 @@
+# $Id$
+# Maintainer: Grey Christoforo <first name at last name dot net>
+
+pkgname=vtk9-java
+pkgver=9.0.1
+pkgrel=1
+pkgdesc='A software system for 3D computer graphics, image processing, and visualization. version 9 with java bindings'
+arch=('x86_64')
+url="http://vtk.org"
+license=('BSD')
+depends=(
+gdal
+freetype2
+jsoncpp
+libharu
+libjpeg-turbo
+libogg
+libpng
+libtheora
+libtiff
+libxml2
+lzip
+python
+sqlite
+zlib
+ospray
+openimagedenoise
+libxt
+double-conversion
+glew
+eigen
+expat
+lz4
+hdf5
+proj
+utf8cpp
+pugixml
+netcdf
+pegtl
+gl2ps
+ffmpeg
+libtheora
+java-runtime
+)
+
+makedepends=(
+'java-runtime-openjdk=8'
+cmake
+ninja
+)
+
+provides=(vtk)
+conflicts=(vtk vtk9 vtk9-fix)
+source=("${pkgname}-${pkgver}.tar.gz::https://gitlab.kitware.com/vtk/vtk/-/archive/v${pkgver}/vtk-v${pkgver}.tar.gz"
+ "freetype.patch")
+sha256sums=('15c269946a8a8ed578bbd28a59672c251089185d582cd1268658908bf414e017'
+ 'aa2daca929f4bc75809dcfe959b1bf6f8b81450a8c29892c73420711823d1438')
+
+prepare() {
+ cd vtk-v${pkgver}
+ patch -p1 < "${srcdir}/freetype.patch"
+
+ # https://gitlab.kitware.com/vtk/vtk/-/issues/18048
+ curl https://src.fedoraproject.org/rpms/vtk/raw/rawhide/f/vtk-AllValues.patch | patch -p1
+
+ curl https://src.fedoraproject.org/rpms/vtk/raw/rawhide/f/vtk-libharu.patch | patch -p1
+
+ # https://gitlab.kitware.com/vtk/vtk/-/issues/18130
+ curl https://gitlab.kitware.com/vtk/vtk/-/commit/29bfddf455fb909ce32ede0b8cddcb55e0bb794d.patch | patch -p1
+ curl https://gitlab.kitware.com/vtk/vtk/-/commit/0325638832e35c8c8c6fc96e2c1d887aeea3dd43.patch | patch -p1
+}
+
+# -D VTK_BUILD_ALL_MODULES=ON
+build() {
+ export JAVA_HOME=/usr/lib/jvm/default
+ local _tkver=$(echo 'puts $tcl_version' | tclsh)
+ cmake -B build_dir -S vtk-v${pkgver} \
+ -W no-dev \
+ -G Ninja \
+ -D CMAKE_BUILD_TYPE=Release \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ -D CMAKE_INSTALL_LIBDIR=lib \
+ -D CMAKE_INSTALL_LICENSEDIR:PATH=share/licenses/vtk \
+ -D BUILD_SHARED_LIBS=ON \
+ -D VTK_USE_FFMPEG_ENCODER=ON \
+ -D VTK_CUSTOM_LIBRARY_SUFFIX="" \
+ -D VTK_INSTALL_INCLUDE_DIR=include/vtk \
+ -D VTK_INSTALL_PACKAGE_DIR=lib/cmake/vtk \
+ -D VTK_VERSIONED_INSTALL=OFF \
+ -D VTK_PYTHON_VERSION=3 \
+ -D VTK_WRAP_PYTHON=ON \
+ -D VTK_MODULE_USE_EXTERNAL_VTK_pegtl=OFF \
+ -D VTK_GROUP_ENABLE_Imaging=YES \
+ -D VTK_GROUP_ENABLE_Qt=YES \
+ -D VTK_GROUP_ENABLE_Rendering=YES \
+ -D VTK_GROUP_ENABLE_StandAlone=YES \
+ -D VTK_GROUP_ENABLE_Views=YES \
+ -D VTK_GROUP_ENABLE_Web=YES \
+ -D VTK_MODULE_USE_EXTERNAL_VTK_libharu=NO \
+ -D VTK_MODULE_ENABLE_VTK_CommonArchive=YES \
+ -D VTK_MODULE_ENABLE_VTK_DomainsMicroscopy=NO \
+ -D VTK_MODULE_ENABLE_VTK_GeovisGDAL=YES \
+ -D VTK_MODULE_ENABLE_VTK_ImagingOpenGL2=YES \
+ -D VTK_MODULE_ENABLE_VTK_InfovisBoost=YES \
+ -D VTK_MODULE_ENABLE_VTK_InfovisBoostGraphAlgorithms=YES \
+ -D VTK_MODULE_ENABLE_VTK_IOMySQL=YES \
+ -D VTK_USE_EXTERNAL=ON \
+ -D VTK_USE_TK=ON \
+ -D VTK_USE_OGGTHEORA_ENCODER=ON \
+ -D VTK_INSTALL_TCL_DIR=/usr/lib/tcl${_tkver}/vtk/ \
+ -D VTK_WRAP_JAVA=ON
+
+ cmake --build build_dir
+}
+
+package() {
+ cd vtk-v${pkgver}
+ local _destdir=/
+ DESTDIR="${pkgdir}${_destdir}" cmake --build ../build_dir -- install
+}
diff --git a/freetype.patch b/freetype.patch
new file mode 100644
index 000000000000..9ad7d277d490
--- /dev/null
+++ b/freetype.patch
@@ -0,0 +1,19 @@
+--- a/ThirdParty/freetype/vtk_freetype.h.in
++++ b/ThirdParty/freetype/vtk_freetype.h.in
+@@ -20,6 +20,15 @@
+
+ #ifdef VTK_USE_SYSTEM_FREETYPE
+ # include <ft2build.h>
++/* FT_CALLBACK_DEF no longer exported since freetype-2.10.3 */
++/* has been moved to <freetype/internal/compiler-macros.h> */
++# ifndef FT_CALLBACK_DEF
++# ifdef __cplusplus
++# define FT_CALLBACK_DEF( x ) extern "C" x
++# else
++# define FT_CALLBACK_DEF( x ) static x
++# endif
++# endif /* FT_CALLBACK_DEF */
+ #else
+ # include <vtkfreetype/include/ft2build.h>
+ #endif
+