summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKirill Isakov2023-08-19 19:48:26 +0600
committerKirill Isakov2023-08-19 19:48:26 +0600
commit351889deabb0d6ecdbe2d22259c409ef53fef035 (patch)
tree9751b3c32c1b63f1a1b2ac1a35f01eca39d2e4ce
parent0d83b0b0dee6fde49edb5bebffbcf278a5ac280e (diff)
downloadaur-351889deabb0d6ecdbe2d22259c409ef53fef035.tar.gz
upgpkg: vtsls 0.1.20-2
-rw-r--r--.SRCINFO6
-rw-r--r--LICENSE45
-rw-r--r--PKGBUILD12
3 files changed, 57 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb7b2b2945b9..4093a2e119eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = vtsls
pkgdesc = LSP wrapper for the TypeScript extension from Visual Studio Code
pkgver = 0.1.20
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/yioneko/vtsls
arch = any
- license = unknown
+ license = MIT
makedepends = npm
depends = nodejs
noextract = vtsls-0.1.20.tgz
source = vtsls-0.1.20.tgz::https://registry.npmjs.org/@vtsls/language-server/-/language-server-0.1.20.tgz
+ source = LICENSE
sha256sums = fe7d05db68aff984285471e14dd3c657d0c8ab2fd2fcb016bd089bceee865250
+ sha256sums = 9bb7826149a1b0c343eeec81e74375c5d840af39016af5d41a49d71b0342b3d4
pkgname = vtsls
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..8c9834d89654
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,45 @@
+MIT License
+
+Copyright (c) 2023 yioneko
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+ AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+ SOFTWARE.
+
+## Some of the code is copied or derived from VSCode[https://github.com/microsoft/vscode], which is subject to the following copyright notice:
+
+MIT License
+
+Copyright (c) 2015 - present Microsoft Corporation
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 15607bbf2d51..ebaa1e8c0a2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,24 @@
pkgname=vtsls
pkgver=0.1.20
-pkgrel=1
+pkgrel=2
pkgdesc='LSP wrapper for the TypeScript extension from Visual Studio Code'
url='https://github.com/yioneko/vtsls'
-license=(unknown)
+license=(MIT)
arch=(any)
depends=(nodejs)
makedepends=(npm)
-source=("$pkgname-$pkgver.tgz::https://registry.npmjs.org/@vtsls/language-server/-/language-server-$pkgver.tgz")
+source=("$pkgname-$pkgver.tgz::https://registry.npmjs.org/@vtsls/language-server/-/language-server-$pkgver.tgz"
+ LICENSE)
noextract=("$pkgname-$pkgver.tgz")
-sha256sums=('fe7d05db68aff984285471e14dd3c657d0c8ab2fd2fcb016bd089bceee865250')
+sha256sums=('fe7d05db68aff984285471e14dd3c657d0c8ab2fd2fcb016bd089bceee865250'
+ '9bb7826149a1b0c343eeec81e74375c5d840af39016af5d41a49d71b0342b3d4')
package() {
npm install --global \
--cache "$srcdir/npm-cache" \
--prefix "$pkgdir/usr" \
"$srcdir/$pkgname-$pkgver.tgz"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}