summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKirill Isakov2023-08-26 12:45:11 +0600
committerKirill Isakov2023-08-26 12:45:11 +0600
commitc4860fa09565a3827f88f5535049e9a3732d909b (patch)
treeeb6ef93b03fce38c1d46c6face8f278990d85506
parent351889deabb0d6ecdbe2d22259c409ef53fef035 (diff)
downloadaur-c4860fa09565a3827f88f5535049e9a3732d909b.tar.gz
upgpkg: vtsls 0.1.21-1
upstream release
-rw-r--r--.SRCINFO12
-rw-r--r--LICENSE45
-rw-r--r--PKGBUILD13
3 files changed, 11 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4093a2e119eb..711af34f704c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = vtsls
pkgdesc = LSP wrapper for the TypeScript extension from Visual Studio Code
- pkgver = 0.1.20
- pkgrel = 2
+ pkgver = 0.1.21
+ pkgrel = 1
url = https://github.com/yioneko/vtsls
arch = any
license = MIT
makedepends = npm
depends = nodejs
- noextract = vtsls-0.1.20.tgz
- source = vtsls-0.1.20.tgz::https://registry.npmjs.org/@vtsls/language-server/-/language-server-0.1.20.tgz
- source = LICENSE
- sha256sums = fe7d05db68aff984285471e14dd3c657d0c8ab2fd2fcb016bd089bceee865250
- sha256sums = 9bb7826149a1b0c343eeec81e74375c5d840af39016af5d41a49d71b0342b3d4
+ noextract = vtsls-0.1.21.tgz
+ source = vtsls-0.1.21.tgz::https://registry.npmjs.org/@vtsls/language-server/-/language-server-0.1.21.tgz
+ b2sums = 0a73d003652f95201c23ef5af7b8299f7b641182c25e9cb14d653cee84d4017f121865e30e89adaf5c2ab745b17c20020e07389d17fe0d7f736a0b402575d9dd
pkgname = vtsls
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 8c9834d89654..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,45 +0,0 @@
-MIT License
-
-Copyright (c) 2023 yioneko
-
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in all
-copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
- FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
- AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
- LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
- OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
- SOFTWARE.
-
-## Some of the code is copied or derived from VSCode[https://github.com/microsoft/vscode], which is subject to the following copyright notice:
-
-MIT License
-
-Copyright (c) 2015 - present Microsoft Corporation
-
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in all
-copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index ebaa1e8c0a2f..6140632930c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,17 @@
# Maintainer: tarball <bootctl@gmail.com>
pkgname=vtsls
-pkgver=0.1.20
-pkgrel=2
+pkgver=0.1.21
+pkgrel=1
pkgdesc='LSP wrapper for the TypeScript extension from Visual Studio Code'
url='https://github.com/yioneko/vtsls'
license=(MIT)
arch=(any)
depends=(nodejs)
makedepends=(npm)
-source=("$pkgname-$pkgver.tgz::https://registry.npmjs.org/@vtsls/language-server/-/language-server-$pkgver.tgz"
- LICENSE)
+source=("$pkgname-$pkgver.tgz::https://registry.npmjs.org/@vtsls/language-server/-/language-server-$pkgver.tgz")
noextract=("$pkgname-$pkgver.tgz")
-sha256sums=('fe7d05db68aff984285471e14dd3c657d0c8ab2fd2fcb016bd089bceee865250'
- '9bb7826149a1b0c343eeec81e74375c5d840af39016af5d41a49d71b0342b3d4')
+b2sums=('0a73d003652f95201c23ef5af7b8299f7b641182c25e9cb14d653cee84d4017f121865e30e89adaf5c2ab745b17c20020e07389d17fe0d7f736a0b402575d9dd')
package() {
npm install --global \
@@ -21,5 +19,6 @@ package() {
--prefix "$pkgdir/usr" \
"$srcdir/$pkgname-$pkgver.tgz"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$pkgdir/usr/lib/node_modules/@vtsls/language-server/LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}