summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomasz Maciej Nowak2020-05-30 02:03:37 +0200
committerTomasz Maciej Nowak2020-05-30 15:31:29 +0200
commitc6529c3654164af8672d4e7e27eb10f92e612d1f (patch)
tree607b13c3439eff654fd70e46484dd30640dc8a31
parentbbf06bcaf7581d091becf03d2b985c6e426ee7e5 (diff)
downloadaur-c6529c3654164af8672d4e7e27eb10f92e612d1f.tar.gz
upgpkg: vtunerc-dkms 1.4-10
fix compilation error with 5.6 kernel and warning with 5.3 kernel
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--dkms.conf10
-rw-r--r--kernel-5.3.patch11
-rw-r--r--kernel-5.6.patch29
5 files changed, 60 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97bd008612ae..1c800607b50f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vtunerc-dkms
pkgdesc = Kernel module to create virtual DVB devices
pkgver = 1.4
- pkgrel = 9
+ pkgrel = 10
url = http://code.google.com/p/vtuner
arch = x86_64
arch = i686
@@ -21,7 +21,9 @@ pkgbase = vtunerc-dkms
source = kernel-4.15.patch
source = kernel-4.16.patch
source = kernel-4.19.patch
+ source = kernel-5.3.patch
source = kernel-5.4.patch
+ source = kernel-5.6.patch
source = replace-Z-with-z.patch
source = tweaks.patch
source = 93-vtunerc.rules
@@ -33,11 +35,13 @@ pkgbase = vtunerc-dkms
sha256sums = ae701414fee3c96fc8a2a5f705c534d4933485e6b28fab94d912f63395d184b7
sha256sums = 2e8a410409bba057d61ae8b1005a13cb1f359caa562b846e37b5db0448d62395
sha256sums = c7bc232a5743a0fc4e80f9f72c6e27c2d82444cc307b1835873f63ae10c7efae
+ sha256sums = 7b0834bf8580aeb40ebedd4766368045d63e03af4d860cbbe4df8ebe2925123f
sha256sums = b93588eb487fae99c8a74fe1d84f6140d1d51450b2e69d8d9efe16af9a0d8a06
+ sha256sums = 8b410a9aa7b34c0c3b14d7cff9d0e8376673c483eb65d449de6270680a385dab
sha256sums = 64cfd76c471ab3634711bc2e30dee90ae6498815b970014fe68adcbd50ad3741
sha256sums = 723631658d0a630538f5ab4f87afd69b551a636a31ddb05e6ab13c0a9e5244a1
sha256sums = 4b2d860cac8c8bab2d8fa79760d4405bef6fd042f4e78b680d25d1a5ebcbf83d
- sha256sums = e387a4aaaac5ce56e5c865f94108a44c8a1c34b739597a7d23ce5b904812ff0c
+ sha256sums = 0fe4422a04439adff2635dcd77ba4f17fe663cce0481ae9b046cf665632f5a68
pkgname = vtunerc-dkms
diff --git a/PKGBUILD b/PKGBUILD
index aee5f6058899..6b40c2509dc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname='vtunerc-dkms'
pkgdesc='Kernel module to create virtual DVB devices'
pkgver=1.4
-pkgrel=9
+pkgrel=10
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url='http://code.google.com/p/vtuner'
license=('GPL2')
@@ -18,7 +18,9 @@ source=("vtuner.linux-driver-rel${pkgver}.tar.gz::https://github.com/lecotex/vtu
'kernel-4.15.patch'
'kernel-4.16.patch'
'kernel-4.19.patch'
+ 'kernel-5.3.patch'
'kernel-5.4.patch'
+ 'kernel-5.6.patch'
'replace-Z-with-z.patch'
'tweaks.patch'
'93-vtunerc.rules'
@@ -30,11 +32,13 @@ sha256sums=('c6ba0cfd808e3f8473a5ea25d4ac2871b826edc62de5f3624c0bd812aad63bc1'
'ae701414fee3c96fc8a2a5f705c534d4933485e6b28fab94d912f63395d184b7'
'2e8a410409bba057d61ae8b1005a13cb1f359caa562b846e37b5db0448d62395'
'c7bc232a5743a0fc4e80f9f72c6e27c2d82444cc307b1835873f63ae10c7efae'
+ '7b0834bf8580aeb40ebedd4766368045d63e03af4d860cbbe4df8ebe2925123f'
'b93588eb487fae99c8a74fe1d84f6140d1d51450b2e69d8d9efe16af9a0d8a06'
+ '8b410a9aa7b34c0c3b14d7cff9d0e8376673c483eb65d449de6270680a385dab'
'64cfd76c471ab3634711bc2e30dee90ae6498815b970014fe68adcbd50ad3741'
'723631658d0a630538f5ab4f87afd69b551a636a31ddb05e6ab13c0a9e5244a1'
'4b2d860cac8c8bab2d8fa79760d4405bef6fd042f4e78b680d25d1a5ebcbf83d'
- 'e387a4aaaac5ce56e5c865f94108a44c8a1c34b739597a7d23ce5b904812ff0c')
+ '0fe4422a04439adff2635dcd77ba4f17fe663cce0481ae9b046cf665632f5a68')
package() {
install -dm755 ${pkgdir}/usr/src/vtunerc-${pkgver}/patches
diff --git a/dkms.conf b/dkms.conf
index 7ec7b563a405..e0723e37c5ef 100644
--- a/dkms.conf
+++ b/dkms.conf
@@ -28,5 +28,11 @@ PATCH_MATCH[6]="(4\.1[6-9](.*)|4\.[2-9][0-9]\.(.*)|[5-9].*)"
PATCH[7]="kernel-4.19.patch"
PATCH_MATCH[7]="(4\.19(.*)|[5-9].*)"
-PATCH[8]="kernel-5.4.patch"
-PATCH_MATCH[8]="(5\.[4-9](.*)|5\.[0-9][0-9]\.(.*)|[6-9].*)"
+PATCH[8]="kernel-5.3.patch"
+PATCH_MATCH[8]="(5\.[3-9](.*)|5\.[0-9][0-9]\.(.*)|[6-9].*)"
+
+PATCH[9]="kernel-5.4.patch"
+PATCH_MATCH[9]="(5\.[4-9](.*)|5\.[0-9][0-9]\.(.*)|[6-9].*)"
+
+PATCH[10]="kernel-5.6.patch"
+PATCH_MATCH[10]="(5\.[6-9](.*)|5\.[0-9][0-9]\.(.*)|[6-9].*)"
diff --git a/kernel-5.3.patch b/kernel-5.3.patch
new file mode 100644
index 000000000000..cacbb6e5dc03
--- /dev/null
+++ b/kernel-5.3.patch
@@ -0,0 +1,11 @@
+https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit?id=a035d552a93bb9ef6048733bb9f2a0dc857ff869
+--- a/vtunerc_ctrldev.c
++++ b/vtunerc_ctrldev.c
+@@ -205,6 +205,7 @@ static long vtunerc_ctrldev_ioctl(struct file *file, unsigned int cmd,
+ }
+ /* follow into old code for compatibility */
+
++ fallthrough;
+ case VTUNER_SET_TYPE:
+ dprintk(ctx, "msg VTUNER_SET_TYPE\n");
+ if (strcasecmp((char *)arg, "DVB-S") == 0) {
diff --git a/kernel-5.6.patch b/kernel-5.6.patch
new file mode 100644
index 000000000000..1c789e39be2f
--- /dev/null
+++ b/kernel-5.6.patch
@@ -0,0 +1,29 @@
+https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=d56c0d45f0e27f814e87a1676b6bdccccbc252e9
+--- a/vtunerc_main.c
++++ b/vtunerc_main.c
+@@ -213,11 +213,11 @@ static int vtuner_proc_release(struct inode *inode, struct file *file)
+ return ret;
+ }
+
+-static const struct file_operations vtunerc_read_proc_fops = {
+- .open = vtunerc_proc_open,
+- .read = seq_read,
+- .llseek = seq_lseek,
+- .release = vtuner_proc_release,
++static const struct proc_ops vtunerc_read_proc_ops = {
++ .proc_open = vtunerc_proc_open,
++ .proc_read = seq_read,
++ .proc_lseek = seq_lseek,
++ .proc_release = vtuner_proc_release,
+ };
+
+ #endif
+@@ -333,7 +333,7 @@ static int __init vtunerc_init(void)
+ ctx->idx);
+ ctx->procname = my_strdup(procfilename);
+ if (proc_create_data(ctx->procname, 0, NULL,
+- &vtunerc_read_proc_fops,
++ &vtunerc_read_proc_ops,
+ ctx) == 0)
+ printk(KERN_WARNING
+ "vtunerc%d: Unable to register '%s' proc file\n",