summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDouglas McFadzean2015-08-28 23:01:30 +0100
committerDouglas McFadzean2015-08-28 23:01:30 +0100
commitb4b81942c3947ea4a0e7a11e913e4d0022dc6c47 (patch)
treea3b5cb2467d7e9ecb8dfca7f8c9b7b00eb38026a
downloadaur-b4b81942c3947ea4a0e7a11e913e4d0022dc6c47.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--LICENSE1
-rw-r--r--PKGBUILD30
-rw-r--r--vuescan.desktop8
-rwxr-xr-xvuescan.sh3
5 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d11001995f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = vuescan-bin
+ pkgdesc = A powerful proprietary scanning tool developed by Hamrick Software
+ pkgver = 9.5
+ pkgrel = 1
+ url = http://www.hamrick.com/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = gtk2
+ depends = libsm
+ depends = libusb-compat
+ options = !strip
+ source = LICENSE
+ source = vuescan.sh
+ source = vuescan.desktop
+ md5sums = e4d56c48bc5ac80b83630238a7ab658d
+ md5sums = da269332a033a101a4509d34f1552c10
+ md5sums = 30e56e810df66e0d8425563903bcfa83
+ md5sums = SKIP
+
+pkgname = vuescan-bin
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..2d30659f1f2c
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1 @@
+For VueScan Warranty see http://www.hamrick.com/vuescan/vuescan.htm#warranty
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fcf32228fc49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: ninian <mcfadzean.org.uk ta linux>
+
+pkgname=vuescan-bin
+_pgmname=vuescan
+_srcname=VueScan
+pkgver=9.5
+pkgrel=1
+pkgdesc="A powerful proprietary scanning tool developed by Hamrick Software"
+arch=('i686' 'x86_64')
+url="http://www.hamrick.com/"
+license=('custom')
+depends=('gtk2' 'libsm' 'libusb-compat')
+# Following required to accept registration details
+options=(!strip)
+source=(LICENSE vuescan.sh vuescan.desktop)
+md5sums=('e4d56c48bc5ac80b83630238a7ab658d'
+ 'da269332a033a101a4509d34f1552c10'
+ '30e56e810df66e0d8425563903bcfa83')
+[ "${CARCH}" == 'i686' ] && source+=(http://www.hamrick.com/files/vuex3295.tgz)
+[ "${CARCH}" == 'x86_64' ] && source+=(http://www.hamrick.com/files/vuex6495.tgz)
+md5sums+=('SKIP')
+
+package() {
+ cd "$srcdir"
+ install -dm755 "$pkgdir/opt/$_pgmname"
+ cp -rp "$_srcname"/* "$pkgdir/opt/$_pgmname/"
+ install -Dm755 "$srcdir/$_pgmname.sh" "$pkgdir/usr/bin/$_pgmname"
+ install -Dm644 "$srcdir/$_pgmname.desktop" "$pkgdir/usr/share/applications/$_pgmname.desktop"
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$_pgmname/LICENSE"
+}
diff --git a/vuescan.desktop b/vuescan.desktop
new file mode 100644
index 000000000000..e0b17326fa9d
--- /dev/null
+++ b/vuescan.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=VueScan
+Comment=A powerful proprietary scanning tool
+Type=Application
+Categories=Application;Graphics
+Terminal=false
+Icon=scanner
+Exec=vuescan
diff --git a/vuescan.sh b/vuescan.sh
new file mode 100755
index 000000000000..9933bdfe353e
--- /dev/null
+++ b/vuescan.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /opt/vuescan
+exec ./vuescan "$@"