summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCorey Stephan2020-02-15 14:25:29 -0600
committerCorey Stephan2020-02-15 14:25:29 -0600
commit6c3f725b610511b5d82cae5a40e0d9175180f22f (patch)
treebbff5487224fcf13caec244fa53e96c6188f1a52
downloadaur-6c3f725b610511b5d82cae5a40e0d9175180f22f.tar.gz
Initial upload.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD25
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84546292cb79
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = vul-git
+ pkgdesc = Latin Vulgate Bible in the terminal
+ pkgver = r12.996c670
+ pkgrel = 1
+ url = https://github.com/LukeSmithxyz/vul
+ arch = any
+ license = custom:Public Domain
+ depends = bash
+ source = vul::git+https://github.com/LukeSmithxyz/vul
+ md5sums = SKIP
+
+pkgname = vul-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0366a45c826f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Corey Stephan <corey.stephan@marquette.edu>
+pkgname=vul-git
+pkgver=r2.2f031ac
+pkgrel=1
+pkgdesc="Latin Vulgate Bible in the terminal"
+arch=(any)
+url="https://github.com/LukeSmithxyz/vul"
+license=('custom:Public Domain')
+depends=(bash)
+source=('vul::git+https://github.com/LukeSmithxyz/vul')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -Dm755 vul $pkgdir/usr/bin/vul
+}