summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2019-11-29 11:45:48 +0000
committerEric Engestrom2019-11-29 11:45:48 +0000
commit4975c6327b476f8d924eb7ef27e8b5dc491da5c0 (patch)
treec4f6f803340c6be5a3ba3acf0197c5b76fb20a07
parentdc4fbcddf993d4f8c820a803f24ef46aee0897e8 (diff)
downloadaur-4975c6327b476f8d924eb7ef27e8b5dc491da5c0.tar.gz
submodule hack: let makepkg deal with the git clone
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 033481bac6f7..76ca8e56875b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vulkan-caps-viewer
pkgdesc = Vulkan Hardware Capability Viewer
pkgver = 2.03
- pkgrel = 1
+ pkgrel = 2
url = http://vulkan.gpuinfo.org/
arch = x86_64
license = GPL2
@@ -11,7 +11,9 @@ pkgbase = vulkan-caps-viewer
depends = qt5-base
depends = qt5-x11extras
source = https://github.com/SaschaWillems/VulkanCapsViewer/archive/2.03.tar.gz
+ source = https://github.com/KhronosGroup/Vulkan-Headers
sha1sums = 2cecf6fa42a21060171c974af607a79ad490162c
+ sha1sums = SKIP
pkgname = vulkan-caps-viewer
diff --git a/PKGBUILD b/PKGBUILD
index ff3ca4f9578a..50e2ae771614 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,15 @@
pkgname=vulkan-caps-viewer
pkgver=2.03
-pkgrel=1
+pkgrel=2
pkgdesc='Vulkan Hardware Capability Viewer'
url='http://vulkan.gpuinfo.org/'
arch=('x86_64')
license=('GPL2')
-source=("https://github.com/SaschaWillems/VulkanCapsViewer/archive/$pkgver.tar.gz")
-sha1sums=('2cecf6fa42a21060171c974af607a79ad490162c')
+source=("https://github.com/SaschaWillems/VulkanCapsViewer/archive/$pkgver.tar.gz"
+ "git+https://github.com/KhronosGroup/Vulkan-Headers")
+sha1sums=('2cecf6fa42a21060171c974af607a79ad490162c'
+ 'SKIP')
makedepends=(qt5-base)
depends=(vulkan-icd-loader qt5-base qt5-x11extras)
@@ -24,8 +26,7 @@ prepare() {
fi
#HACK: github doesn't package submodules...
- git clone --depth 1 https://github.com/KhronosGroup/Vulkan-Headers \
- VulkanCapsViewer-$pkgver/Vulkan-Headers
+ cp -r Vulkan-Headers/include VulkanCapsViewer-$pkgver/Vulkan-Headers/
#HACK: the last commit of 2.02 explicitely breaks the build; probably wasn't intended to be pushed out
sed 's#"/Vulkan-Headers/include"#"./Vulkan-Headers/include"#' \