summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2019-06-07 17:00:02 +0100
committerEric Engestrom2019-06-07 17:00:05 +0100
commit78b9b5b0742c18d9655ae6c99e1e8c34daa4c7c4 (patch)
tree5c6f33441d34d0396ec318f5061c52710b75397f
parentb7d20d9881a1915ff201a8f283811df5dc575f1e (diff)
downloadaur-78b9b5b0742c18d9655ae6c99e1e8c34daa4c7c4.tar.gz
convert package to build from versioned source
see vulkan-caps-viewer-bin for what this package used to provide
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD43
2 files changed, 33 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e8847e5589b..53db81d3143e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,15 +5,14 @@ pkgbase = vulkan-caps-viewer
url = http://vulkan.gpuinfo.org/
arch = x86_64
license = GPL2
+ makedepends = qt5-base
depends = vulkan-icd-loader
depends = qt5-base
depends = qt5-x11extras
+ source = https://github.com/SaschaWillems/VulkanCapsViewer/archive/1.92.tar.gz
source = vulkan-caps-viewer.desktop
- source = android_icon_256.png
+ sha1sums = 685a80eafd573a37f466149c35b4d0959f465847
sha1sums = 7ccdb4b4487b43bb428c32994092c00ca14f594a
- sha1sums = 96c802c82c45626f3b6bdbb846d0f1f7e67ab28e
- source_x86_64 = http://vulkan.gpuinfo.org/downloads/vulkancapsviewer_1_92_linux64.tar.gz
- sha1sums_x86_64 = e1fed300f8fc270ca661beccbd0a7bd7ebb8eea1
pkgname = vulkan-caps-viewer
diff --git a/PKGBUILD b/PKGBUILD
index 8b2b850ea623..7a086bbccdab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,22 +7,39 @@ pkgdesc='Vulkan Hardware Capability Viewer'
url='http://vulkan.gpuinfo.org/'
arch=('x86_64')
license=('GPL2')
-source=('vulkan-caps-viewer.desktop'
- 'android_icon_256.png')
-sha1sums=('7ccdb4b4487b43bb428c32994092c00ca14f594a'
- '96c802c82c45626f3b6bdbb846d0f1f7e67ab28e')
-sha1sums_x86_64=('e1fed300f8fc270ca661beccbd0a7bd7ebb8eea1')
-source_x86_64=("http://vulkan.gpuinfo.org/downloads/vulkancapsviewer_${pkgver//./_}_linux64.tar.gz")
-depends=('vulkan-icd-loader' 'qt5-base' 'qt5-x11extras')
+source=("https://github.com/SaschaWillems/VulkanCapsViewer/archive/$pkgver.tar.gz"
+ 'vulkan-caps-viewer.desktop')
+sha1sums=('685a80eafd573a37f466149c35b4d0959f465847'
+ '7ccdb4b4487b43bb428c32994092c00ca14f594a')
+makedepends=(qt5-base)
+depends=(vulkan-icd-loader qt5-base qt5-x11extras)
-package() {
- cd "${srcdir}"
+prepare() {
+ if [ -d build ]
+ then
+ msg2 "Build dir already exist; performing an incremental build"
+ msg2 "If you want to perform a clean build, please delete $(realpath build)"
+ return
+ fi
+
+ mkdir build
+ cd build
+ export PREFIX="$pkgdir"
+ qmake ../VulkanCapsViewer-$pkgver/vulkanCapsViewer.pro
+}
+build() {
+ make -C build
+}
+
+package() {
# App
- install -dm755 "${pkgdir}"/usr/bin
- install -m755 vulkanCapsViewer "${pkgdir}"/usr/bin
+ install -dm755 "$pkgdir"/usr/bin
+ install -m755 build/Win32/Release/vulkanCapsViewer "$pkgdir"/usr/bin
# Desktop shortcut
- install -Dm644 vulkan-caps-viewer.desktop "${pkgdir}"/usr/share/applications/vulkan-caps-viewer.desktop
- install -Dm644 android_icon_256.png "${pkgdir}"/usr/share/icons/hicolor/256x256/apps/vulkanCapsViewer.png
+ install -Dm644 vulkan-caps-viewer.desktop \
+ "$pkgdir"/usr/share/applications/vulkan-caps-viewer.desktop
+ install -Dm644 VulkanCapsViewer-$pkgver/gfx/android_icon_256.png \
+ "$pkgdir"/usr/share/icons/hicolor/256x256/apps/vulkanCapsViewer.png
}